none
unattended installation - error in log and post install task RRS feed

  • Question

  • Hello,

    I have two questions:

    1. After unattended installation, I can see in log file such error message: 

    WARNING: 2016/08/11 13:07:33:546::[976] MSI(INFO): 'ExecNetFx:
    Error: The specified file or directory "C:\GAC_MSIL\" is invalid.'

    Why setup process looks for this path?

    2. After unattended installation setup process runs "Post Install" task which is run PSConfigGUI.exe, is it possible to skip it?

    2016/08/11 13:07:42:092::[4516] Post install command running.  Executing command: C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\BIN\PSConfigUI.exe, args: 
    2016/08/11 13:07:42:092::[4516] Starting C:\Program Files\Common Files\Microsoft Shared\Web Server Extensions\16\BIN\PSConfigUI.exe 

    Thursday, August 11, 2016 11:27 AM

All replies

  • Hello Przlwo,

    For your questions:

    1. During the installation, the installer will copies some assemblies to the path.

    2. Installing Sharepoint is not complete till you run the Post Setup Configuration Wizard which integrates the server to an existing SharePoint farm or creates a new farm.

    Post Setup Configuration Wizard is responsible for making all the database changes involved as part of the install.

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Friday, August 19, 2016 2:32 AM
    Moderator
  • Hi Chris yuri,

    Thank you for reply.

    1. Why in my case the path is "C:\GAC_MSIL\"? I guess this should be a constant value, same for every installation. Do I have any possibility to influence on the path?

    Friday, August 19, 2016 9:31 AM
  • Hi Przlwo,

    It seems you cannot change it. The path is specified by default.

    This is the path you can change.

    Best Regards,

    CY


    TechNet Community Support
    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Tuesday, August 23, 2016 9:59 AM
    Moderator
  • Hi CY,

    This is what I already know, the question is why this prereq installer (downloaded from MSDN site) has got wrong path hardcoded? Are you able to perform such installation and check logs for similar error message?

    Tuesday, August 23, 2016 11:19 AM
  • hello

    maybe you can open a ticket for this.

    Wednesday, August 31, 2016 9:47 AM