locked
Deleting and Re-Creating the Exchange Connector SCSM 2012 RRS feed

  • Question

  • We are setting up a test environment for SCSM 2012. I am trying to create the SendEmail workflows like in our production environment, but the Exchange Connector will not allow me to get the properties window to edit the settings. When trying to delete it so I can recreate it - I am unable to. Also tried making a second one which throws an error as well. Stopping services doesn't allow us to get into the console at all so I am not sure how to proceed.
    Wednesday, February 6, 2013 8:32 PM

Answers

  • We discarded the test environment and started over - this time it works.
    • Marked as answer by AudreyPaige Wednesday, February 20, 2013 4:40 PM
    Wednesday, February 20, 2013 4:40 PM

All replies

  • Hi

    Does you try to this from a console on you computer or console on the SCSM management server. The .dll for the exchange connector is not copied to local pc console.

    Regards

    Jon

    • Proposed as answer by Jon Berg Crayon Thursday, February 7, 2013 1:59 PM
    • Unproposed as answer by AudreyPaige Thursday, February 7, 2013 7:49 PM
    Thursday, February 7, 2013 1:59 PM
  • Could not do it in either place. Were finally able to delete it after some intensive Powershell work by my network counterpart. Now when we try to recreate the Exchange Connector, we get this error and cannot recreate the connector.

    Microsoft.EnterpriseManagement.Common.ObjectNotFoundException: An object of class ManagementPackClass with ID 333337a6-78bf-8c72-3794-2f048b84ef91 was not found.
       at Microsoft.EnterpriseManagement.Configuration.TypeSpaceCache.Get[T](Guid id)
       at Microsoft.EnterpriseManagement.EntityTypeManagement.GetClass(Guid id)
       at Microsoft.EnterpriseManagement.Configuration.ManagementPackDatabaseReader.GetClass(ManagementPackElementReference`1 reference)
       at Microsoft.EnterpriseManagement.Configuration.ManagementPack.Microsoft.EnterpriseManagement.Configuration.IO.IManagementPackSearch.GetClass(ManagementPackElementReference`1 reference)
       at Microsoft.EnterpriseManagement.Configuration.ManagementPack.GetClass(String name)
       at Microsoft.SystemCenter.ExchangeConnector.InboxConnectorWizardData.CreateConnectorInstance()
       at Microsoft.SystemCenter.ExchangeConnector.InboxConnectorWizardData.AcceptChanges(WizardMode wizardMode)

    • Edited by AudreyPaige Thursday, February 7, 2013 7:51 PM
    Thursday, February 7, 2013 7:50 PM
  • We were able to recreate it - and get to the properties - but now it will not go into running state. I don't know what is going on... Need help... :(
    Monday, February 11, 2013 3:45 PM
  • We discarded the test environment and started over - this time it works.
    • Marked as answer by AudreyPaige Wednesday, February 20, 2013 4:40 PM
    Wednesday, February 20, 2013 4:40 PM