locked
Search programs and files not workig RRS feed

  • Question

  • It used to work, but stopped, and now I can't get it to work.

    When you search for wordpad for example, it returns a list of:
    Programs
    If you click on Programs
    is says

    These files can't be opened
    Your internet security settings prevented on or more files from being opened

    I don't think this is an ie issue, but I reset IE, and my start menu all defaults

    I also rebuilt my index.

    I also tried to add the c:\users\allusers\startmenu to my list of searched files, but can't.  When you try to add it from the advanced section of the index utility, you can only select my name, default and public - the all users is not listed.

    I really used to love this feature!!

    Sunday, November 1, 2009 8:44 PM

Answers

  • do you have the following registry key?
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{EF87B4CB-F2CE-4785-8658-4CA6C63E38C6}\TopViews\{00000000-0000-0000-0000-000000000000}

    If so, try deleting it, and restart explorer.

    Hope this helps,
    Alexander Sklar | Software Development Engineer 2
    Windows Sustaining Engineering - Client Platform Development Team
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Steve Garf Tuesday, December 8, 2009 1:57 AM
    • Marked as answer by Vivian Xing Tuesday, December 8, 2009 6:09 AM
    Thursday, November 5, 2009 9:24 AM
    Answerer

All replies

  • Hi,

     

    You can try creating a new account:

     

    Create a new user account

    ====================

    1. Click the Start Button, type User Accounts in the start search pane and press Enter.

    2. Click Manage user accounts. 

    3. Click Create a new account, and type the name.

    4. Choose account type as Computer administrator.

    5. Click Create Account.

    6. Log off and log on with the new account.

    If the issue persists, you can collect Screenshot of the error and upload it to the http://skydrive.live.com/ using your Live ID and I will check it:

     

    Screenshot

    ========

    1. If the error message appears, press the Print Screen key (PrtScn) on your keyboard.

    2. Click the "Start" menu, type "mspaint" in the Search Bar and Press Enter.

    3. In the Paint program, click the "Edit" menu, click "Paste", click the "File" menu, and click "Save".

    4. The "Save As" dialogue box will appear. Type a file name in the "File name:" box, for example: "screenshot".

    5. Make sure "JPEG (*.JPG;*.JPEG;*.JPE;*.JFIF)" is selected in the "Save as type" box, click Desktop on the left pane and then click "Save".

     


    Vivian Xing - MSFT
    Monday, November 2, 2009 9:12 AM
  • Creating a new user did work.  But, it would have been nice to hear some ideas on how to fix the "old" user.

    I am not the first person to have this happen to them.  And, it is kind of a hassle to move my files, documents, preferences from one profile to the other.  So, if you come across this again (and you will) please try and spend a little time to figure out what the issue is.

    thank you.
    Tuesday, November 3, 2009 10:21 PM
  • Hi,

     

    I would like to confirm if any Parent Control setting is used or if any Group Policy is applied.

     

    If so, please disable it. In addition, if any security program is used, please temporarily disable it.

     

    You can also try the following steps:

     

    Enable the Include all network paths (UNCs) setting in Internet Options applet

    =============================================

    1. Click Start, type INETCPL.CPL into Start Search box and press Enter.

    2. Select the Security tab, Local intranet

    3. Click Sites button

    4. Uncheck “Automatically detect intranet network”

    4. Put a checkmark near “Include all network paths (UNCs)”

     

    If it persists, you can try Transferring user profile, I have listed the steps as below:

     

    Transfer user profile

    ===============

    1. Log on as the new user account

    2. Click the Start menu, and click Computer.

    3. Click the Organize button on the left top corner and choose Folder and Search Options.

    4. Under View tab, check the "Show hidden files and folders" box and click OK to save settings.

    5. Navigate to the C:\Users\(old user name) folder.

     

    5. Copy all files and folders in the C:\Users\(old user name) folder to the C:\Users\(new user name) folder.

     

    Restart your computer with the new user account. If everything is working, you can now delete the old account.


    Vivian Xing - MSFT
    • Marked as answer by Vivian Xing Friday, November 6, 2009 7:18 AM
    • Unmarked as answer by Vivian Xing Tuesday, December 8, 2009 6:09 AM
    Wednesday, November 4, 2009 7:00 AM
  • do you have the following registry key?
    HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer\FolderTypes\{EF87B4CB-F2CE-4785-8658-4CA6C63E38C6}\TopViews\{00000000-0000-0000-0000-000000000000}

    If so, try deleting it, and restart explorer.

    Hope this helps,
    Alexander Sklar | Software Development Engineer 2
    Windows Sustaining Engineering - Client Platform Development Team
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.
    • Proposed as answer by Steve Garf Tuesday, December 8, 2009 1:57 AM
    • Marked as answer by Vivian Xing Tuesday, December 8, 2009 6:09 AM
    Thursday, November 5, 2009 9:24 AM
    Answerer
  • I already created a new profile and deleted the old one.

    It would have been nice to hear these options first...


    Parental control was NOT on.  I did disable all antivirus software.  It did not help. 

    I did not try deleting the registry key, but unless this key is unique to a particular user profile, it was not that as a new profile works.


    Friday, November 6, 2009 5:34 PM
  • Yes, the key is unique to the currently logged on user

    Hope this helps,
    Alexander Sklar | Software Development Engineer 2
    Windows Sustaining Engineering - Client Platform Development Team
    http://blogs.msdn.com/asklar
    This posting is provided "AS IS" with no warranties, and confers no rights.
    Friday, November 6, 2009 8:27 PM
    Answerer
  • I had this happen again, and this solution worked.

    Now the question is where/how does this registry entry get in.

    With this solution, it is not a big deal to correct it, but I would like to know what is start it in the first place.
    Tuesday, December 22, 2009 8:44 AM
  • I didn't have the registry entry mentioned in my HKCU. I fixed the problem by resetting all my IE settings. It fixed it for every profile on the computer.
    Friday, March 12, 2010 8:01 PM
  • Deleting the key works for me. Thanks!
    Friday, July 2, 2010 9:31 PM
  • Finally a fix!  thank you!  This has been bugging me for several months now.  It just started one day.

    what in the world causes this?

    Wednesday, October 20, 2010 11:07 PM
  • Alexandar's fix worked for me straight away - thanks

    Friday, April 8, 2011 1:26 AM
  • This worked for me
    Monday, July 9, 2012 11:35 PM
  • My search was broken for a while until I saw this post and deleted the registry key.  Thanks!
    Monday, April 1, 2013 7:11 PM
  • THANK YOU!!!!!
    Sunday, June 23, 2013 3:11 AM