locked
Permission Problems RRS feed

  • Question

  •  

    I can't seem to get Vista Home Premium with SP1 to take my permission settings.

     

    I am configured as an Administrator on the PC, my wife and kids are not.

     

    I do not want my kids to be able to use Yahoo Instant Messenger. So I changed permissions on c:\Program Files\Yahoo!\Messenger folder. I remove "everyone" user group from permissions and give my wife AND administrators full control. I deselect "inherit permissions from this object's parent" and select "replace all existing inheritable permissions on all descendants...". But my wife doesn't get permissions on c:\Program Files\Yahoo!\Messenger\YahooMessenger.exe. I was able to fix this by removing "Administrators" and "Everyone" and specifying myself and my wife as having full control of the folder.

     

    So I got by the first problem... but it caused me some concern. Then...

     

    I put all of our family pictures in c:\users\Public\Public Pictures. But I do not trust my wife and kids not to delete files, or edit them and mess them up. So I do not want them to have permissions. So I modify "everyone" so they have read and execute permissions only. I deselect "inherit permissions from this object's parent" and select "replace all existing inheritable permissions on all descendants..."

     

    I log in as my wife, open a file in Windows Photo Gallery. But before I do, I confirm that the permissions are set as I would expect them. I use Photo Gallery to remove some red eye, expecting to get an error that she cannot modify the file. The file is changed and my wife is now "owner" of the file and now has permissions.

     

     

    Wednesday, March 26, 2008 3:53 AM

Answers

  • Hi

     

    You can set full control permission on %programfiles%\yahoo! folder with you and your wife account. And ensure the account has been set to apply for this folder, subfolder and files.

     

    Hope this helps.

    Monday, March 31, 2008 10:46 AM

All replies

  • Hi,

     

    We do not recommend to save the files or photes in public folder to restrict permission. Because user account will be added into other build-in groups.You can create a new folder and put all the picture into it. Then, go to properties-> sercurity ->uncheck "inheritable permissions from this object's parent" and then remove the authenticated users. At the same time, ensure the accounts of your wife and child have read-only permission.

     

    After that, try to log on with your wife account to see if it works at this time.

     

    Hope this helps.

     

    Friday, March 28, 2008 9:19 AM
  •  

    The problem here is permissions. There is something definitely wrong there. Trying to modify permissions and security settings just refuse to take sometimes. How can you explain the problems trying to set access on program folders? Vista has attempted to go completely secure. It's a pain, but I understand the reasoning. But what good is all these headaches we have to put up with now if you can't even set security properly?

     

    For example, on another Vista PC (running ultimate). I go into Network and Sharing Center and try to turn off "password protect sharing" so I can setup a shared directory for everyone in the house to drop files to be backed up. I change the setting, click apply and one of those UAC dialogs pop up. I click continue and the setting goes back to on. HUH? No dialog to explain why the setting change was reverted.

     

    Saturday, March 29, 2008 5:41 PM
  • Hi

     

    You can set full control permission on %programfiles%\yahoo! folder with you and your wife account. And ensure the account has been set to apply for this folder, subfolder and files.

     

    Hope this helps.

    Monday, March 31, 2008 10:46 AM
  • That's what I said. But that's wrong.

     

    I should be able to set "Administrators" AND my wife as having permissions to this folder, but I cannot. I have to remove "Administrators" and specify myself explicitly in order to make it work. If I ever setup another administrator account, I will have to go in and add them as having permissions. I shouldn't have to do that.

     

    There are a lot of weird things in Vista were settings do not take, or they just arbitrarily change. The permission problem  is one example. Another is that I cannot setup my explorer views to show file details for each view. I specify in my folder options that I do not want to remember each views settings. I click "reset all folders", then I setup my view how I'd like it. I like every folder to be details view. Then I click "apply to all folders" and immediately I start navigating and I'm getting thumbnails when I should not be and every view appears to be different.

     

    Today, I log in and for some reason "select all" is disabled in my explorer. I want to select 72 files from one directory and copy to another, but I cannot select more than one file at a time. Holding down shift or ctrl does nothing. I select "edit" from the menu and "select all" is disabled. I did not change anything between yesterday and today.

     

     

     

    Wednesday, April 16, 2008 12:54 PM