Start Dates of tasks not changing based on Predecessors RRS feed

  • Question

  • OK, I know this has been asked a bunch of times but I can't find a recent one and I have tried the suggestions with no luck.

    I just got project 2010 at work and for some reason none of the tasks are changing based on the predecessors unless I delete the start and end date and the predecessor info and then retype the predecessor info. Then it works. Here's what I've checked so far:


    -my tasks have a 0% complete

    -I have not entered start or end date manually on any of them

    -they are start as soon as possible

    -I went into  file options schedule and calculate project after each edit is on

    -My project is standalone (no related projects linked)

    -I started my project fresh (didn't try to reuse an old project with old info, just started typing tasks and linking them fresh)


    So as an example, I have task A (create project plan) and task B (signoff project plan) is FS+1day

    I change the duration of task A from 5 to 10days because it is taking longer than expected. 

    To me task B start should move but it stays the same.

    When I delete the start date and end date and the predecessor, then retype the predecessor, the new correct start and end dates pop in.

    This problem is through the whole project so tasks all the way along look like they are starting before they really should.



    Friday, March 21, 2014 11:52 PM

All replies

  • WpgMom --

    From your description, it sounds totally like you are using Manually Scheduled tasks, which is not what you should be using in your project.  If you look at the Gantt bars in the Gantt Chart view of your project, if the Gantt bars are a turquoise color, you are using Manually Scheduled tasks, and that would be the reason that the dates do not automatically calculate for you.  If this is the case, click the Select All button to select every task in the project.  In the Tasks section of your Task ribbon, click the Auto Schedule button.  From this point forward, your project schedule will automatically recalculate every time you make any kind of schedule edit.

    Also, in the lower left corner of the Microsoft Project application window, you will probably see a button that says New Tasks: Manually Scheduled.  Click this button and select the Auto Scheduled option.

    To avoid all of these problems in all future projects, click File > Options.  In the Project Options dialog, click the Schedule tab.  In the Scheduling Options for This Project section, click the pick list where you see the name of your project and select the All New Projects item on the pick list.  Click the New Tasks Created pick list and select the Auto Scheduled option.  Click the OK button.

    Hope this helps.

    Dale A. Howard [MVP]

    Saturday, March 22, 2014 2:26 AM
  • WpgMom,

    You just switched to Project 2010. It sounds like your project is in manual schedule mode. Go to File/Options/Schedule group and look at the option for "New Tasks Created". Change that to Auto scheduled.

    Hope this helps.


    Saturday, March 22, 2014 2:31 AM
  • This was helpful information!  Thanks!
    Monday, May 8, 2017 10:18 PM
  • It's been awhile since I used MS Project and I found this thread and additional suggestion very helpful - thanks!
    Monday, May 8, 2017 10:19 PM
  • I have someone I'm helping that's using 365 that says these items were tried and it still doesn't help him.  They've done a Project repair but still nothing.  Other than trying to uninstall/reinstall, is there anything further you may suggest?
    Tuesday, May 9, 2017 8:27 PM
  • I am also still having this issue with 2010.  All of my tasks are Auto Schedule, and new tasks are auto schedule, but do not obey the links at all.  I had one task that completed early yesterday, but the successor didn't pull in at all.  It is a finish-start with a week lag, but still says that it won't start for 4 weeks even though it's predecessor is 100% complete with an end date of yesterday.  And if I manually change the start date to today, it ignores the 1 week lag and just moves it to today.
    Wednesday, May 10, 2017 10:31 PM
  • Larry-M,

    Take a look at the following Wiki article and see if that helps. If not, post back and we'll take a deeper look at your file.


    Thursday, May 11, 2017 1:34 AM
  • I see this is an old post, but I had this same problem and almost pulled out my last bit of hair.  What I found was that at some time - I don't know when or why ...or how - there were dates entered as my Actual Start Dates for my tasks.  I had not started any but one task so far, so I cleared those entries resulting in an "NA" shown in that column (I had to add the Actual Start column to see it).  After I did that, things worked as normal.

    Hope this helps, if not you then others with this problem.

    Monday, August 7, 2017 9:39 PM
  • I see this is an old post, but I had this same problem and almost pulled out my last bit of hair.  What I found was that at some time - I don't know when or why ...or how - there were dates entered as my Actual Start Dates for my tasks.  I had not started any but one task so far, so I cleared those entries resulting in an "NA" shown in that column (I had to add the Actual Start column to see it).  After I did that, things worked as normal.

    Hope this helps, if not you then others with this problem.

    Jason you are a legend! I have been pulling my hair out trying to figure out the exact same problem and you made it easy for me.  I have been copying task which has been randomly carrying over actual start dates for few of them (where i may have set them manually earlier).  

    helps a lot thanks again!

    Tuesday, August 15, 2017 2:47 PM
  • Hi all,

    yes, this is an old post already. But finally I have this problem now and persisting. Of course I checked all of the possibilities mentioned above. And there are no "actuals" in any tasks and there are no linked summaries at all.

    May be I should mention two other circumstances: The problem occurs across the files in a multiproject only - inside a file everything works fine. Also tasks with only one external predecessor won't move up - even if "started as soon as possible". Funny thing: "Respect Links" moves it back, F9 moves it forward again.

    My client version is 14.0.705.1000 which is 2010 professional with a server behind.

    Any help would be appreciated very much - I am definetively lost at the moment.



    Monday, October 16, 2017 12:32 PM
  • Michael,

    First off, it looks like your last update was SP2 so you need to run Windows Update to get all the fixes installed. When done, Project 2010 should be version 14.0.7176.5000 which is the November 2016 Public update, the last update for Project 2010 (Microsoft support for Project 2010 has stopped so it is no longer actively updated).

    If you still have an issue after updating, let us know.


    Monday, October 16, 2017 2:00 PM
  • John,

    thank you for taking care - very nice.

    I made the update and have now the version 14.0.7176.5000. All "Actual Start+Finish" dates are N/A ... all constraints are gone ... still same result:

    If I open the file "alone" without the others which are included in the multiproject, it shifts the date to the left (correctly). If I open the connected file FCSW it shifts to the right again. No lagtime at all. And here - even more strange - inspect task does not show the predecessor - this is a real confusing hardcopy, isn't it?

    What does that mean: "Factors affecting task" and the summary is mentioned? If I delete the predecessor, the task still does not move. Only if I close the file with the predecessors, the date jumps to the left.

    Any idea? Should I open a ticket at Microsoft? Or create a new post?

    Thank you very much again!


    Tuesday, October 17, 2017 8:07 AM
  • Mick,

    What exactly are you referring to when you say "multiproject"? Do you mean a dynamically linked master with inserted subprojects? If not, what do you mean?

    What exactly is your first screen shot showing? Is it the dynamic master? I hope not, because if it is, the structure is corrupt. How do I know that? Because if you see ghost tasks (external tasks) at master level then it is because there are "dangling links" to files that are no longer active in the structure. This is caused if you ever rename, move, overwite or save off to another location, any of the files in the structure. It can also occur if you operate the structure over a network, which seems to be indicated in your case by the path shown in what I assume is the Predecessor and Successor fields.

    You mention opening a ticket with Microsoft. Do you have a support contract with Microsoft? If you do then certainly, let them help you resolve it. But if you are thinking about opening a ticket because you have found a bug, then no, this is not a bug.


    Tuesday, October 17, 2017 2:31 PM
  • Hi John,

    again thank you for taking the time to type an answer for me.

    Yes, I'm talking about one "container" project, containing 12 subprojects. And those subprojects are linked to each other. What you see is one of the subprojects - and the grey "ghost tasks" are quite normal in this situation. This is NOT a view from the "master container" file. I also know about the problems saving a file somewhere else than on the project server. I am doing this job now for several years. My problem is: Everything worked fine up to may be four weeks ago. No idea what happened, from one day to the other it stopped moving the successor dates (in this file only!). And I am not in charge for updating or patching anything. I don't even know if someone else does.

    I also can remove all links by a macro. And re-integrate them again. This is possible because I keep the linking information in separate user-text fields. I do this for years now - and never had problems with that up to now. And only in this one file - all the others calculate correctly. I checked all settings, no change. I used a new file - no change. Export/Import XML - no change.

    What confuses me most is: If I remove the predecessor and press F9, the task is not moving to project start. But it should, or not? And if i close the connected file with the predecessor and press F9 again - it moves!

    I do not like to open a ticket at Microsoft (yes, there is a contract) because I did this before several times - and each call was a bug finally and we did not have to pay for it. And it was a tremendous effort each time because they always want to have an "isolated" situation.

    Isn't there any workaroud or known problem solution for that? Any tool or macro to check? Where do I have to look? Should I post elsewhere?

    Thanks a lot again ;-)


    Wednesday, October 18, 2017 7:21 AM
  • Mick,

    Yes you're right, you will see "ghost" tasks in an individual file if it contains cross-project links. I'm just trying to cover the bases.

    I'm a little confused by your statement at the end of your second paragraph where you say you are not in charge of updating or patching. In your previous response you said you updated Project to 14.0.7176.5000 which is the most current version of Project 2010, so what is it you're not in charge of?

    Tell me a little bit about the macro that removes and re-establishes the inter-project links. Is it something you run on a regular basis? If so, why?

    You indicate you did an export/import using XML. What exactly did you do?

    If the problem you are seeing is something that "just popped up" recently and it only seems to show with one of the subprojects, then I'm highly suspicious of that particular file and/or it's link structure with the master and/or other subprojects. In particular, you mention that if you remove predecessors to a particular task that does not have an actual start and no constraints, that task will not slide back to the project start when you calculate (F9). I assume it is an auto-scheduled task. Correct? That action sounds like there may be a link fragment (i.e. corruption) that is still active but unseen. Without actually having the files to test, it is difficult to troubleshoot at a distance. Is there any way you could share your files with me?


    Wednesday, October 18, 2017 5:52 PM
  • Hi John,

    I'm not responsible - but I asked for an update to the latest status of MSP and I got it. Large Company and not my personal PC.

    Link Macro: I had problems in former times so I helped myself by removing all external linking (<xyz>)  and re-linking again with the LinkTasksEdit method. Worked fine. But this was not necessary the last months.

    XML: Export file(s) as XML and tried to open again. XML file looks OK - some binary stuff stays unknown of course. "An unexpected problem occured while opening the file. The file may be damaged. Try using a backup copy." The file can be opend in XML-Spy and looks OK. It stays "damaged" even if all the links are removed. (btw: is there any DTD for those XML files from MSP?)

    So I am at the point where I suppose a "broken" structure inside. If I remove all links from the file, the dates jump left. If I create ONE external link again as a predecessor, ALL tasks (even the ones not linked !) jump to the right again - months later than the predecessor. This happens even if I do that manually - with the first link set.

    I asked if it would be possible to send you the file but my customer refused to accept. May be I will strip it down and then he will agree. Not so easy situation here.

    So I will try to fix the problem by creating new files now (checking validity via XML export/import) and then re-linking again. Up to now already copy and pasting of the tasks causes XML inconsistencies. If I create new tasks from scratch nothing happens. So may be the structure inside some tasks is gone.

    Thank you very very much for your help - and I still will try to put the sample file up here.


    Thursday, October 19, 2017 2:42 PM
  • Mick,

    You're welcome and thanks for the feedback.

    I do not know if there is a document definition for XML. I assume there is but I don't know where to direct you.

    Note that going through the XML process doesn't always clear corruption from a file and it sounds like that may be the case with your errant subproject file. You might try other methods (see:

    Copying and pasting is not a good way to re-create a new file from a damaged one since there is no way to tell if you're simply copying and pasting the problem. I'd first try method 3 of the cited reference or if that doesn't help, bite the bullet and start from scratch.


    Thursday, October 19, 2017 3:26 PM
  • Thank you Jason! This uncovered one of my issues. I wonder how many other corrupted task attributes/fields are lurking under the hood ready to cause an issue. 

    Wednesday, February 14, 2018 9:08 PM
  • I see this is almost a year later than your post, but THANK YOU!!  This sorted out my issues 100%
    Wednesday, October 3, 2018 9:20 AM
  • I see this is an old post, but I had this same problem and almost pulled out my last bit of hair.  What I found was that at some time - I don't know when or why ...or how - there were dates entered as my Actual Start Dates for my tasks.  I had not started any but one task so far, so I cleared those entries resulting in an "NA" shown in that column (I had to add the Actual Start column to see it).  After I did that, things worked as normal.

    Hope this helps, if not you then others with this problem.

    This almost worked for me. What I found was that a "rouge" task that would not obey, was a summary task. Switching it to Auto mode DID NOT help, until used "fill down" option to change all the sub tasks in that summary task to automode as well. Magically all the date aligned.

    Friday, March 29, 2019 9:24 PM
  • thanks this did it....the 'Actual Start' columns were still showing dates because I had copied activities from a live schedule. When I set the dates here to NA, the task was scheduled correctly. 

    Thanks for the tip!

    Monday, October 12, 2020 2:29 PM