none
How to deny mails from External users to Internal multiple recipients users on Exchange 2013 and assign specific number of recipients

    Question

  • Hello All ,
    I have Exchange 2013 , we need to restrict emails from External users only send to multiple Internal users and assign Specific number of recipients ,  if more than this number deny and not received this message .

    Thank you .




    • Edited by Mohammad B Sunday, October 18, 2015 9:27 AM
    Sunday, October 18, 2015 8:56 AM

Answers

  • Hi Md,

    What are you using as a SMTP gateway or Edge server. See if you have any options there.

    You can create a Receive Connector and scope it to listen to only the Edge server, this way only external emails would be effected.

    You can create a Receive connector when you want to control which servers receive messages from a particular IP address or IP address range, and when you want to configure special connector properties for messages that are received from a particular IP address, such as allowing larger messages or more recipients per message.


    Regards,

    Satyajit

    Please“Vote As Helpful” if you find my contribution useful or “MarkAs Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.



    Monday, October 19, 2015 5:57 AM
  • Hi,

    As you want to limit external email to a maximum of 5 recipients per message, you need to configure the entry point for the external email. External email is routed through to a few Exchange servers and they use the default receive connector. The problem is that the default receive connector is also used for internal mail transport so if you set the max recipients limit on this then it will affect internal email also. 

    To achieve your goal, you will need to do the below tasks:

    1. Create a smarthost or edge server to receive external email and relay it through to two or more Exchange servers
    2. Configure a new internet receive connector on these Exchange servers which is scoped to the IP of the smarthost or edge server and enable anonymous authentication: https://technet.microsoft.com/EN-US/library/jj657447(v=exchg.150).aspx
    3. On this new receive connector, configure the max recipients limit

    Also, reset the Transport Configuration back to default settings for MaxRecipientEnvelopeLimit. See here: https://technet.microsoft.com/en-us/library/bb124151%28v=exchg.160%29.aspx

    Let us know how you get along.

    Thanks.


    Please mark as an answer if this answers your question

    Mark Gossa

    MCSE 2003, MCITP Enterprise Administrator 2008 R2, MCSA 2012 R2, MCTS Exchange 2010

    Blog: http://markgossa.blogspot.com

    Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    Monday, October 19, 2015 2:37 PM

All replies

  • Hello

    tip: on receive conector MaxRecipientsPerMessage limit not good?


    sorry my english

    Sunday, October 18, 2015 9:40 AM
  • Hello Sneff ,

    I did this stpes but only working with internal users .

    Thank you

    Sunday, October 18, 2015 9:44 AM
  • Create a transport rule for rejecting emails sent to specific internal recipients. 

    For recipient count check the transport config and internet receive connector.


    PREM RANA MCSE Exchange 2013, MCSA 2012 Server MCTS Exchange 2007,2010, MCITP Exchange 2007,2010 MCSE 2003 Server, MCSA Exchange 2003 ITIL V3 Foundation https://ranaprem.wordpress.com/ This posting is provided AS IS with no warranties,and confers no rights.

    Sunday, October 18, 2015 10:46 AM
  • Hello Prem ,

    I have it internaly working without any problem when configured in transport config  .

    We need  for any one of outside copmany (External Sender) want to send email to inside compamy for more than 5 Recipents (internally mailbox ) in that time the Exchange reject this messages .

    Thank u

    Sunday, October 18, 2015 10:57 AM
  • Hi,

    To configure Exchange to reject messages sent to more than 5 recipients, run the below command on each Exchange CAS server:

    Get-ReceiveConnector | ? {$_.Identity -match "Default Frontend"} | Set-ReceiveConnector -MaxRecipientsPerMessage 5

    Thanks.


    Please mark as an answer if this answers your question

    Mark Gossa

    MCSE 2003, MCITP Enterprise Administrator 2008 R2, MCSA 2012 R2, MCTS Exchange 2010

    Blog: http://markgossa.blogspot.com

    Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    Sunday, October 18, 2015 9:19 PM
  • Hello Mark ,

    Thank you for ur help ,

    This command affected only sender of  External users ( Outside Company) OR both Internal & External Sender to my Exchange Server .



    • Edited by Mohammad B Monday, October 19, 2015 5:42 AM
    Monday, October 19, 2015 5:36 AM
  • Hi Md,

    What are you using as a SMTP gateway or Edge server. See if you have any options there.

    You can create a Receive Connector and scope it to listen to only the Edge server, this way only external emails would be effected.

    You can create a Receive connector when you want to control which servers receive messages from a particular IP address or IP address range, and when you want to configure special connector properties for messages that are received from a particular IP address, such as allowing larger messages or more recipients per message.


    Regards,

    Satyajit

    Please“Vote As Helpful” if you find my contribution useful or “MarkAs Answer” if it does answer your question. That will encourage me - and others - to take time out to help you.



    Monday, October 19, 2015 5:57 AM
  • Hi,

    As you want to limit external email to a maximum of 5 recipients per message, you need to configure the entry point for the external email. External email is routed through to a few Exchange servers and they use the default receive connector. The problem is that the default receive connector is also used for internal mail transport so if you set the max recipients limit on this then it will affect internal email also. 

    To achieve your goal, you will need to do the below tasks:

    1. Create a smarthost or edge server to receive external email and relay it through to two or more Exchange servers
    2. Configure a new internet receive connector on these Exchange servers which is scoped to the IP of the smarthost or edge server and enable anonymous authentication: https://technet.microsoft.com/EN-US/library/jj657447(v=exchg.150).aspx
    3. On this new receive connector, configure the max recipients limit

    Also, reset the Transport Configuration back to default settings for MaxRecipientEnvelopeLimit. See here: https://technet.microsoft.com/en-us/library/bb124151%28v=exchg.160%29.aspx

    Let us know how you get along.

    Thanks.


    Please mark as an answer if this answers your question

    Mark Gossa

    MCSE 2003, MCITP Enterprise Administrator 2008 R2, MCSA 2012 R2, MCTS Exchange 2010

    Blog: http://markgossa.blogspot.com

    Posts are provided “AS IS” without warranty of any kind, either expressed or implied.

    Monday, October 19, 2015 2:37 PM
  • Thank you all  for helping ,

    We have a hardware smart host , we will try to configure it in smart host connector .
    i will update you .

    Thank you .

    Tuesday, October 20, 2015 4:40 AM