locked
LocalStorage function don't work after applied KB3008923 patch for IE11 RRS feed

  • Question

  • detail information following

    1、my code is    localStorage.setItem("listTitle",n.listTitle);    nis object, i am sure that n.listTitle is not empty, even if i change the code to  localStorage.setItem("listTitle","testlist"); then still have the same error

    2、my operation system is windows8.1, afte installed the system, IE was automatically update to 11.0.9600.17498 version, i found out the patch is KB3008923

    3、yes, my computer connected to a domain

    4、my actions is localStorage.setItem("listTitle","testList");

    5、exact error message is Access is deniedImage

    i try to do some test, if open IE using run administrator, the error is not exist and i am sure the lower than the version is also ok,

    looking forward to receive your response, thanks again

    Thursday, January 8, 2015 12:21 AM

Answers

  • if open IE using run administrator, the error is not exist

    So, it sounds like a permissions problem.  ProcMon could help identify it.  If necessary you could trace both cases and then compare them for their essential differences.


    Robert Aldwinckle
    ---

    • Marked as answer by Yolanda Zhu Monday, February 9, 2015 10:01 AM
    Friday, January 9, 2015 1:43 PM
    Answerer
  • Hi,

    How about your problem now? For this problem, I'm aggree with Robert, because of I know little knowledge with IE web development, it's hard to provide any suggestion about this function access error. But since it is Permission problem, Process Monitor should be helpful to capture the trace of IE running. You can download and run this tool for test.

    Process Monitor:http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    If there is any progress with this problem, please feel free let me know.


    Roger Lu
    TechNet Community Support

    • Marked as answer by Yolanda Zhu Monday, February 9, 2015 10:01 AM
    Sunday, January 11, 2015 2:39 PM

All replies

  • if open IE using run administrator, the error is not exist

    So, it sounds like a permissions problem.  ProcMon could help identify it.  If necessary you could trace both cases and then compare them for their essential differences.


    Robert Aldwinckle
    ---

    • Marked as answer by Yolanda Zhu Monday, February 9, 2015 10:01 AM
    Friday, January 9, 2015 1:43 PM
    Answerer
  • Hi,

    How about your problem now? For this problem, I'm aggree with Robert, because of I know little knowledge with IE web development, it's hard to provide any suggestion about this function access error. But since it is Permission problem, Process Monitor should be helpful to capture the trace of IE running. You can download and run this tool for test.

    Process Monitor:http://technet.microsoft.com/en-us/sysinternals/bb896645.aspx

    If there is any progress with this problem, please feel free let me know.


    Roger Lu
    TechNet Community Support

    • Marked as answer by Yolanda Zhu Monday, February 9, 2015 10:01 AM
    Sunday, January 11, 2015 2:39 PM