locked
Uninstallation of SCVMM2012 SP1 fails with error 1603 RRS feed

  • Question

  • Hi all,

    I have the following situation - a single box with SQL2012, SCOM 2012 SP1 and SCVMM2012 SP1 (connected). As I am upgrading to VMM 2012 R2, I had to uninstall the VMM 2012 SP1. The issue is that the SP1 setup fails with error 1603. Before uninstalling I removed the VMM rollup update (there was only one installed). Here is part of the vmmserver.log file I think is somewhat relevant:

    MSI (s) (40:F4) [21:33:23:983]: Invoking remote custom action. DLL: C:\Windows\Installer\MSI12C7.tmp, Entrypoint: DisableWsmanCredSSP
    Action start 21:33:23: DisableWsmanCredSSP.
    CustomAction DisableWsmanCredSSP returned actual error code 1603 (note this may not be 100% accurate if translation happened inside sandbox)

    I tried the following cmdlet - disable-wsmancredssp -role server and disable-wsmancredssp -role client but setup still fails with the same error.

    I hope someone can enlighten me regarding this as now I don't have any VMM working :D

    Thanks in advance!


    Ivailo Tzenkov

    Thursday, October 24, 2013 8:30 AM

All replies

  • Ivailo,

    I have this exact same issue. Would love to know what the fix is.

    Thanks!

    Jason


    Wednesday, October 30, 2013 10:09 PM
  • I ended up having to manually uninstall SCVMM SP1 by removing folders, services and registry keys. Once that was done I was able to install R2 successfully.
    Tuesday, November 5, 2013 10:52 PM
  • Hi,Would you share the exact keys and folders you removed? I was going to rebuild the server...

    Ivailo Tzenkov

    Wednesday, November 6, 2013 6:20 PM
  • I too am seeing this error.  I was using Windows 2012 Server with SQL2012 installed locally.  I had installed SCVMM 2012 with SP1 included, then applied Update Rollup 2.  No further URs had been installed.  The SCOM 2012 SP1 console was installed on this system for SCVMM/SCOM integration.

    I was attempting to upgrade to VMM 2012 R2, so I chose to uninstall VMM server but retain the database.  I too had to uninstall UR2 due to experiencing problems described here:

    http://robbieroberts.wordpress.com/2013/10/18/error-uninstalling-vmm-2012-sp1/

     

    Tuesday, November 12, 2013 4:17 PM
  • Also having the same problem.  I cannot uninstall SCVMM 2012 SP1 Management server in readiness to upgrade to SCVMM 2012 R2.  I have researched and tried everything and nothing works :(
    Thursday, November 21, 2013 10:59 AM
  • Same problem here.

    Japanese version of SCVMM 2012 SP1 have same problem.




    Thursday, December 19, 2013 7:08 AM
  • I rebuilt the server eventually :) I hate such "solutions" but after all I needed it working.

    Ivailo Tzenkov

    Thursday, December 19, 2013 9:04 AM
  • The issue is related to Windows Assessment and Deployment Kit (Windows ADK) 8.0.

    In my case I had ADK 8.1 installed over VMM 2012 Server recently.

    I had to reinstall ADK 8.0 to be able to successfully remove VMM 2012 Server.

    Wednesday, September 3, 2014 9:54 AM
  • Solved by simply enabling wsmancredspp.

    From an elavated PowerShell run:

    • Enable-WSManCredSSP -Role server

    Regards

    Saturday, September 27, 2014 4:07 PM
  • Enable both - server and client wsmancredspp

    Enable-WSManCredSSP -Role Client -DelegateComputer computername

    Enable-WSManCredSSP -Role server


    Monday, October 6, 2014 1:21 PM
  • But anyone know what causes this to happen?  It pretty much tanked my VMM installation, and service wouldn't start.
    Thursday, June 4, 2015 8:42 PM
  • Thank you Kaspik,  Entering both commands in PowerShell (Admin) fixed my Uninstaller.

    Enable both - server and client wsmancredspp

    Enable-WSManCredSSP -Role Client -DelegateComputer computername

    Enable-WSManCredSSP -Role server

    Jim




    james sparks

    Thursday, August 6, 2015 8:38 PM
  • Thank you Kaspik,

    I had to use this to uninstall/re-install VMM2012r2 after DB corruption. so clearly it's a fault Microsoft have not resolved.

    Thursday, March 10, 2016 10:13 PM
  • You saved my day!
    Wednesday, June 15, 2016 9:07 AM
  • Saved me on my 2016 upgrade of SCVMM. Thanks!
    Wednesday, October 25, 2017 7:49 PM
  • Now that I have run this and solved the issue, I wished I checked the status of WSManCredSSP before to revert the settings back 

    STEP 1

    Get-WSManCredSSP

    make a note of what is set or not set for step 3

    STEP 2

    Enable-WSManCredSSP -Role Client -DelegateComputer computername

    Enable-WSManCredSSP -Role server

    Now remove SSVMM (FYI this is still the same in SS2016 VMM)

    STEP 3

    If the machine was not configured to allow/receive delegating credentials in Step 1 run this to revert the security settings back

    Disable-WSManCredSSP -Role Client 

    Disable-WSManCredSSP -Role server


    Mark Masiak

    Friday, January 19, 2018 1:42 PM
  • Enable both - server and client wsmancredspp

    Enable-WSManCredSSP -Role Client -DelegateComputer computername

    Enable-WSManCredSSP -Role server


    This worked for me (for uninstalling both 1807 and 2019), but only if I was logged in with the actual VMM service account. Hopefully this doesn't happen again, since now my 2019 server is now installed using a gMSA account, which you can't actually login interactively with. So I guess we'll find out in a few years when the next version comes out!

    I had also manually uninstalled Microsoft Web Deploy 3.5 as recommended in another post, but I don't think that is what did the trick. But I'll mention it here anyway, just in case.

    Friday, April 5, 2019 2:19 AM
  • Nevermind. I just tried using my own instructions, and it still didn't work. Guess I'm reformatting again.

    MICROSOFT!! THIS HAS BEEN A PROBLEM SINCE 2012 SP1, AND IT'S STILL PRESENT IN 2019!! PLEASE FIX THIS ISSUE!

    I have my uninstall log files available for anyone who cares to look at them.

    Tuesday, May 14, 2019 11:21 PM
  • Same issue here. Several unintalls failed with error 1603, until i tried with the SCVMM service account.

    So i fixed the uninstall issue by signing in as the SCVMMService account, which is used to run the VMM Server.

    Friday, September 6, 2019 11:03 AM
  • I was able to complete the uninstall by running the uninstallation with the SYSTEM user by using psexec. Thank you Paul :)
    Wednesday, September 25, 2019 1:01 PM