locked
How to Disable the Annoying "Feature" of Auto-Scrolling Windows to Display Partially Concealed Items in List View RRS feed

  • Question

  • I've never met another human being online, or in person, who doesn't despise the way, in list view, when you click on a file or folder that is not completely visible because part of it's name is over the edge of the window, the window will jump or scroll so that that file or folder is no longer partially off the screen.

    What this results in is, when double-clicking to open said file or folder, instead it jumps out from under the mouse immediately after the first click, thereby causing the procedure of simply opening a file or folder to fail.

    Please tell me that there is a tweak or fix for this in the registry somewhere or something that can disable this disastrous "feature."

    Thanks

    Cheers

    Tuesday, February 10, 2015 4:20 AM

Answers

  • I also use QTTabBar - see

    http://sourceforge.net/projects/qttabbar/

    - for the ability to use tabs in Explorer. Although (or because) it is highly configurable, if you have never used it before, there may be a small learning curve associated with setting it up.

    Anyway, in the options, under "Misc" there is a setting called "Use old Listview control (Win 7)" which, after restarting Explorer, prevents the side scrolling on the first click.

    I am not sure, but this feature may also be available in Quizo's (newer) version of QTTabBar here

    http://qttabbar.wikidot.com/

    (QTTabBar was originally Quizo's app.)

    • Edited by mystifeid Wednesday, February 11, 2015 4:07 AM
    • Marked as answer by labornvain Wednesday, February 11, 2015 5:32 AM
    Wednesday, February 11, 2015 3:36 AM

All replies

  • I prefer single click and do not see this behaviour with list view.

    To change: Control Panel -> Appearance and Personalization -> Folder Options -> General Tab -> select "single-click to open an item (point to select)".

    Just tried double-click with list view and agree that this issue would be annoying.
    Tuesday, February 10, 2015 4:53 AM
  • Are you having this issue on a laptop by chance? You can usually disable "Vertical Scrolling" in your mouse properties under your touch-pad options. 
    Tuesday, February 10, 2015 3:04 PM
  • Thanks for the suggestion mystified. But one step forward, two steps back. No thanks.

    Tuesday, February 10, 2015 10:04 PM
  • No. This issue is not unique to me. It is a "feature", albeit a stupid one, of the new explorer in Windows 7.

    It has nothing to do with vertical scrolling or the mouse.

    Again, in "List View", if one has a lot of files or folders in a folder, and some of them are partially hidden because maybe they have really long names, or your window is too small so the name extends beyond the edge or border of the window, when you click on that file or folder, Win7 thinks that it needs to correct the situation by auto-scrolling so that the complete name of the file or folder you clicked on can be seen in its entirety.

    What happens is that, if you want to open one of these files or folders, and you go to double-click on it, before you can even do the second click, the auto-scroll moves the file or folder so that the second click acvtually lands on a completely difference file or folder.

    It is truly the stupidest thing imaginable and has left many people banging their heads against wall. But after 5 years or more, Microsoft won't fix it.

    Unless there's a new update I'm not aware of or a trick or something. Thus my decision to inquire here.

    Cheers

    Tuesday, February 10, 2015 10:17 PM
  • I also use QTTabBar - see

    http://sourceforge.net/projects/qttabbar/

    - for the ability to use tabs in Explorer. Although (or because) it is highly configurable, if you have never used it before, there may be a small learning curve associated with setting it up.

    Anyway, in the options, under "Misc" there is a setting called "Use old Listview control (Win 7)" which, after restarting Explorer, prevents the side scrolling on the first click.

    I am not sure, but this feature may also be available in Quizo's (newer) version of QTTabBar here

    http://qttabbar.wikidot.com/

    (QTTabBar was originally Quizo's app.)

    • Edited by mystifeid Wednesday, February 11, 2015 4:07 AM
    • Marked as answer by labornvain Wednesday, February 11, 2015 5:32 AM
    Wednesday, February 11, 2015 3:36 AM
  • Ah man, thanks for the tip. But I already found a solution here:

    http://www.winhelponline.com/blog/disable-full-row-select-explorer-windows-7/

    This involves some registry tweaks but it works!!!

    If I had only seen your post first because, between searching and then implementing, I spent 4 hours on what looks like it takes 2 seconds withQTTabBar.

    Thanks again for the tip. Big help, especially to those who won't want to edit their registry. I'm going to go install QTTabBar now and play with it.

    Cheers

    Wednesday, February 11, 2015 5:32 AM