locked
set desktop background group policy RRS feed

  • Question

  • We set via group policy a desktop background .bmp (also tried jpg) with company logo, which works well on 2003, xp, vista, 2008. However on windows 7 things do not work so well. If a user has logged on previously, then the picture seems to work.

    However, if a new user logs in, there is only a black background (and the taskbar). Right click desktop, personalise, select desktop background, the correct picture appears in the list of available pictures and is ticked, but it still wont display as the desktop background. As you go to logoff the computer, the correct desktop background picture breifly appears before teh logon background screen is displayed.

    We do set default theme in group policy which works when a new user is created, however, the theme pictures are not displayed either if a desktop bacground is set in gp (it does display properly if bg not set in gp).


    any ideas???
    thanks
    Tuesday, August 25, 2009 1:32 PM

Answers

  • Hi,

    It's a known bug:

    It seems the Registry key [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] is missing and caused this problem. To work around this issue, please create a String Value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] on client and try to set wallpaper. 
     

    We can use Group Policy Preference->Registry to deploy this Registry key or use user logon script to deploy this Registry key.

     

    Thanks.

     

     

    • Marked as answer by Arthur Xie Wednesday, September 2, 2009 2:07 AM
    Wednesday, September 2, 2009 2:04 AM

All replies

  • Hi,

    It's a known bug:

    It seems the Registry key [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] is missing and caused this problem. To work around this issue, please create a String Value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] on client and try to set wallpaper. 
     

    We can use Group Policy Preference->Registry to deploy this Registry key or use user logon script to deploy this Registry key.

     

    Thanks.

     

     

    • Marked as answer by Arthur Xie Wednesday, September 2, 2009 2:07 AM
    Wednesday, September 2, 2009 2:04 AM
  • Hi,

    It's a known bug:

    It seems the Registry key [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] is missing and caused this problem. To work around this issue, please create a String Value [HKEY_CURRENT_USER\Control Panel\Desktop\WallPaper] on client and try to set wallpaper. 
     

    We can use Group Policy Preference->Registry to deploy this Registry key or use user logon script to deploy this Registry key.

     

    Thanks.


    Actually, you need a value named Wallpaper in the key [HKEY_CURRENT_USER\Control Panel\Desktop].

    Ie, "Wallpaper"="<path to your wallpaper>"
    Wednesday, September 2, 2009 2:21 AM
  • Hi,

    Can you clarify where the registry entry should be added, what it's name should be, and what value(s) should be included?

    I'm quite new to Group Policy and am struggling to get this to work.

    Thanks,

    Monday, September 28, 2009 3:43 PM
  • Vladimir:

    I know nothing of Group Policy Preference. I haven't played with that yet.

    If you want to try Group Policy, there is also the setting "\User Configuration\Policies\Administrative Templates\Desktop\Desktop\Desktop Wallpaper".

    Or you could use a .reg file:


    Windows Registry Editor Version 5.00
    
    [HKEY_CURRENT_USER\Control Panel\Desktop]
    "Wallpaper"="C:\\Windows\\Web\\Wallpaper\\img1.jpg"
    
    • Proposed as answer by Brian Borg Wednesday, October 7, 2009 7:46 PM
    • Unproposed as answer by Brian Borg Friday, July 1, 2011 4:33 PM
    Monday, September 28, 2009 10:45 PM
  • Thanks Brian,

    Seems to be working quite nicely now. For now I've run the reg file on the broken PC's, and it works fine.

    Thanks for the help everyone.
    Tuesday, October 6, 2009 2:15 PM
  • Hi there,

    I know this is an old issue (has microsoft fixed it properly yet) but Im having a similar problem but I do have that registry setting.

    I have created the registry entry as per this and other postings, and I have even changed it to a local wallpaper file, even though the wallpaper on the server share was available. It has been created using the group policy preferences.

    I still get a black screen. If I right click on the desktop I can see the corporate wallpaper as an unsaved theme and as the current wallpaper. Right click and refresh does nothing.

    Anyone have any ideas what is going on...?

    The main DC is a windows 2003 server (group policy preferences created using a domain attached windows 7 machine).
    The XP users receive the desktop wallpaper in the usual way and all the active desktop settings in the normal GPO are set.

    Anyone have any ideas..?

    Thanks
    Rolf
    Tuesday, December 29, 2009 10:42 PM
  • I've got this same issue, but creating and running the reg file will only apply to the current user, correct? I tried this on a users computer but they don't have privileges to run the reg file.
    If they are unable to edit the registry will this also fail to work if i put it in a script?
    I am not that familiar with scripts so can anyone show me how to make a batch or what ever to include the reg entry?

    Thanks,
    Geoff
    Thursday, January 21, 2010 6:01 AM
  • Hi,

    As of today morning we have a fix available for this issue.

    You can download the Hotfix straight off the KB article page.

    The "Desktop Wallpaper" Group Policy setting is not applied in Windows 7 or in Windows Server 2008 R2
    http://support.microsoft.com/kb/977944

    • Proposed as answer by Brian Borg Tuesday, February 9, 2010 10:10 PM
    Tuesday, February 9, 2010 8:28 AM
  • How to deploy the hotfix in all the computers??

    Thanks.


    Johan C
    Monday, February 14, 2011 4:27 PM
  • Can you send me instruction on how to apply group policy from windows 2003 server to XP machines for desktop background?

     

    Thanks

    Nimit Shah

    Friday, July 1, 2011 2:38 PM
  • Here are instructions on deploying this registry fix to your computers:

    http://deployhappiness.com/setting-the-desktop-wallpaper-background-with-group-policy/


    If my answer helped you, check out my blog: DeployHappiness. Subscribe by RSS or email. 


    Friday, August 16, 2013 1:36 PM