none
VM backup failes after adding hosts to cluster RRS feed

  • Question

  • Hi,

    we added more hosts to a cluster. After that I started to experience backup failures for VM from this cluster. At first I thought it is just because there was no agent installed on the new hosts. So I did that and still not able to create backup. In the event logs (DPM/Microsoft system) there was no entry for the failures but whenever I tried to start a synchronisation it would fail within seconds. So I am not sure if adding thos hosts to the cluster had anything to do with it.

    The strange thing is - when I went to "modify protection group" the VM's were there on the right hand side but when I looked on the left hand side - those VM's were not selected. I mean normaly they should have been selected but they were not. So I selected them again and now I had two entries for the same VM. So I deleted the old one and sure enough even though it is the same VM (even on the same host as before) DPM treated it as a new datasource.

    Someone has an idea what happened? Where I could determine what is going on? I tried to find an entry in the DPM log files the to get more information why it failed but was not lucky. Someone could tell me where to look and what key entries to look for?

    Monday, September 5, 2011 2:13 PM

All replies

  • I'm assuming you are using the System Software VSS provider in the scenario.  The problem may be that you need to update the datasourcegroups.xml file to include the new VM's running on the hosts you have added to the Cluster.  Look at the content titled "Considerations for Backing Up Virtual Machines on CSV with the System VSS Provider" at http://technet.microsoft.com/en-us/library/ff634192.aspx for more information about updating the XML file. 

     

    If this doesn't address the issue, look in the DPM console under Monitoring and then alerts for details about what is failing.

    Tuesday, September 6, 2011 10:44 PM
    Moderator
  • Hi,

    sorry I guess my explanation wasn't clear enough. Those VM's are not new. They are the ones in my existing Protection Group. I have creating backups from those VM's for 6 months now. They started to fail right after the new hosts were added to the cluster.

    The first error message was saying that agents are missing on the new hosts in the cluster and therfor the backup might have failed. So I installed the agents on the hosts. As this did not change anything. I went to the protection group and that is when I saw this strange occurence. Meaning the VM's I had selected were no longer selected but they still appeared in my protection group. So I removed them and re-added them. So I am now trying to find out why those existing VM's were no longer selected. The error message was that the target path could not be found anymore.

    Thursday, September 8, 2011 9:32 AM
  • We should not expect that adding a new host would cause these problems.  The one thing i suspect could be related is the problem could happen after a restore of some of the VM's.  When a VM is restored, DPM sees it as a new datasource.  You will need to remove the duplicate datasource after a restore. 

     

    Let me know if this addresses your issue.  If not, please provide me with the details of the alert you received when the synchronization failed.

    Thursday, January 19, 2012 11:37 PM
    Moderator