locked
How to hide disable or inactive users from SharePoint online search? RRS feed

Answers

  • Hi all,

    Update:

    By changing the profiles AD property "msExchHideFromAddressLists" to True or Yes and updating the search query as  {searchboxquery} AND -"SPS-HideFromAddressLists":1    all disable users are not showing up in the search but changing the “MailNickName” attribute in on-prem AD is must without this attribute changes the "msExchHideFromAddressLists" attribute will not be synced to SharePoint online. 

    So Microsoft need to change the below "May" to "Must" in the below document:

    "Hint: You may (should be must) need to add/update the “MailNickName” attribute in on-prem AD for the msExchHideFromAddressLists  to sync. "

    Reference Url:

    https://techcommunity.microsoft.com/t5/SharePoint-Support-Blog/Exclude-Users-From-Delve-and-SharePoint-Online-People-Search/ba-p/170731



    Thanks&Regards,

    Habibur Rahaman

    MCSA,MCP,MCTS

    My Certificates

    Note: If you feel the proposed answer is helpful, please mark as so or if this answered your question,please mark as answer.


    Friday, July 5, 2019 12:55 PM

All replies

  • Hi, Habibur,

    According to the developer's blog, for now the best approach is the way you mentioned. Changing the  "msExchHideFromAddressLists" to 1 or true in AD. And there are some limitations. It does not work for cloud accounts. Changing msExchHideFromAddressLists does not remove the user from the Organization view in Delve.

    For more detailed information you can check this: https://techcommunity.microsoft.com/t5/SharePoint-Support-Blog/Exclude-Users-From-Delve-and-SharePoint-Online-People-Search/ba-p/170731

    I am still testing the approach mentioned in the second link. Add a new property to distinguish inactive users from common users (waiting for a crawl to pick up the custom property). 

    Best Regards

    Jerry



    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Wednesday, July 3, 2019 6:15 AM
  • Hi Jerry,

    Thanks for your reply - I am also exploring the second link which I had sent. By the I way I have already referred this link:  https://techcommunity.microsoft.com/t5/SharePoint-Support-Blog/Exclude-Users-From-Delve-and-SharePoint-Online-People-Search/ba-p/170731


    Thanks&Regards,

    Habibur Rahaman

    MCSA,MCP,MCTS

    My Certificates

    Note: If you feel the proposed answer is helpful, please mark as so or if this answered your question,please mark as answer.

    Wednesday, July 3, 2019 9:10 AM
  • Hi,

    From my testing I have found that if we make changes in "msExchHideFromAddressLists” property to True or 1 in local AD...and add filter query in sharepoint online search like {searchboxquery} && -"SPS-HideFromAddressLists":1 , for most of the cases the user which has "msExchHideFromAddressLists" eqaul 1 or True...its not showing up in the search this is expected and positive result but for some users eventhough "msExchHideFromAddressLists" set as 1 or True in the local AD, still showing up those users in the SharePoint online search..What could be the reason? Anyone experienced the same?

    Reference Url:
    https://blogs.technet.microsoft.com/beyondsharepoint/2016/11/11/restrict-disabled-users-in-search-results/


    Update for the below url:
    http://thomasdaly.net/2016/01/16/hiding-people-from-people-search/

    As per the above url created the "HideFromPeopleSearch" new property yesterday but still it is not showing up in the search crawl property list...not sure how frequently online search gets crawled.

    Thanks&Regards,

    Habibur Rahaman

    MCSA,MCP,MCTS

    My Certificates

    Note: If you feel the proposed answer is helpful, please mark as so or if this answered your question,please mark as answer.


    Thursday, July 4, 2019 8:55 AM
  • Hi all,

    Update:

    By changing the profiles AD property "msExchHideFromAddressLists" to True or Yes and updating the search query as  {searchboxquery} AND -"SPS-HideFromAddressLists":1    all disable users are not showing up in the search but changing the “MailNickName” attribute in on-prem AD is must without this attribute changes the "msExchHideFromAddressLists" attribute will not be synced to SharePoint online. 

    So Microsoft need to change the below "May" to "Must" in the below document:

    "Hint: You may (should be must) need to add/update the “MailNickName” attribute in on-prem AD for the msExchHideFromAddressLists  to sync. "

    Reference Url:

    https://techcommunity.microsoft.com/t5/SharePoint-Support-Blog/Exclude-Users-From-Delve-and-SharePoint-Online-People-Search/ba-p/170731



    Thanks&Regards,

    Habibur Rahaman

    MCSA,MCP,MCTS

    My Certificates

    Note: If you feel the proposed answer is helpful, please mark as so or if this answered your question,please mark as answer.


    Friday, July 5, 2019 12:55 PM