locked
Copy queue lenght too high - Please help!! RRS feed

  • Question

  • This is on a Exchange 2010 SP1 test environment and I have a two member DAG configured, we had an issue with the disk on the second server and corrupted some databases. I'm trying to fix a mailbox database that is currently in 'healthy' status, with a copy queue lenght of 25000.  When I try to make it the active copy I get an error that basically says that the CQL is too high.  I've tried runningg 'Move-ActiveMailboxDatabase DB1 –ActivateOnServer Server1 -SkipLagChecks –MountDialOverride:none' but it tells me that the db has content index catalog files in 'Failed' state. 

    Can anybody suggest a way to correct this problem?, I don't need the log files and can be deleted if needed.  I've search the web and tried few things, but nothing has work so far.  The idea here is to fix this db and seed a copy on the other server. Any help is appreciate it.

    Thursday, October 20, 2011 1:39 PM

All replies

  • Update-MailboxDatabaseCopy "DB1\Server1" -CatalogOnly
    

    Update the catalog and then the move again.


    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security
    Thursday, October 20, 2011 1:59 PM
  • Thanks for the suggestion, but I got an error when I run that command.  It says that it can't dismount the search catalog, dismount failed.  Any ideas?
    FLaidman
    Thursday, October 20, 2011 2:11 PM
  • C:\Program Files\Microsoft\Exchange Server\V14\Scripts>.\Troubleshoot-CI.ps1 -Database DB1 –Action  DetectAndResolve
    

    Try to fix it by running the above command
    Jasjit Singh Dhindsa | ITIL v3 | IASA Foundation Certified | MCITP:Exchange 2010 | Exchange 2007 | MCTS:OCS 2007 | Exchange 2010 | Exchange 2007 | MCSA:Messaging | Security | MCSE:Messaging | Security
    Thursday, October 20, 2011 2:29 PM
  • Just run the script, this is what I got:

    [PS] C:\Program Files\Microsoft\Exchange Server\V14\Scripts>.\Troubleshoot-CI.ps1 -Database DB2F-S -Action DetectAndReso
    lve

    Name                                                               IsDeadLocked CatalogStatusArray
    ----                                                               ------------ ------------------
    TMAIL                                                                     False {DB2F-S\TMAIL}


    FLaidman
    Thursday, October 20, 2011 3:53 PM
  • Hi Fred,

     

    Any updates on this issue?

     

    For the issue that “the db has content index catalog files in ‘Failed’state”, you can refer to this document:

     

    Exchange 2010 Database copy on server has content index catalog files in the following state: Failed

    http://blogs.msdn.com/b/pepeedu/archive/2010/12/14/exchange-2010-database-copy-on-server-has-content-index-catalog-files-in-the-following-state-failed.aspx

     

    Thanks,

     

    Evan

    Tuesday, October 25, 2011 6:38 AM
    Moderator
  • Thanks I'll take a look
    FLaidman
    Tuesday, October 25, 2011 1:15 PM