none
Project Server 2010 Permissions Broken - Sync not working RRS feed

  • Question

  • Hi all,

    I have the problem where the project workspace permissions are not being applied to resources that are assigned tasks. it works if you are very tip-toe around it, as in it worked once on a new project but then I had it get wiped out for no reason and then won't go back.

    Is there some "it just works" post that shows how to fix this? It's not rocket science, it seems to me this shoddy feature is still shoddy even after going to v2010.

    Thanks for any suggestions,
    Greg

    Wednesday, October 3, 2012 10:16 PM

All replies

  • Hi Greg,

    Do you see any errors in the Project Server queue? What happens if you force a site sync by selecting the project and clicking the synchronise button from the Project Sites page on Server Settings, does this resolve the issue?

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Wednesday, October 3, 2012 10:45 PM
    Moderator
  •  

    Hi Greg,

    Sorry to hear that it’s not working for you. You are right and it's not a rocket science to get this thing work. There are multiple reasons for workspace sync not to work. I will try my best to get your issue fixed.

    What is your current service pack and cu level on Project Server?

    Is this issue affected all the projects or projects created using specific template?

    Do you use Active Directory sync to add users in PWA?

    Issue this issue specific to any user or group like Team Member, Project Manager Etc.?


    Hrishi Deshpande – Senior Consultant DeltaBahn
    Blog | < | LinkedIn

    Please click Mark As Answer; if a post solves your problem or Vote As Helpful; if a post has been useful to you.This can be beneficial to other community members reading the thread.

    Wednesday, October 3, 2012 10:52 PM
    Moderator
  • Hi Paul,

    I forced a site sync and it actually ran the full sync on all the workspaces .... and broke permissions on the ones that initially were working (meaning they too now showed only the system account as having access).

    Fun! I am just unchecking the option and keeping the upgrade environment without that just like in use currently. It's a shame, I thought with the upgrade some enhancements related to security would be useful. But they are not it seems.

    Thanks,
    Greg

    Thursday, October 4, 2012 5:07 PM
  • Hi Hrishi,

    I am not currently using AD Sync on this test environment, although I have used that in the past. I am using build 14.0.6123.5000 at the moment.

    I tried with several different AD users, trying individual sync, full organization group creation and resync, and nothing makes it work on existing projects. If I tiptoe, I can create a new empty project, add people to the team, and I believe it works when first creating the site.

    But it goes away quickly :-)

    Thursday, October 4, 2012 5:09 PM
  • Hi Greg,

    Do you see any errors in the Project Server queue after a sync or project update? So even users in the Project Server Administrators group / group that has Manage SharePoint Foundation permission enabled do not have access to a site after it is synchronised?

    See the links below for Project Server 2010 Project Site permissions:

    http://technet.microsoft.com/en-us/library/cc197668.aspx

    http://technet.microsoft.com/en-us/library/gg982961.aspx

    Thanks

    Paul


    Paul Mather | Twitter | http://pwmather.wordpress.com | CPS

    Thursday, October 4, 2012 7:45 PM
    Moderator