none
IPAM can't find service instance (localhost) RRS feed

  • Question

  • Hi,

    I'm trying to create a new IP address range on Windows Server 2016 & IPAM installed.
    When using GUI and I select "Managed by service: IPAM", I can not find the service instance from my IPAM server which should be localhost. There is no option in the drop-down menu. I can do this via Powershell and it is also interesting that I did create a new range yesterday. Now that does not work somehow

    My IPAM overview says it is connected to localhost IPAM server.

    Here is a screenshot about the problem:

    Monday, February 20, 2017 6:42 AM

All replies

  • Hi Matt,

    Have you tried to change value of Managed by service? and then check if other services could be found instance.

    >> I can do this via Powershell and it is also interesting that I did create a new range yesterday

    Did you mean that you could achieve the goal by using Powershell?

    Have you found related information on event viewer?

    Please right-click IPv4, and then click Provide name of the address range group, please check if value of this is Device Type.

    Best Regards

    John


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    • Edited by John Lii Tuesday, February 21, 2017 12:39 PM
    Tuesday, February 21, 2017 12:30 PM
  • Hi,

    Under Managed by service menu there are these options: IPAM, Non-MS DHCP, Others and VMM and the service instance drop-down menu is empty in every option.
    I checked from IPAM Settings - Configure custom fields menu that there should be "localhost" built-in value for that Service instance -option.

    I managed before to add range from GUI and there was "localhost" under Service instance menu.
    Now I can create the range only from Powershell with this example command:
    Add-IpamRange -NetworkId 20.20.20.0/24 -CreateSubnetIfNotFound -StartIPAddress 20.20.20.0 -EndIPAddress 20.20.20.255 -ManagedByService IPAM -ServiceInstance localhost

    There is no error and the range is created successfully to the IPAM but if I try to edit the range, the service instance field is shown empty. In the event log there is one Information-log:
    "IPv4 address range 20.20.20.0/24 of type Non-Virtualized having start IP address 20.20.20.0, end IP address 20.20.20.255, managed by IPAM, service instance Localhost and address space Default IP Address Space has been added.IPv4 address range: 20.20.20.0/24"
    No errors in the event log and because from GUI it requires that service instance to be entered, I cant produce an error because OK button is greyed out.

    What do you mean by that checking Device Type value? Here is a screenshot of my address range groups below.
    I did delete just before screenshot my few test groups if that would have helped but not.

    Tuesday, February 21, 2017 8:43 PM
  • I reinstalled the IPAM role and now it seems to find that service instance again. Don't know which suddenly caused that not working because reboots did not work either...

    Do not remember for sure but seems that IP addr. inventory is now populated from DNS host record information which did not also come to the inventory if I recall correctly.

    So now this works but unfortunately do not know the reason why it didn't before...

    Saturday, February 25, 2017 8:38 AM