locked
lost performance counters RRS feed

  • Question

  • Hello,

    We have uninstalled and reinstalled streaming server role and restored it from servernamespace.xml file. After restore, WM Server is working fine but we do not see counters working. Infact counters are missing under Performance & Reliability Monitor.

    OS - Windows 2008 SP2

    I will appreciate any help!


    Jay
    Friday, August 19, 2011 9:56 AM

Answers

All replies

  • Try opening an admin command prompt and go to:

    C:\Windows\inf\WMServer\0409

    Then run the command:

    loadctr.exe wmsperf.ini

     

    See if that helps!

    Tuesday, August 23, 2011 7:01 PM
    Moderator
  • I have same problem.When i tried this solution it failed

    Error: Unable to restore performance counter setting from backup file C:\Windows
    \inf\WMServer\0409\wmsperf.ini, error code is 1006.

    any help will be really appreciated !

    Sunday, September 4, 2011 6:06 PM
  • I ended up reinstalling WMS and adding pubpoints manually. Suggested solution doesn't work.

     


    Jay
    Monday, September 5, 2011 5:38 AM
  • I have 50+ pubpoints and i am having this problem on my 2 new servers(windows 2008 sp2) .Can someone give any solution for this please ???
    Thursday, September 8, 2011 9:16 AM
  • Try this for reloading the performance counters:

    1. Open an administrative command prompt (Start / All Programs / Accessories / Right click on Command Prompt / Run as Administrator).
    2. Type in:
       cd \windows\inf\wmserver
    3. Run the command:
       Lodctr.exe .\0409\wmsperf.ini

    This should hopefully properly load the counters into the registry for US-English versions of the operating system.  Try opening Performance Monitor and see if the Windows Media Services object is listed.  If not, then we may have an additional problem.  The WMS performance registry key may have values that are actually the wrong type.  To inspect / correct this value, do the following:

    1. Start / Run / regedit.exe.
    2. Navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\WMServer\Performance
    3. One of the values in this key is ‘Library’.  This will point to %SystemRoot%\system32\wmsperf.dll, however it may be the wrong type of value.  It *should* be a REG_EXPANDED_SZ.  If it is a REG_SZ then we need to change it.  Only do these next steps if the Library value is REG_EXPANDED_SZ.
       a.  Delete the ‘Library’ value (and only this value).
       b.  Choose Edit / New / Expanded String Value.
       c.  For the name type in:
        Library
       d.  Double click on it and add the value:
        %SystemRoot%\system32\wmsperf.dll

     Hopefully at this will fix the problem. 

    Thursday, September 8, 2011 6:29 PM
    Moderator
  • Library value is already REG_EXPAND_SZ.

    I tried all above solutions you gave but it doesnt solve the problem even I reinstalled wms role but counters are not working :(

    Thursday, September 22, 2011 2:34 PM
  • Thursday, September 22, 2011 7:17 PM
    Moderator