none
Failed Create WIM RRS feed

  • Question

  • I am trying to create a wim of a Surface Pro 3 with windows 8.1.

    I have created the reference image in HyperV; disabled UAC in the registry (this is the only way that sysprep would run off the *.wsf file).

    Sysprep finished ; the system booted into win PE.

    Then halted with following error:

    Litetouch deployment failed, Return Code 2147467259 0x8000424

    Filed to run the Action: Create WIM.

    The specified service does not exists ans an installed service (Error: 00000424 Source: Windows)

    I have searched around and made the following edit to : LITApply.wsf


    ' Copy bootmgr
    '//----------------------------------------------This next line is added as per ms support: 2797676--
    If not oFSO.FolderExists(sBootDrive & "\Boot") then
       oFSO.CreateFolder(sBootDrive & "\Boot")
    End if
    '//------------------------------------------------------

    I am stumped


    jawsurgeon

    Monday, August 7, 2017 4:50 PM

Answers

  • Here is the WinPE Init Log

    2017-08-07 15:36:36.167, Info      WPEINIT is processing the unattend file [X:\unattend.xml]
    2017-08-07 15:36:36.167, Info      Spent 62ms initializing removable media before unattend search
    2017-08-07 15:36:36.182, Info      ==== Initializing Display Settings ====
    2017-08-07 15:36:36.198, Info      Setting display resolution 1024x768x32@60: 0x00000000
    2017-08-07 15:36:36.198, Info      STATUS: SUCCESS (0x00000000)
    2017-08-07 15:36:36.198, Info      ==== Initializing Computer Name ====
    2017-08-07 15:36:36.198, Info      Generating a random computer name
    2017-08-07 15:36:36.198, Info      No computer name specified, generating a random name.
    2017-08-07 15:36:36.198, Info      Renaming computer to MININT-UFU7CS5.
    2017-08-07 15:36:36.198, Info      Waiting on the profiling mutex handle
    2017-08-07 15:36:36.198, Info      Acquired profiling mutex
    2017-08-07 15:36:36.245, Info      Service winmgmt disable: 0x00000000
    2017-08-07 15:36:36.245, Info      Service winmgmt stop: 0x00000000
    2017-08-07 15:36:36.260, Info      Service winmgmt enable: 0x00000000
    2017-08-07 15:36:36.260, Info      Released profiling mutex
    2017-08-07 15:36:36.260, Info      STATUS: SUCCESS (0x00000000)
    2017-08-07 15:36:36.260, Info      ==== Initializing Virtual Memory Paging File ====
    2017-08-07 15:36:36.260, Info      No WinPE page file setting specified
    2017-08-07 15:36:36.260, Info      STATUS: SUCCESS (0x00000001)
    2017-08-07 15:36:36.260, Info      ==== Initializing Optional Components ====
    2017-08-07 15:36:36.260, Info      WinPE optional component 'Microsoft-WinPE-HTA' is present
    2017-08-07 15:36:36.323, Info      WinPE optional component 'Microsoft-WinPE-MDAC' is present
    2017-08-07 15:36:36.323, Info      WinPE optional component 'Microsoft-WinPE-WMI' is present
    2017-08-07 15:36:36.338, Info      WinPE optional component 'Microsoft-WinPE-WSH' is present
    2017-08-07 15:36:36.354, Info      STATUS: SUCCESS (0x00000000)
    2017-08-07 15:36:36.354, Info      ==== Initializing Network Access and Applying Configuration ====
    2017-08-07 15:36:36.354, Info      No EnableNetwork unattend setting was specified; the default action for this context is to enable networking support.
    2017-08-07 15:36:36.354, Info      Global handle for profiling mutex is non-null
    2017-08-07 15:36:36.354, Info      Waiting on the profiling mutex handle
    2017-08-07 15:36:36.354, Info      Acquired profiling mutex
    2017-08-07 15:36:36.657, Info      Install MS_MSCLIENT: 0x0004a020
    2017-08-07 15:36:36.657, Info      Install MS_NETBIOS: 0x0004a020
    2017-08-07 15:36:36.845, Info      Install MS_SMB: 0x0004a020
    2017-08-07 15:36:37.251, Info      Install MS_TCPIP6: 0x0004a020
    2017-08-07 15:36:37.833, Info      Install MS_TCPIP: 0x0004a020
    2017-08-07 15:36:37.833, Info      Service dhcp start: 0x00000000
    2017-08-07 15:36:37.833, Info      Service lmhosts start: 0x00000000
    2017-08-07 15:36:38.005, Info      Service ikeext start: 0x00000000
    2017-08-07 15:36:38.130, Info      Service mpssvc start: 0x00000000
    2017-08-07 15:36:38.146, Info      Service mrxsmb10 start: 0x00000000
    2017-08-07 15:36:38.146, Info      Released profiling mutex
    2017-08-07 15:36:38.146, Info      Spent 1781ms installing network components
    2017-08-07 15:36:38.536, Info      Installing device root\kdnic X:\windows\INF\kdnic.inf succeeded
    2017-08-07 15:36:39.411, Info      Installing device vmbus\{f8615163-df3e-46c5-913f-f2d2f965ed0e} X:\windows\INF\wnetvsc.inf succeeded
    2017-08-07 15:36:39.427, Info      Spent 1281ms installing network drivers
    2017-08-07 15:36:40.502, Info      QueryAdapterStatus: found operational adapter with DHCP address assigned.
    2017-08-07 15:36:40.502, Info      Spent 1015ms confirming network initialization; status 0x00000000
    2017-08-07 15:36:40.502, Info      STATUS: SUCCESS (0x00000000)
    2017-08-07 15:36:40.502, Info      ==== Applying Firewall Settings ====
    2017-08-07 15:36:40.502, Info      STATUS: SUCCESS (0x00000001)
    2017-08-07 15:36:40.502, Info      ==== Executing Synchronous User-Provided Commands ====
    2017-08-07 15:36:40.502, Info      Parsing RunSynchronousCommand: 1 entries
    2017-08-07 15:36:40.502, Info        Command 0: 0x00000000
    2017-08-07 15:37:47.384, Info      Successfully executed command 'wscript.exe X:\Deploy\Scripts\LiteTouch.wsf' (exit code 0x80004005)
    2017-08-07 15:37:47.384, Info      STATUS: FAILURE (0x80004005)
    2017-08-07 15:37:47.384, Info      ==== Executing Asynchronous User-Provided Commands ====
    2017-08-07 15:37:47.384, Info      STATUS: SUCCESS (0x00000001)
    2017-08-07 15:37:47.384, Info      ==== Applying Shutdown Settings ====
    2017-08-07 15:37:47.384, Info      No shutdown setting was specified
    2017-08-07 15:37:47.384, Info      STATUS: SUCCESS (0x00000001)
    2017-08-07 15:37:47.384, Warning   Applying WinPE unattend settings failed with status 0x80004005; ignoring shutdown settings


    jawsurgeon

    • Marked as answer by Jawsurgeon Tuesday, August 8, 2017 1:26 AM
    • Unmarked as answer by Jawsurgeon Tuesday, August 8, 2017 1:26 AM
    • Marked as answer by Jawsurgeon Tuesday, August 8, 2017 1:27 AM
    Monday, August 7, 2017 8:13 PM

All replies

  • here are the entries from the winPE Netsetup log

    08/07/2017 15:36:36:245 -----------------------------------------------------------------
    08/07/2017 15:36:36:245 NetpDoDomainJoin
    08/07/2017 15:36:36:245 NetpDoDomainJoin: using new computer names
    08/07/2017 15:36:36:245 NetpDoDomainJoin: NetpGetNewMachineName returned 0x0
    08/07/2017 15:36:36:245 NetpMachineValidToJoin: 'MININT-UFU7CS5'
    08/07/2017 15:36:36:245 OS Version: 6.3
    08/07/2017 15:36:36:245 Build number: 9600 (9600.winblue_rtm.130821-1623)
    08/07/2017 15:36:36:260 SKU: 
    08/07/2017 15:36:36:260 Architecture: 64-bit (AMD64)
    08/07/2017 15:36:36:260 NetpGetLsaPrimaryDomain: status: 0x0
    08/07/2017 15:36:36:260 NetpMachineValidToJoin: status: 0x0
    08/07/2017 15:36:36:260 NetpJoinWorkgroup: joining computer 'MININT-UFU7CS5' to workgroup 'WORKGROUP'
    08/07/2017 15:36:36:260 NetpValidateName: checking to see if 'WORKGROUP' is valid as type 2 name
    08/07/2017 15:36:36:260 NetpCheckNetBiosNameNotInUse: for 'WORKGROUP' returned: 0x858
    08/07/2017 15:36:36:260 NetpCheckNetBiosNameNotInUse for 'WORKGROUP' [ Workgroup as MACHINE]  returned 0x858
    08/07/2017 15:36:36:260 NetpValidateName: name 'WORKGROUP' is valid for type 2
    08/07/2017 15:36:36:260 NetpSetLsaPrimaryDomain: for 'WORKGROUP' status: 0x0
    08/07/2017 15:36:36:260 NetpJoinWorkgroup: status:  0x0
    08/07/2017 15:36:36:260 NetpDoDomainJoin: status: 0x0


    jawsurgeon

    Monday, August 7, 2017 8:12 PM
  • Here is the WinPE Init Log

    2017-08-07 15:36:36.167, Info      WPEINIT is processing the unattend file [X:\unattend.xml]
    2017-08-07 15:36:36.167, Info      Spent 62ms initializing removable media before unattend search
    2017-08-07 15:36:36.182, Info      ==== Initializing Display Settings ====
    2017-08-07 15:36:36.198, Info      Setting display resolution 1024x768x32@60: 0x00000000
    2017-08-07 15:36:36.198, Info      STATUS: SUCCESS (0x00000000)
    2017-08-07 15:36:36.198, Info      ==== Initializing Computer Name ====
    2017-08-07 15:36:36.198, Info      Generating a random computer name
    2017-08-07 15:36:36.198, Info      No computer name specified, generating a random name.
    2017-08-07 15:36:36.198, Info      Renaming computer to MININT-UFU7CS5.
    2017-08-07 15:36:36.198, Info      Waiting on the profiling mutex handle
    2017-08-07 15:36:36.198, Info      Acquired profiling mutex
    2017-08-07 15:36:36.245, Info      Service winmgmt disable: 0x00000000
    2017-08-07 15:36:36.245, Info      Service winmgmt stop: 0x00000000
    2017-08-07 15:36:36.260, Info      Service winmgmt enable: 0x00000000
    2017-08-07 15:36:36.260, Info      Released profiling mutex
    2017-08-07 15:36:36.260, Info      STATUS: SUCCESS (0x00000000)
    2017-08-07 15:36:36.260, Info      ==== Initializing Virtual Memory Paging File ====
    2017-08-07 15:36:36.260, Info      No WinPE page file setting specified
    2017-08-07 15:36:36.260, Info      STATUS: SUCCESS (0x00000001)
    2017-08-07 15:36:36.260, Info      ==== Initializing Optional Components ====
    2017-08-07 15:36:36.260, Info      WinPE optional component 'Microsoft-WinPE-HTA' is present
    2017-08-07 15:36:36.323, Info      WinPE optional component 'Microsoft-WinPE-MDAC' is present
    2017-08-07 15:36:36.323, Info      WinPE optional component 'Microsoft-WinPE-WMI' is present
    2017-08-07 15:36:36.338, Info      WinPE optional component 'Microsoft-WinPE-WSH' is present
    2017-08-07 15:36:36.354, Info      STATUS: SUCCESS (0x00000000)
    2017-08-07 15:36:36.354, Info      ==== Initializing Network Access and Applying Configuration ====
    2017-08-07 15:36:36.354, Info      No EnableNetwork unattend setting was specified; the default action for this context is to enable networking support.
    2017-08-07 15:36:36.354, Info      Global handle for profiling mutex is non-null
    2017-08-07 15:36:36.354, Info      Waiting on the profiling mutex handle
    2017-08-07 15:36:36.354, Info      Acquired profiling mutex
    2017-08-07 15:36:36.657, Info      Install MS_MSCLIENT: 0x0004a020
    2017-08-07 15:36:36.657, Info      Install MS_NETBIOS: 0x0004a020
    2017-08-07 15:36:36.845, Info      Install MS_SMB: 0x0004a020
    2017-08-07 15:36:37.251, Info      Install MS_TCPIP6: 0x0004a020
    2017-08-07 15:36:37.833, Info      Install MS_TCPIP: 0x0004a020
    2017-08-07 15:36:37.833, Info      Service dhcp start: 0x00000000
    2017-08-07 15:36:37.833, Info      Service lmhosts start: 0x00000000
    2017-08-07 15:36:38.005, Info      Service ikeext start: 0x00000000
    2017-08-07 15:36:38.130, Info      Service mpssvc start: 0x00000000
    2017-08-07 15:36:38.146, Info      Service mrxsmb10 start: 0x00000000
    2017-08-07 15:36:38.146, Info      Released profiling mutex
    2017-08-07 15:36:38.146, Info      Spent 1781ms installing network components
    2017-08-07 15:36:38.536, Info      Installing device root\kdnic X:\windows\INF\kdnic.inf succeeded
    2017-08-07 15:36:39.411, Info      Installing device vmbus\{f8615163-df3e-46c5-913f-f2d2f965ed0e} X:\windows\INF\wnetvsc.inf succeeded
    2017-08-07 15:36:39.427, Info      Spent 1281ms installing network drivers
    2017-08-07 15:36:40.502, Info      QueryAdapterStatus: found operational adapter with DHCP address assigned.
    2017-08-07 15:36:40.502, Info      Spent 1015ms confirming network initialization; status 0x00000000
    2017-08-07 15:36:40.502, Info      STATUS: SUCCESS (0x00000000)
    2017-08-07 15:36:40.502, Info      ==== Applying Firewall Settings ====
    2017-08-07 15:36:40.502, Info      STATUS: SUCCESS (0x00000001)
    2017-08-07 15:36:40.502, Info      ==== Executing Synchronous User-Provided Commands ====
    2017-08-07 15:36:40.502, Info      Parsing RunSynchronousCommand: 1 entries
    2017-08-07 15:36:40.502, Info        Command 0: 0x00000000
    2017-08-07 15:37:47.384, Info      Successfully executed command 'wscript.exe X:\Deploy\Scripts\LiteTouch.wsf' (exit code 0x80004005)
    2017-08-07 15:37:47.384, Info      STATUS: FAILURE (0x80004005)
    2017-08-07 15:37:47.384, Info      ==== Executing Asynchronous User-Provided Commands ====
    2017-08-07 15:37:47.384, Info      STATUS: SUCCESS (0x00000001)
    2017-08-07 15:37:47.384, Info      ==== Applying Shutdown Settings ====
    2017-08-07 15:37:47.384, Info      No shutdown setting was specified
    2017-08-07 15:37:47.384, Info      STATUS: SUCCESS (0x00000001)
    2017-08-07 15:37:47.384, Warning   Applying WinPE unattend settings failed with status 0x80004005; ignoring shutdown settings


    jawsurgeon

    • Marked as answer by Jawsurgeon Tuesday, August 8, 2017 1:26 AM
    • Unmarked as answer by Jawsurgeon Tuesday, August 8, 2017 1:26 AM
    • Marked as answer by Jawsurgeon Tuesday, August 8, 2017 1:27 AM
    Monday, August 7, 2017 8:13 PM
  • I fixed the problem ;

    The issue was that I had entered the network credentials in the options under the create WIM task.

    Once I unchecked that it ran fine.


    jawsurgeon

    • Proposed as answer by Larry_Brown Wednesday, November 27, 2019 2:55 AM
    Tuesday, August 8, 2017 1:27 AM