locked
Context has expired and can no longer be used RRS feed

  • Question

  • Hi everyone,

    if i want to view or edit a list-item i get this message.

    I have tried several ways to get rid of this problem:

    • web application date settings to server date
    • disabled distributed cache 

    nothing helped.

    Any other possibilites ?

    Iam using SharePoint 2013 Enterprise on Windows Server 2008 R2 64-bit.

    Thanks

    BR,

    Atilla

    Friday, July 14, 2017 8:39 AM

All replies

  • Hi Atilla,

    Try to increase the Security Token Service Application life time using the PowerShell command below:

    $sts = Get-SPSecurityTokenServiceConfig
    $sts.FormsTokenLifetime = (New-TimeSpan -minutes 2)
    $sts.WindowsTokenLifetime = (New-TimeSpan -minutes 2)
    $sts.LogonTokenCacheExpirationWindow = (New-TimeSpan -minutes 1)
    $sts.Update()

    After updating, please do IISRest and then to see if it works as expect.

    More information:

    https://sharepoint.stackexchange.com/questions/215563/the-context-has-expired-and-can-no-longer-be-used-exception-from-hresult-0x80

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Monday, July 17, 2017 10:03 AM
  • Hi Jerry,

    i tried it and the problem is there.

    BR,

    Atilla

    Monday, July 17, 2017 3:19 PM
  • Hi,

    Have you tried IISReset ?

    If the issue still exists, please check the SharePoint ULS log for more detailed error information for a better troubleshooting.

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, July 18, 2017 12:43 AM
  • Hi Jerry,

    yes i tried iisreset.

    Sometimes i get this error for the left navigation. It says "an error occured while rendering... the context has expired".

    Could that be a problem caused outside the SharePoint maybe within the active-directory ?

    BR,

    Atilla

    Wednesday, July 19, 2017 7:14 AM
  • Hi,

    This error could related to multiple reasons, for a better troubleshooting, I suggest you can check the ULS log for more detailed information and then find the right troubleshooting direction.

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Thursday, July 20, 2017 1:26 AM
  • Hi Jerry,

    i checked the uls log and i hope you can help me to understand why i get the error message.

    Thanks.

    BR,

    Atilla


    • Edited by Atilla87 Monday, July 24, 2017 3:24 PM
    Monday, July 24, 2017 3:24 PM
  • Hi,

    Did this error happen on just a specific list form or all the list forms ? 

    Thanks

    Best Reagrds


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Tuesday, July 25, 2017 9:24 AM
  • Hi Jerry,

    on display form and edit form.

    BR,

    Atilla

    Tuesday, July 25, 2017 10:00 AM
  • Hi Allita,

    It's very difficult to troubleshooting this issue, as I can't reach your environment, I suggest you can open a ticket to Premier Support so that Microsoft can directly troubleshooting this case in your environment, it will be easier to resolve this issue:

    https://www.microsoft.com/en-us/microsoftservices/support.aspx

    Thanks

    Best Regards


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com

    Friday, August 4, 2017 12:22 PM