locked
Windows 10 on domain apps dont work. RRS feed

  • Question

  • My this is frustrating.

    I am an IT professional. As I am buying new computers I am upgrading these new computers from windows 7 Prof to the free windows 10 Prof.

    I assume that eventually we will all go to win 10 in the future so I'm slowly migrating people as they get new computers.

    Now it is my understanding that the MS store needs to work, to upgrade some programs.

    Before putting the computer on the Domain the store would open and I assume the apps worded as well. I admit that I never tested them because well I don't need or want candy crush and some of the other stupid programs that a company does not need to reduce productivity. I just left some of them alone, but I assumed that some other apps I need.

    Anyway as soon as I put the computer on the domain and then tried to open the store it opens and then closes.

    I have read many many posts and tried many many things but nothing seems to fix this. I'm as confused as ****.  There seem to be so many intrusive things that are on this OS particularly for a business computer on a domain.

    It use to be that I could log in as a local user and the store would work. Now that seems broken too.

    Now when I try to open some apps they just don't open. When I logged on  as network admin I get some error about cant open because its using local admin. As a domain user when I open groove for example it opens then closes, same for the weather charm for example.

    I tried reinstalling, installing windows 7 from Lenovo partition, then upgrading to win10  again using CD. Basically same problem.

    As I say I have tried many many things. Is there any answers out there for this store **** that I'm stuck in.

    I'm not sure if anyone can help. As I say I have looked on net and tried many things, some do appear to be for win8. Some don't work at all like running some powershell commands.

    I'm frustrated. I told an end user I would have a computer to them 2 days ago but for 2 days I have reinstalled and tried a number of fixes. all for nothing. I'm considering just sticking to win7.

    Has anyone got any possible solutions.

    thanks?

    PS to anyone from MS that is reading. I'm confused why you design an os eg win10 that I suppose is for a phone but not a pc. I don't want games, and the stupid OS asks about Wifi and a number of things like that which this computer and none of my computers have. Cant it be smart enough to know if there is a wifi card. Also I don't want a ms live account. We use office 365. But there is soooo much confusing on the net regarding accounts Live/Outlook/365 I don't know whether I'm coming or going.

    Tuesday, April 5, 2016 4:28 PM

All replies

  • Have you checked if there is a GPO blocking the Store or Microsoft Account? 

    Regards dont want to use a Microsoft Account, you can use the Office365 account together with Windows Store for Business and allow your users to get apps based on that account insted of the Microsoft Account. 

    That means that IT Admin need to provide the actual apps through the Business Store Portal, but that is not hard to do. To be able to automaticly sign your users into the Store for Business you will also need to register your domain joined devices in Azure AD. 

    Some links on the last part: 

    http://jankesblog.com/2016/01/20/why-and-how-you-should-register-your-windows-10-domain-joined-pcs-with-azure-ad/

    http://jankesblog.com/2016/03/26/microsoft-intune-integrate-windows-store-for-business/

    https://technet.microsoft.com/en-us/library/mt606938(v=vs.85).aspx


    Regards,

    Jan Ketil Skanke

    Senior Consultant - Lumagate AS

    Partner-TSP Enterprise Mobility - Microsoft

    Blog: http://jankesblog.com

    Note: If my respons helps you solve your issue, please mark as answered

    Tuesday, April 5, 2016 10:09 PM
  • Hello,

    Please check registry permissions and see if that helps you (applies to Windows 10 as well):

    http://www.kapilarya.com/fix-app-minimizes-or-closes-itself-in-windows-8

    Hope this helps, Good luck :)

    Windows Troubleshooting & How to guides - http://www.kapilarya.com

    Wednesday, April 6, 2016 1:59 AM
  • Hi 288,

    The main issue is that the store app won`t work after joining to the domain but it works when the machine is not in the domain, right?  Are all the machines up to date? Are there any related error messages recorded in the Event Viewer(Windows Logs\Application or Applications and Services\Microsoft\Windows\Appx, Appxployment)

    Are you using roaming profile?
    There is a known issue that the roaming profile won`t work well with the Metro apps. This bug is fixed on Windows 10 Insider Build 14279 (confirmed), but now MS know this issue and we require a hotfix for Windows 10 1511. We could try the following command line as a workaround.
    Remove-Item -Recurse -Force -Path $env:LOCALAPPDATA\Packages\Microsoft.MicrosoftEdge_8wekyb3d8bbwe
    Get-AppXPackage -Name 'Microsoft.MicrosoftEdge' | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register “$($_.InstallLocation)\AppXManifest.xml”}
    Scripts:
    #!PowerShell. De pilo pendet.
    function MakeACE() {
        # S-1-15-2-1 is WELL_KNOWN_SID_TYPE::WinBuiltinAnyPackageSid, "APPLICATION PACKAGE AUTHORITY\ALL APPLICATION PACKAGES".
        # The self-documenting NTAccount type results in an object that "cannot be translated".
        $id = New-Object System.Security.Principal.SecurityIdentifier("S-1-15-2-1")
        New-Object System.Security.AccessControl.RegistryAccessRule($id,
                                                                    [System.Security.AccessControl.RegistryRights]::FullControl,
                                                                    [System.Security.AccessControl.InheritanceFlags]::ContainerInherit,
                                                                    [System.Security.AccessControl.PropagationFlags]::None,
                                                                    [System.Security.AccessControl.AccessControlType]::Allow)
    }        
    function GrantRequiredAccess($key) {

        $acl = Get-Acl $key
        $acl.AddAccessRule((MakeACE))
        Set-Acl $key $acl
    }

    # All Windows 10, since Microsoft apparently managed to break build 10240 as well in December 2015, after having shipped 10586 broken from the start.
    if ([Environment]::OSVersion.Version.Major -eq 10) {
        GrantRequiredAccess "HKCU:\Software\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.microsoftedge_8wekyb3d8bbwe"
        GrantRequiredAccess "HKCU:\SOFTWARE\Classes\Local Settings\Software\Microsoft\Windows\CurrentVersion\AppContainer\Storage\microsoft.windows.cortana_cw5n1h2txyewy"
    }
    Add other metro apps to the Grant area to fix news, sports, ....

    Considering the issue occurred after joining the machine to the domain, we could refer to the following link to have a troubleshoot. The theory should be applied to Windows 10, too.
    Windows 8.1 Store Apps Won’t Open (Or Close Immediately) when logged on as a domain user. Make it stop! (Updated 3/14/2015)
    https://blogs.technet.microsoft.com/ouc1too/2014/07/22/windows-8-1-store-apps-wont-open-or-close-immediately-when-logged-on-as-a-domain-user-make-it-stop/

    "When I logged on  as network admin I get some error about cant open because its using local admin"

    Try the following group policy:User Account Control: Admin Approval Mode for the built-in Administrator account (GPO_name\Computer Configuration\Windows Settings\Security Settings\Local Policies\Security Options)

    Best regards


    Please remember to mark the replies as answers if they help, and unmark the answers if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.




    Wednesday, April 6, 2016 7:30 AM
  • I appreciate all of the answers. I have tried them all and many more. People seem to indicate its permissions issue. But despite adjusting permissions in safe mode, in registry in , programs, in programs (86), deleting various caches, reinstalling apps etc etc. after over a week of frustration, Im out.

    I completely give up. I'm reloading windows 7. And going to pass on win10. Particularly for a business with active directories. What ever the current version is it doesn't seem to run on a new Lenovo computer.

    Thanks for your help.

    Regards

    Thursday, April 7, 2016 1:52 PM
  • Terribly sorry you're having a frustrating time.

    If you still have access to the machine, could you try the following please?

    Win7 -> Upgrade to W10 -> Repro your issue -> Reset the device (Settings -> Update & Recovery -> Reset this PC) -> This is the equivalent of a clean W10 install

    At this point, try and create a local account and check the store, then join the domain and then try accessing the store.

    Monday, May 9, 2016 11:07 PM
  • I have had the same issue as the original poster. I have reset the device and joined the domain sucessfully but once I updated and restarted the computer, it did not work.

    Any solid help would be appreciated, otherwise we will be forced to avoid store installed applications. 

    Friday, July 8, 2016 8:26 PM
  • Sorry to necro this thread, but I wanted to add a possible solution for the historical record. Our company was having the exact same problem with Windows 10 Apps on domain computers with roaming profiles. The ultimate solution was to check permissions on the C:\Program Files\WindowsApps folder and apply them appropriately. After giving the domain user full control to this folder, everything opened normally. Obviously I cannot suggest giving full control of the folder to "Everyone" (cough) but this did alleviate the problem.
    Friday, January 26, 2018 7:40 PM