Android VPN connection keeps droppingseconds after connecting RRS feed

  • Question

  • I setup L2TP/IPSec VPN with PSK on TMG 2010 but when connecting an Android device, the VPN connection keeps dropping seconds after connecting. All other devices are fine.

    I have found the hotfix that would almost certainly fix the issue, the link to it however (http://support.microsoft.com/kb/2722729) isn't working.

    I've checked if it is included in this month's updates for TMG but it isn't.

    Does anyone have any suggestions? Surely, there must be thousands of Android users out there who connect to a TMG firewall for their VPN.


    Marco S

    Wednesday, September 19, 2012 1:08 PM


All replies

  • Hi,

    Thank you for the post.

    I have tested in my side, it seems lack of English language version. But this will not affect all other versions, e.g. you can access http://support.microsoft.com/kb/2722729/de. And I will inform this issue to our relative team and update this thread later on.


    Nick Gu - MSFT

    Thursday, September 20, 2012 5:58 AM
  • Hi Nick

    The download link for the hotfix isn't actually working:

    Hotfix Request

    The KB article has no public hotfixes. Please contact support if you need immediate assistance.


    I'll wait for your update then- thanks.

    Marco S

    Thursday, September 20, 2012 9:16 AM
  • Microsoft have now informed me that they are revising this hotfix and that it will be unavailable until the issues with it are fixed.

    Marco S

    Monday, September 24, 2012 3:31 PM
  • Any news on this?

    I have same issue here and KB is still not working.

    ---------- Ondrej Zilinec - Cievo ----------

    Friday, October 5, 2012 11:53 AM
  • I logged a call with Microsoft. Initially, I got this response

    "That hot fix is still not available.

    However on discussion with my Technical Lead, we reached the conclusion that if all the latest windows updates are installed and the version of “Mprddm.dll” is higher than “6.1.7601.22044”, the Hotfix would not be required. Please check the version number and let me know. Also please advise the version of the TMG."

    Followed by:

    "As discussed, please find below the links to install Rollup 1 and Rollup 2 for TMG 2010 SP2:
    Rollup 1 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 2:
    Rollup 2 for Forefront Threat Management Gateway (TMG) 2010 Service Pack 2:
    Please restart the server once after the installation of both the updates.
    Please confirm the version number of both TMG and the dll once done."

    This didn't fix the problem and the latest is:

    " It seems the concerned hot fix has been retired.
    We are awaiting an update from the relevant team (Networking Team who associate with the concerned dll) regarding a replacement Hotfix or Service Pack for the same.
    I will keep you posted.
    Thank you again for your time and patience."

    So, still waiting...

    Marco S

    Friday, October 5, 2012 2:11 PM
  • Finally, they have updated the original KB link with a hotfix that should work:


    Marco S

    • Proposed as answer by Ing. Ondrej Žilinec Thursday, October 11, 2012 8:58 AM
    • Marked as answer by Mark-199 Tuesday, October 16, 2012 8:52 AM
    Thursday, October 11, 2012 7:14 AM
  • Yes, I have to agree. It works now.

    Thank you.

    ---------- Ondrej Zilinec - Cievo ----------

    Tuesday, October 16, 2012 9:20 AM