locked
SCCM Package Transefer RRS feed

  • Question

  • After completing a SCCM restore I am trying to redistribute content to another distribution point.  I am getting the error below.  I have also posted logs from PkgXferMgr.log.  Please give me any thoughts thanks.

    Package Transfer Manager failed to update the package "TR300071", Version 9 on distribution point servername. Review PkgXferMgr.log for more information about this failure.

    Possible cause: Site server does not have sufficient rights to the source directory.
    Solution: Verify that the site server computer account has at least Read access to the directory you specify as the source directory.

    Possible cause: There is not enough disk space available on the distribution point.
    Solution: Verify that there is enough free disk space available on the distribution point.

    Failed to notify PullDP. check \\*\SMS_DP$\sms\logs\smsdpprov.log  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:16.929+300><thread=1084 (0x43C)>
    ~ PullDP Notification failed. Failure count = 2/30, Restart time = 12/30/2016 9:39:16 AM Eastern Standard Time  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:16.929+300><thread=1084 (0x43C)>
    STATMSG: ID=8211 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_PACKAGE_TRANSFER_MANAGER" SYS=* SITE=* PID=2840 TID=1084 GMTDATE=Fri Dec 30 14:19:16.931 2016 ISTR0="TR300071" ISTR1="9" ISTR2="QT-U-IMG-01.TECHRESP.NET" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=3 AID0=400 AVAL0="TR300071" AID1=410 AVAL1="9" AID2=404 AVAL2="["Display=\\*\"]MSWNET:["SMS_SITE=*"]\\*\"  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:16.931+300><thread=1084 (0x43C)>
    Pull DP Sending thread complete~  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:16.934+300><thread=1084 (0x43C)>
    No (more) send requests found to process.~  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:16.941+300><thread=6268 (0x187C)>
    ~Waiting for new/rescheduled send requests, Maximum Sleep Time = 20 minutes  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:16.942+300><thread=6268 (0x187C)>
    Failed to notify PullDP. check \\*\SMS_DP$\sms\logs\smsdpprov.log  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:17.093+300><thread=540 (0x21C)>
    ~ PullDP Notification failed. Failure count = 2/30, Restart time = 12/30/2016 9:39:17 AM Eastern Standard Time  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:17.093+300><thread=540 (0x21C)>
    STATMSG: ID=8211 SEV=E LEV=M SOURCE="SMS Server" COMP="SMS_PACKAGE_TRANSFER_MANAGER" SYS=QT-U-SCCM-01.techresp.net SITE=TR3 PID=2840 TID=540 GMTDATE=Fri Dec 30 14:19:17.095 2016 ISTR0="TR300036" ISTR1="5" ISTR2="*" ISTR3="" ISTR4="" ISTR5="" ISTR6="" ISTR7="" ISTR8="" ISTR9="" NUMATTRS=3 AID0=400 AVAL0="TR300036" AID1=410 AVAL1="5" AID2=404 AVAL2="["Display=*"]MSWNET:["SMS_SITE=TR3"]\\*\"  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:17.095+300><thread=540 (0x21C)>
    Pull DP Sending thread complete~  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:17.098+300><thread=540 (0x21C)>
    No (more) send requests found to process.~  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:17.105+300><thread=6268 (0x187C)>
    ~Waiting for new/rescheduled send requests, Maximum Sleep Time = 20 minutes  $$<SMS_PACKAGE_TRANSFER_MANAGER><12-30-2016 09:19:17.105+300><thread=6268 (0x187C)>

    Friday, December 30, 2016 2:31 PM

All replies

  • Did yu check the log file noted above: \\*\SMS_DP$\sms\logs\smsdpprov.log ?

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Friday, December 30, 2016 3:02 PM
  • [18E0][Fri 12/30/2016 10:40:38]:Failed to validate IIS and ShareFolder configurations. Return code: 0x80070002
    [18E0][Fri 12/30/2016 10:40:38]:RegQueryValueExW failed for Software\Microsoft\SMS\DP, ContentLibUsableDrives
    [18E0][Fri 12/30/2016 10:40:38]:RegReadString failed; 0x80070002
    [18E0][Fri 12/30/2016 10:40:38]:Failed to GetDPUsableDrives. error = 0x80070002

    Not sure what this means

    Friday, December 30, 2016 3:53 PM
  • I unchecked the DP pull setting and rechecked it and got the following:

    [18E0][Fri 12/30/2016 10:40:38]:Failed to validate IIS and ShareFolder configurations. Return code: 0x80070002
    [9B0][Fri 12/30/2016 10:44:48]:CcmInstallPXE
    [9B0][Fri 12/30/2016 10:44:48]:PXE provider is already installed.
    [9B0][Fri 12/30/2016 10:44:48]:Installed PXE
    [9B0][Fri 12/30/2016 10:44:48]:A DP health monitoring task has been deleted successfully
    [9B0][Fri 12/30/2016 10:44:49]:CSMSDPInstProv::EnableDPUsageStatsGathering entered
    [9B0][Fri 12/30/2016 10:44:49]:1998-01-01T00:00:00
    [9B0][Fri 12/30/2016 10:44:49]:A DP usage gathering task has been registered successfully
    [156C][Fri 12/30/2016 10:45:07]:Started process msiexec.exe /x {C1637FAB-51F2-4BF6-8084-FB17DCC74640} /qn /log G:\SMS_DP$\sms\logs\pulldp_install.log
    [156C][Fri 12/30/2016 10:45:13]:CcmInstallPXE
    [156C][Fri 12/30/2016 10:45:13]:PXE provider is already installed.
    [156C][Fri 12/30/2016 10:45:13]:Installed PXE
    [156C][Fri 12/30/2016 10:46:53]:CcmInstallPXE
    [156C][Fri 12/30/2016 10:46:53]:PXE provider is already installed.
    [156C][Fri 12/30/2016 10:46:53]:Installed PXE
    [156C][Fri 12/30/2016 10:46:53]:A DP health monitoring task has been deleted successfully
    [156C][Fri 12/30/2016 10:46:53]:CSMSDPInstProv::EnableDPUsageStatsGathering entered
    [156C][Fri 12/30/2016 10:46:53]:1998-01-01T00:00:00
    [156C][Fri 12/30/2016 10:46:53]:A DP usage gathering task has been registered successfully
    [156C][Fri 12/30/2016 10:47:14]:AlgID property is not valid
    [156C][Fri 12/30/2016 10:47:14]:No pulldp is currently installed.
    [156C][Fri 12/30/2016 10:47:14]:Started process G:\SMS_DP$\sms\bin\vcredist_x64.exe /q /norestart /l G:\SMS_DP$\sms\logs\vcredist.log
    [156C][Fri 12/30/2016 10:47:14]:Waiting for the completion of: G:\SMS_DP$\sms\bin\vcredist_x64.exe /q /norestart /l G:\SMS_DP$\sms\logs\vcredist.log
    [9B0][Fri 12/30/2016 10:47:18]:CcmInstallPXE
    [9B0][Fri 12/30/2016 10:47:18]:PXE provider is already installed.
    [9B0][Fri 12/30/2016 10:47:18]:Installed PXE
    [156C][Fri 12/30/2016 10:47:19]:Run completed for: G:\SMS_DP$\sms\bin\vcredist_x64.exe /q /norestart /l G:\SMS_DP$\sms\logs\vcredist.log
    [156C][Fri 12/30/2016 10:47:19]:Started process msiexec.exe /quiet /i G:\SMS_DP$\sms\bin\pulldp.msi /log G:\SMS_DP$\sms\logs\pulldp_install.log

    Friday, December 30, 2016 4:06 PM
  • Looks like your DP may not have been updated correctly after the restore and the above log shows the DP getting reinstalled.

    Jason | http://blog.configmgrftw.com | @jasonsandys

    Friday, December 30, 2016 6:21 PM
  • Well I unchecked the DP Pull and the PXE option to get it to reinstall again.  Not sure if that is what you mean.  The DP shows that its installed.  I keep getting the following errors.

    [7D8][Fri 12/30/2016 13:03:09]:Failed to validate IIS and ShareFolder configurations. Return code: 0x80070002
    [7D8][Fri 12/30/2016 13:03:09]:RegQueryValueExW failed for Software\Microsoft\SMS\DP, ContentLibUsableDrives
    [7D8][Fri 12/30/2016 13:03:09]:RegReadString failed; 0x80070002
    [7D8][Fri 12/30/2016 13:03:09]:Failed to GetDPUsableDrives. error = 0x80070002

    [7D8][Fri 12/30/2016 13:03:09]:Failed to validate IIS and ShareFolder configurations. Return code: 0x80070002
    [10EC][Fri 12/30/2016 13:23:30]:RegQueryValueExW failed for Software\Microsoft\SMS\DP, ContentLibUsableDrives
    [10EC][Fri 12/30/2016 13:23:30]:RegReadString failed; 0x80070002
    [10EC][Fri 12/30/2016 13:23:30]:Failed to GetDPUsableDrives. error = 0x80070002

    [10EC][Fri 12/30/2016 13:23:30]:Failed to validate IIS and ShareFolder configurations. Return code: 0x80070002
    [10EC][Fri 12/30/2016 13:23:30]:RegQueryValueExW failed for Software\Microsoft\SMS\DP, ContentLibUsableDrives
    [10EC][Fri 12/30/2016 13:23:30]:RegReadString failed; 0x80070002
    [10EC][Fri 12/30/2016 13:23:30]:Failed to GetDPUsableDrives. error = 0x80070002

    [10EC][Fri 12/30/2016 13:23:30]:Failed to validate IIS and ShareFolder configurations. Return code: 0x80070002

    Friday, December 30, 2016 6:26 PM
  • Thanks. I ended up unchecking the pxe and DP pull options on the DP. After that I checked the pxe and didn't reinstall the DP pull and things are working.
    Sunday, January 1, 2017 1:52 AM