none
Not able to Scan MFA code after resetting my iOS RRS feed

  • Question

  • Hi All,

    I'm unable to setup my work account on the Authenticator app as it's unable to scan the QR code on phone, it keeps on saying "QR Code was already been used"  tried to enter the code manually but still does the same thing.

    The Device is iOS which I recently reset with new OS and Authenticator app was working perfectly before the reset.

    And even there is no existing account is visible in the authenticator app which I can remove. Did a fresh installation of the app and mfa reset but no luck.

    What should be done here?





    Friday, March 23, 2018 9:33 AM

All replies

  • Hi Rahul,

    Have you marked your iphone as trusted?

    If yes, maybe you can try to use "Restore two-step verification".

    More information about restore, please refer to this article.

    Also, you can try to enter account name and key in your configuration page:

    Best regards,

    Jason Ye


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    Tuesday, March 27, 2018 9:16 AM
  • Hi jason,

    1. Reset the user MFA method still same issue.
    2. Did fresh installation of the MFA app on the device still no go.
    3. When ever scanning getting the same error code. "QR Code was already been used"

    Anything else we can try here...

    Wednesday, March 28, 2018 12:54 PM
  • Quick Analysis:

    1. If we have already setup our work account on MFA app on a device and if we try to remove and setup the same account on the same device the MFA authenticator app will not allow you to setup MFA again with same account.
    2. All the testing performed here were done on iOS devices (Version: 11.2.6) not sure how android behaves here.
    3. This turns out to be a bug in the MFA app. Tried testing on the new MFA authenticator for iOS version 5.6.1 which just got released yesterday but experiencing same issue.

    BUG in the MFA app !!!!!

    Wednesday, March 28, 2018 3:48 PM
  • Tried "Require users to provide contact methods again" tried it two times. No Luck.

    I can only use one-way SMS as MFA method.

    I'll recommend try this on your test account and test environment over iOS.

    1. Setup MFA app on your iOS with your work account.
    2. Next remove the work account from your MFA app. Now try QR code scanning again if it fails.
    3. Perform "Require users to provide contact methods again" https://docs.microsoft.com/en-us/azure/multi-factor-authentication/multi-factor-authentication-manage-users-and-devices
    4. After MFA reset try to scan the new code again.

    Please let me know your experience.

    Thursday, March 29, 2018 9:02 AM
  • Are you getting a new QR code each time? Are you an AzureMFA cloud service user? If so, be sure to access http://aka.ms/mfasetup. 
    Wednesday, April 4, 2018 7:30 PM