locked
WSUS Role on Server 2012 R2 fails - SQL Server Error "Schema Verification Failed SUSDB" RRS feed

  • Question

  • Server is Windows Server 2012R2

    After installing the WSUS role with WID, when running the post installation task it installs the SUSDB in single user mode, runs all its scripts but then when it tries to set it it MULTI mode it fails with the error:

    Schema Verification Failed SUSDB

    If I log onto SQL Management Studio and try to set the database SUSDB to MULTI user mode manually it fails with the same error.

    Detaching, deleting the susdb.mdf and .ldf files and re-running the post-installation task fails on the same error.

    Uninstalling the WSUS and WID roles, deleting the C:\Windows\WID folder and reinstalling everything once again gives the same error during post installation.

    Seems like a nasty bug.

    Does anyone have any ideas? Perhaps there is a way to debug "Schema Verification Failed" errors in SQL Server?

    Thursday, April 23, 2015 10:01 PM

All replies

  • Hi,

    If the WID can't access "C:\Windows\WID\Binn\DBVerify\SUSDBVerify.dll", this issue may occur.

    Please change the account of WID to local system account in services.msc, then restart the WID service.

    Then try to start the post-install again.

    If issue persists, please check the detailed information of WID log.

    Best Regards. 


    Steven Lee Please remember to mark the replies as answers if they help and unmark them if they provide no help. If you have feedback for TechNet Support, contact tnmff@microsoft.com.

    Sunday, April 26, 2015 2:32 PM
  • Hi Steven,

    It was worth trying but no luck with that I'm afraid.

    Running processmonitor during the post installation show no access denied attempts on any files.

    Still the same error no matter what when trying to mount the database as MULTI_USER (even if we remove the C:\Windows\WID\Binn\DBVerify\SUSDBVerify.dll file it's the same error):

    Schema verification failed for database 'SUSDB'.

    Sunday, April 26, 2015 8:35 PM
  • Same issue here.

    Try to grant explicit permission on "C:\Windows\WID\Binn\DBVerify\SUSDBVerify.dll" to WID service account but no change.

    Try to restore backup when WSUS working properly => Same error "Schema Verification Failed SUSDB" when attaching SUSDB.

    If I switch the database to single user mode I can explore the database and table content.

    BUT I can't  switch back into multi user mode since "Schema Verification Failed SUSDB".

    Kind regards



    Monday, May 30, 2016 9:55 AM
  • I've found a "workaround" to this issue.

    Observing WID SQL logs, I've found why schema validation failed :

    - 3 fields in table tbFile were missing :

        dbo.tbFile.IsSecure.sys.bit(1)
        dbo.tbFile.DecryptionKey.sys.varbinary(-1) => which means varbinary(max)
        dbo.tbFile.IsEncrypted.sys.bit(1)

    I've change SUSDB mode to SINGLE_USER, create the missing fields in tbFile, then I was able to set up the SUSDB online in multi_user mode.

    BUT, WSUS console still not working.

    You've to remove WSUS role

    Restart the server

    Reinstall WSUS Role (keep the same settings storage/DB location during post-install configuration)

    Then your WSUS should now work.

    Monday, May 30, 2016 1:07 PM
  • I have a similar issue but not with missing the table named above. rather with unexpected table.

    ...

    2017-05-20 22:58:19.91 spid55      The following columns are unexpected:

        dbo.sysdiagrams.name.sys.sysname(256)

        dbo.sysdiagrams.principal_id.sys.int(4)

        dbo.sysdiagrams.diagram_id.sys.int(4)

        dbo.sysdiagrams.version.sys.int(4)

        dbo.sysdiagrams.definition.sys.varbinary(-1)

    2017-05-20 22:58:19.91 spid55      Database verification script failed for database 'SUSDB'.

    ...

    Created new question to this issue. Schema Verification Failed

    https://social.technet.microsoft.com/Forums/windowsserver/en-US/ae3c44c6-b094-42b6-9093-e02f8bd97323/wsus-service-on-server-2012-r2-fails-after-installing-kb4012213-sql-server-error-quotschema?forum=winserverwsus



    kailar

    Saturday, May 20, 2017 9:48 PM
  • I had the same issues with 3 fields in table tbFile. I could resolve this by following the steps in https://support.microsoft.com/en-us/help/3159706/update-enables-esd-decryption-provision-in-wsus-in-windows-server-2012

    I had to do the postinstall of WSUS to solve the issue:

    "C:\Program Files\Update Services\Tools\wsusutil.exe" postinstall /servicing

    • Proposed as answer by TheManInOz Thursday, April 5, 2018 1:41 AM
    Thursday, July 13, 2017 8:08 AM
  • For Google.

    I had this problem today on a new VM 2012 R2 with just WSUS. Was downloading updates fine, then this morning ...

    1. Console doesn't load - Reset Server Node
    2. Error about SUSDB not accessible
    3. SUSDB in Recovery state
    4. WID log shows errors about missing fields for encryption

    The fix was to run postinstall as above

    Thursday, April 5, 2018 1:43 AM