locked
External USB 3 Hard Drive Won't Mount at Startup RRS feed

  • Question

  • I have a Western Digital external 3TB USB 3.0 hard drive that I have used for over a year now.  I used it with Windows 7 without any problems.  I just upgraded to Windows 8.  I can get the drive to work, but only if I unplug the USB cable and plug it back in every time I restart the machine.  Once it's recognized I have no problems until I reboot.  Then it does not show up anywhere (Device Manager, Disk Management, etc.).  Once I unplug and plug back in the USB cable it shows up right away.

    Any ideas how I can fix this?

    Saturday, November 3, 2012 10:01 PM

Answers

  • I discovered it is a problem with the USB 3.0 PCI Express card that I have.  When I move the drive to one of the on-board USB 2.0 slots, it is mounted at boot as expected.

    New Windows 8 supported card on the way.

    • Edited by jbhardman1 Saturday, November 10, 2012 11:45 PM
    • Proposed as answer by Andre.ZieglerEditor Sunday, November 11, 2012 4:05 PM
    • Marked as answer by Arthur Xie Tuesday, November 20, 2012 8:41 AM
    Saturday, November 10, 2012 11:44 PM

All replies

  • You may contact WD support and ask if they have released drivers for Windows 8 to resolve this issue.


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread. ”

    Tuesday, November 6, 2012 6:42 AM
  • I discovered it is a problem with the USB 3.0 PCI Express card that I have.  When I move the drive to one of the on-board USB 2.0 slots, it is mounted at boot as expected.

    New Windows 8 supported card on the way.

    • Edited by jbhardman1 Saturday, November 10, 2012 11:45 PM
    • Proposed as answer by Andre.ZieglerEditor Sunday, November 11, 2012 4:05 PM
    • Marked as answer by Arthur Xie Tuesday, November 20, 2012 8:41 AM
    Saturday, November 10, 2012 11:44 PM