none
Resolve SQL Aliases for SharePoint Farm - not working RRS feed

  • Question

  • Hi, I have a SharePoint Farm 2010 with SQL Server 2008 R2 with SQL Aliases configured. Rolled out all the dpm 2010 agents. On one WFE server did configuresharepoint with all switches used (also did the enableAllSQLAliases). I installed the SQL 2008 R2 client connectivity tools on the WFE where I did the configuresharepoint (was not sure which one to install, so I choose all from teh SQL Setup wizard that had the client connecitiy in it). I see the sql aliases when using the sql client tool. Is there anything else I am supposed to do? When I try to backup the SharePoint Farm it throws an error saying that somehting is missing (like SharePoint on the Application farm, or SQL Server 2008 on the SQL-DB) so I am assuming that it is not able to resolve the Aliases for my SQL-DB of SharePoint. Please anyone knows what else I have to do so that DPM 2010 is able to resolv the aliases?
    Thursday, May 12, 2011 1:18 PM

All replies

  • You can check if the SharePoint writer is reporting all the databases with this command.

    vshadow.exe -wm2 > WriterMetadata.txt

    To check if the alias resolution by SharePoint writer is happening correctly,

    In WriterMetadata.txt, for each of the components of SharePoint writer check that the dependency does not contain SQL alias in it.

    It should be of the format \\MachineName\MachineName\SQLInstanceName\DatabaseName. Instead of machineName or instanceName, if it contains alias, then alias needs to be configured correctly, may be alias is not added in the correct namespace. In the SQL Configuration manager, you can check if the aliases are present in the correct namespace(SQL Native Client 10.0 Configuration and not  SQL Native Client 10.0 Configuration(32bit))


    This posting is provided "AS IS" with no warranties, and confers no rights
    Thursday, June 2, 2011 9:26 AM
    Moderator
  • See if this will help you.  Its an explanation on all that is required to setup SQL Aliasing in a SharePoint Environment.

    http://support.microsoft.com/kb/2543859


    Walt W [MSFT] This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, June 23, 2011 2:30 PM
    Moderator
  • Hi, I have a SharePoint Farm 2010 with SQL Server 2008 R2 with SQL Aliases configured. Rolled out all the dpm 2010 agents. On one WFE server did configuresharepoint with all switches used (also did the enableAllSQLAliases). I installed the SQL 2008 R2 client connectivity tools on the WFE where I did the configuresharepoint (was not sure which one to install, so I choose all from teh SQL Setup wizard that had the client connecitiy in it). I see the sql aliases when using the sql client tool. Is there anything else I am supposed to do? When I try to backup the SharePoint Farm it throws an error saying that somehting is missing (like SharePoint on the Application farm, or SQL Server 2008 on the SQL-DB) so I am assuming that it is not able to resolve the Aliases for my SQL-DB of SharePoint. Please anyone knows what else I have to do so that DPM 2010 is able to resolv the aliases?
    Try the steps on this post: http://www.ms4u.info/2011/07/dpm-cannot-protect-your-windows.html

    My Blog | www.buchatech.com | www.systemcenterdataprotectionmanager.com
    Sunday, July 17, 2011 9:15 PM
    Moderator