none
IE8 or IE10 not caching (downloading .xsl file into Internet temporary files folder) when in VPN RRS feed

  • Question

  • Hi,

    We have a third party web application (ASP) that when it is being accessed internally (within corp network), it works fine with IE8 or IE10 with Compatibility view.  However, when we access the web application via VPN, we are getting an "Internal Error: Unhandled error loading XML document (file) ../taskmanager/task-manager_preformat_email.xsl, error:System error -2146697189".  After digging and troubleshooting, I found out that this .xsl file is supposed to be downloaded to the C:\Users\user_name\AppData\Local\Microsoft\Windows\Temporary Internet Files folder.  However, it doesn't when in VPN. I tried to change some settings in IE and registry as well but no success.  

    Anyone has idea?

    Thanks.
    Tuesday, December 10, 2013 3:21 PM

Answers

  • Hi,

    From the description, it indicate that we cannot access the ASP application through VPN. From the perspective of network, I suggest to disable SMB2.0 and flush CSC cache.

    Disable SMB2.0

    Disable the caching on Client(win7) via the following registry settings.

    Open regedit.exe and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

    Create the following REG_DWORD with the value =0

    FileInfoCacheLifetime = 0

    FileNotFoundCacheLifetime = 0

    DirectoryCacheLifetime = 0

    Restart the client.

    Flush CSC cache

    If the CSC cache is corrupt. Please access the shared folder. This is to bypass CSC so that the access will not be satisfied with cache.

    \\servername$NOCSC$\shared folder

    If we could view all the shared folder through the command above. Please kind check the specific cache under the path %system%\CSC\.

    Plese kindly refer to the article kb 942974.

    If the issue is persistent. Please gather the traffic when the issue happens.

    Download Microsoft Network Monitor Tool from the following link and install it on the two machines.

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=983b941d-06cb-4658-b7f6-3088333d062f

    Best Regards,

    Steven Song


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, December 17, 2013 1:33 AM

All replies

  • error -2146697189".
    0x800C001B INET_E_BLOCKED_REDIRECT_XSECURITYID

    http://joshpoley.blogspot.ca/2011/09/hresults-facilityinternet.html

    (BING search for
        0x800C001B
    )

    FWIW I would try using ProcMon to compare the two cases.



    Robert Aldwinckle
    ---

    Tuesday, December 10, 2013 4:05 PM
    Answerer
  • Hi,

    From the description, it indicate that we cannot access the ASP application through VPN. From the perspective of network, I suggest to disable SMB2.0 and flush CSC cache.

    Disable SMB2.0

    Disable the caching on Client(win7) via the following registry settings.

    Open regedit.exe and navigate to HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\LanmanWorkstation\Parameters

    Create the following REG_DWORD with the value =0

    FileInfoCacheLifetime = 0

    FileNotFoundCacheLifetime = 0

    DirectoryCacheLifetime = 0

    Restart the client.

    Flush CSC cache

    If the CSC cache is corrupt. Please access the shared folder. This is to bypass CSC so that the access will not be satisfied with cache.

    \\servername$NOCSC$\shared folder

    If we could view all the shared folder through the command above. Please kind check the specific cache under the path %system%\CSC\.

    Plese kindly refer to the article kb 942974.

    If the issue is persistent. Please gather the traffic when the issue happens.

    Download Microsoft Network Monitor Tool from the following link and install it on the two machines.

    http://www.microsoft.com/downloads/details.aspx?displaylang=en&FamilyID=983b941d-06cb-4658-b7f6-3088333d062f

    Best Regards,

    Steven Song


    Please remember to click “Mark as Answer” on the post that helps you, and to click “Unmark as Answer” if a marked post does not actually answer your question. This can be beneficial to other community members reading the thread.

    Tuesday, December 17, 2013 1:33 AM
  • Hi,

    As per our Server guy, there was a problem with the transparent proxy (configuration got reverted back to what had been when they were testing PaloAlto).  When the configuration was put back, we were able to download the .xsl file.  Although the web pages are now loading in our development environment, we are still encountering an error on one of the pages, which is due to a .js and .xml not being cached also.  I 've asked our server guy to check again the configuration but he said that there's nothing else to check.  Although most of the client machines that we are using for testing are having the same problem, we found one machine that works. So whenever I asked our server group to check their side, they will say it's not on their side but on the client.  Our HelpDesk gave me a laptop with minimum software only VPN and IE8 but still did not work.  I have also disabled the caching on the client machine but it did not change anything.   

    I have configured all the IE settings of the client-B (not working) to be the same as the one (client-A) that works.  What I don't understand is that the IE behavior is different between the two machines.  While client-A is showing Local Intranet while accessing the webapp (as configured in IE security), Client-B is showing Trusted Site (but not configured in IE security).  I've found this article, which am trying to digest  -

    http://support.microsoft.com/kb/303650

    Both clients have IE8 but client A has build ...86337 while client B has build 86146 and other (not working) with 86893

    Thanks.

    Pacita

    Thursday, January 9, 2014 1:22 PM