none
problem in export Number field into graphical reports RRS feed

  • Question

  • I have a custom field Number1.

    I put a decimal number (italian version)  0,5

    I use Number1 inside Cost1...to make some calculations, so the number format I see that is correct.

    I use Number1 as dimension into a graphical report (to excel file).

    Into the pivot of the excel the Number1 has the "," character converted to a underscore "_"

    So 0,5 become 0_5

    0,1 become 0_1

    I need the correct format into excel because I have to do other calculations.

    thank you.

    MS Project 2013 and MS Excel 2010. Both italian version.


    Daniele.b75

    Wednesday, November 5, 2014 9:28 AM

All replies

  • Hi Daniele,

    How do you do your Excel export? Saving the file in a XLS format or creating a visual report?

    A workaround would be to write a simple macro in your Excel file:

    Sub test()
        Cells.Replace What:="_", Replacement:=",", LookAt:=xlPart, SearchOrder _
            :=xlByRows, MatchCase:=False, SearchFormat:=False, ReplaceFormat:=False
    End Sub

    But before trying this, let's try to debug your export.


    Hope this helps,


    Guillaume Rouyre, MBA, MVP, P-Seller |

    Wednesday, November 5, 2014 12:59 PM
    Moderator
  • Daniele,

    In addition to Guillaume's suggestions, also try this: change the system's setting for the decimal point symbol to period (.) temporarily and see how it goes.

    Make sure both Project and Office are updated with the latest CUs: http://technet.microsoft.com/en-us/library/dn789213(v=office.14).aspx

    If nothing works, try to pass data by copy/pasting. 

    - Ismet



    Wednesday, November 5, 2014 3:25 PM