I cant install...Anything(hardware->driver) RRS feed

  • Question


    I cant install ANY new DEVICE to my PC. My Vista is with latest updates, but i cant install any Drivers (i get ACCESS DENIED error) !!! I'm the only user, and the UAC is off, the ADMINISTRATOR acount is ON, but whatever i try i get this error--> ACCES DENIED <-- to EVERY NEW HARDWARE I INSTALL ON MY PC.

    Can anyone please help... ???


    Friday, July 25, 2008 11:26 PM


  • I've reinstalled Vista and all works now (with SP1), all drivers are installed properly, and i'm happy Big Smile


    Tuesday, August 5, 2008 2:54 PM

All replies

  • From the sound of that, your account doesn't belong to the Adminstrators group.
    For grins, try turning UAC back on.  Try to install your hardware or drivers.  When the UAC prompt comes up, select the Administrator account (and enter the password if you set one.)

    To see what group your account belongs to:
    Open User Accounts > click Manage user accounts > select your account > properties.

    What version of Vista?

    Monday, July 28, 2008 3:32 AM

    You need to make sure that you have logged into Windows Vista with the administrator account, which will provide us enough privileges to install hardware either devices or drivers. In addition, please disable any anti-virus application or firewall on the computer temporarily.


    From your problem description, I wonder which hardware driver you would like to install, for sound card, video card, USB device or something else.


    Since old driver might have some compatibility conflicts with the new Windows Vista OS, you should contact with the device vendor or upgrade the driver to the latest version from the official website. Keep the UAC open; if the system has recognized the hardware device, right-click the full-file driver installation package and select Run as administrator option.


    Test to install some other applications onto the computer except for the hardware driver to exclude the possibility that Windows installer causes the problem.


    If the problem still persists, feel free to let me know in which phase of installation you got the "ACCES DENIED" error message. At the same time, please kindly write down and upload the exact error message you have encountered for the further research.


    Have a nice day!

    Monday, July 28, 2008 10:02 AM
  • This is the problem...

    1. I'm Administrator

    2. UAC is ON (now)

    3. Devices that are not installed

    4. Tried to install my monitor BENQ FP91G+ (driver downloaded from MS update)

    5. The same error... ACCESS DENIED


    same to HDD (this driver is in VISTA) ;( .... ACCESS DENIED

    Operating System: Windows Vista™ Ultimate (6.0, Build 6001) Service Pack 1 (6001.vistasp1_gdr.080425-1930)

    Processor: Pentium 4 630 @ 3ghz

    Memory: 2046MB RAM

    DxDiag Version: 6.00.6001.18000 32bit Unicode

    Display Devices: NVIDIA GeForce 7600 GS


    And i have TV tuner  Wayjet 952 (SAA7130 TV Card) witch is the 1 UNKNOWN DEVICE, but under Vista it does not have Drivers (and thats not my problem, because its running).
    Monday, July 28, 2008 6:25 PM
  • Two more questions here:

    1. When did the issue first occur ? Were you able to install device driver properly before installing Windows Vista Service Pack 1?
    2. Do those devices work properly on your system now? I need to know the exact information of the hardware that you'd like to install (device name, manufacturer and model number).

    Then let's continue with the following instructions to troubleshoot the issue.


    Turn off the UAC and test the issue again.


    Please refer to the following KB article to delete filter drivers.
    You receive an error message if you try to install a USB device on a Windows Vista-based computer that was upgraded from Windows XP


    Uninstall the hardware in Device Manager and restart the computer.


    Re-plug these devices onto the computer physically and collect the system information.

    (Copy and paste "msinfo32.exe "(without the quotation marks) in the Start Search bar and Click Enter, save the system information to a *.NFO and upload the file to the web space or directly send it to syh009009@hotmail.com)


    If all the above steps could not work, we might try reinstalling those drivers.


    Reinstall device driver

    1. Please right-click these devices in Device Manager and select Update Driver Software.
    2. Click Browser my computer for driver software option.
    3. Click Browse button and locate the path to the C:\Windows\winsxs folder.
    4. Wait until the system finds the appropriate driver for your device.
    5. Click Close.


    Note: If Windows Vista could not search for the appropriate driver for your device, we'd better contact with hardware manufactures for help or download the latest driver from Internet.


    Tuesday, July 29, 2008 9:55 AM
  • My Win did it before sp1... but i haven't work with other devices since now... (this HDD and one USB mouse)

    Yes the devices are fine but i cant install them... i use USB mouse on my laptop and when i mention to connect her to my desktop it says access denied.

    Between in some when i tried other things like in this article : " Please refer to the following KB article to delete filter drivers. You receive an error message if you try to install a USB device on a Windows Vista-based computer that was upgraded from Windows XP http://support.microsoft.com/kb/940267"

    some keys in register says "Access denied", and i think its a permision issue.

    In msinfo32.exe doesn't show me anything (really nothing only blank screens)

    I'm thinking to reinstall Windows...

    Tuesday, July 29, 2008 5:23 PM
  • First help to confirm whether you have tried the Reinstall device driver instructions provided in the initial response, as this may be helpful in resolving this problem.


    Since your Vista OS was working properly before installing SP1, I recommend you to remove Windows Vista Service Pack 1 from the computer first to check whether the problem is SP1 related. Windows Vista SP1 is the new-released update package for OS, some devices/ software might not work well after installing SP1; for such a case, I suppose that the issue should be caused by some conflicts between some third-party device driver and Vista SP1. In addition, we might restore the system back to the point before installing the update package.


    Note: If you have some important documents or files which were created after the restore point, please backup data first if necessary.


    1.  Before we start, please close all open files and close all open programs.

    2.  Click Start; click All Programs; click Accessories; click System Tools; and click System Restore. The System Restore user interface should appear.

    3.  Click Next.

    4.  From the restore points available, select an appropriate restore point and click Next.

    5.  Click Next again. The restore process will run and your system will restart automatically.


    For more information, please refer to the article below:

    http: //windowshelp.microsoft.com/Windows/en-US/Help/9f6d755a-74bb-4a7d-a625-d762dd8e79e51033.mspx


    Meanwhile, if you don’t think that it is troublesome to format the computer and rebuild the system, I suggest reinstalling Windows Vista should be a best way to resolve such a problem. However, before doing that, we might also try the following instructions to run the System File Checker, which might help to recover the corruption of the systems files.


    1.  Click Start button, copy and paste "cmd" (without the quotation marks); in the above Programs list, right-click the cmd icon and select Run as administrator.

    2.  In the Command window, type "sfc /scannow" (without the quotation marks), and then press ENTER. NOTE: You may be prompted for your Windows vista CD-ROM. Insert the CD-ROM into the CD-ROM drive or DVD-ROM drive, and then click Retry.

    3.  After the scan has completed, remove the Windows Vista CD-ROM from the disc drive and then restart your computer.

    Wednesday, July 30, 2008 10:06 AM

    Hello, and thanks for the post, BUT maybe i can't express myself...

    I was trying to say tht my Windows DIDN'T install drivers before SP1 but i didn't pay attention to it.


    Wednesday, July 30, 2008 3:13 PM
  • We'd better go on the instructions provided in the previous post, both reinstalling device driver from C:\Windows\winsxs and running the System File Checker. If the issue still persists after performing these steps, I suppose that performing a clean install of OS should be an efferent way at the current situation. After formatting the hard disk and reinstalling Windows Vista, we will get a more stable system. Your understanding is appreciated.

    Thursday, July 31, 2008 10:06 AM
  • Yesterday i tried instructions and nothing. I'm considering to fresh install Win. Thanks for advices.
    Thursday, July 31, 2008 12:25 PM
  • Go ahead to reinstall Windows Vista and let me know the result ASAP!

    Friday, August 1, 2008 1:50 AM
  • I've reinstalled Vista and all works now (with SP1), all drivers are installed properly, and i'm happy Big Smile


    Tuesday, August 5, 2008 2:54 PM