none
SharePoint Online - Search

    Question

  • SharePoint Online - Search issue

    1. I created a search results page on a site collection to bring back content from two document libraries only. I added the refinement and search web parts to the page. 

    2. I included a query (having difficulties here) for these specific results using the following query text:

    SearchTerms, Path and FileExtensions

    3.  Initially it worked bringing back all the documents from the two libraries.

    4.  It is now breaking and only bringing back 21 of the 169 items. I made the items in one of the libraries "view only" would this be causing them not to appear in the search?

    Any help is appreciated.  Thank you.

    Friday, May 18, 2018 12:46 PM

Answers

All replies

  • Hi,

    Please check if this item has been crawled.

    You can go to CA->Search service application->Crawl log, check this item.

    Besides, you can set this item to the Read permission.

    Please try to check if this items has been set searchable.

    This is a reference about how to Enable content to be searchable.

    https://support.office.com/en-us/article/enable-content-to-be-searchable-d7ba92db-8618-43fe-87ee-adf03d973062

    Best Regards,

    Carl Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, May 22, 2018 2:52 AM
  • Hi Carl,

    Yesterday, I realized a few things, here is what I've done

    1. Changed the permissions back to read
    2. Verified that the library content has been "enabled" set to searchable (set to yes)
    3. I believe something is wrong with the query although it's bringing content back in the search from one library but not the other.

    • Marked as answer by SSeldonrs Tuesday, May 22, 2018 3:01 PM
    • Unmarked as answer by SSeldonrs Tuesday, May 22, 2018 3:01 PM
    Tuesday, May 22, 2018 1:30 PM
  • I was able to clean up the query (started over!). The search is working fine now.
    Tuesday, May 22, 2018 3:01 PM
  • Hi,

     

    If the post helps you, you can mark it as answer to help other community members to find the information quickly.

    Have a nice day!

     

    Best Regards,

    Carl Zhou


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.


    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Wednesday, May 23, 2018 1:30 AM