locked
Import csv file into calendar, description field issue RRS feed

  • Question

  • I am running Outlook 2016 16.0.9126.2152 32-bit on a Windows 10 Pro 64-bit version 1709 (OS Build 16299.371) PC.

    If I import into a calendar, a csv file (which contains 2 calendar events), the description field in the second event is not parsed correctly.

    I am expecting 3 lines to appear in the Description field for both events.

    In the first event the description correctly shows as:
    Notes line 01
    Brazil, Switzerland, Costa and Serbia
    Notes line 03

    However the second event incorrectly shows as:
    Notes line 01
    Brazil, Switzerland, Costa Rica and Serbia Notes line 03

    The linefeed character (for the 2nd line) is converted to a space character in the second event. The only difference between the 2 description fields is the second event contains Costa Rica and not Costa.

    Please can someone help or advise?

    Note: the csv file used, can be viewed/downloaded here:
    https://1drv.ms/u/s!ApV9KvaY7vuSkKVKs9wnAF9VSe3H8w

    Friday, April 20, 2018 4:05 PM

Answers

  • Thanks for the response, but the problem is not with the csv file. Thanks to the Slipstick.com website, I have discovered that the issue is with one of the Outlook 2016 Mail options.

    If I go to Outlook Options >> Mail >> Message Format and un-tick the Remove extra line breaks in plain text messages option, the import works as expected.

    Even though I am importing Calendar events, this Mail option is affecting the import.

    Monday, April 23, 2018 6:37 PM

All replies

  • Hi avant-guvnor,

    This may because the ways to break lines are not the same when preparing the csv file in Excel. Based on my test, using Alt+Enter to wrap text in a single cell can keep the format when importing to Outlook.

    Since the descriptions of the two events are the same, you may open the csv file in Excel, select I2, press Ctrl+C to copy the cell, then select I3, press Ctrl+V to paste it. Save the file and try again to import to Outlook:

    Hope this can be helpful. 

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Monday, April 23, 2018 8:50 AM
  • Thanks for the response, but the problem is not with the csv file. Thanks to the Slipstick.com website, I have discovered that the issue is with one of the Outlook 2016 Mail options.

    If I go to Outlook Options >> Mail >> Message Format and un-tick the Remove extra line breaks in plain text messages option, the import works as expected.

    Even though I am importing Calendar events, this Mail option is affecting the import.

    Monday, April 23, 2018 6:37 PM
  • Thanks for the response, but the problem is not with the csv file. Thanks to the Slipstick.com website, I have discovered that the issue is with one of the Outlook 2016 Mail options.

    If I go to Outlook Options >> Mail >> Message Format and un-tick the Remove extra line breaks in plain text messages option, the import works as expected.

    Even though I am importing Calendar events, this Mail option is affecting the import.

    Hi avant-guvnor,

    Thanks so much for sharing the resolution!

    By the way, could you please help mark your post as answer to close the thread? It will definitely be beneficial to others who might encounter a similar issue. Thanks again for your understanding and support :)

    Regards,

    Yuki Sun


    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnsf@microsoft.com.

    Click here to learn more. Visit the dedicated forum to share, explore and talk to experts about Microsoft Teams.

    Tuesday, April 24, 2018 1:29 AM