locked
Office 2013 Shell UI Language RRS feed

  • Question

  • I have some issues with the Shell UI language of Office 2013 via App-V 5.0 (SP2). The Shell UI language is German, I want it in English.

    Package was created using the latest ODT version (Office Deployment Tool for Click-to-Run, 2/25/2014).

    1. setup.exe /download Configuration_AllOffice2013.xml

    2. setup.exe /packager Configuration_AllOffice2013.xml E:\tmp\Office\AppV

    So far so good.

    But after publish (manual with Powershell), all icons are using German when using mouse-over.

    Office Tools: German.

    The UI however is English as expected (Language in Office applications).

    According to technet the first language set in configuration.xml is the default shell UI:

    “The first language determines the Shell UI culture. The Shell UI is the language of shortcuts, right-click context menus, and tooltips”.

    http://technet.microsoft.com/en-us/library/jj219426.aspx#BKMK_LanguageElement

    My configuration.xml:

    <Configuration>
    <Add SourcePath="E:\tmp\Office" OfficeClientEdition="32" >
    
    <Product ID="ProPlusVolume" >
    	<Language ID="en-us" />
    	<Language ID="nl-nl" />
    	<Language ID="de-de" />
    	<Language ID="fr-fr" />
    </Product>
    
    <Product ID="VisioStdVolume" >
    	<Language ID="en-us" />
    	<Language ID="nl-nl" />
    	<Language ID="de-de" />
    	<Language ID="fr-fr" />
    </Product>
    
    <Product ID="VisioProVolume" >
    	<Language ID="en-us" />
    	<Language ID="nl-nl" />
    	<Language ID="de-de" />
    	<Language ID="fr-fr" />
    </Product>
    
    <Product ID="ProjectStdVolume" >
    	<Language ID="en-us" />
    	<Language ID="nl-nl" />
    	<Language ID="de-de" />
    	<Language ID="fr-fr" />
    </Product>
    
    <Product ID="ProjectProVolume" >
    	<Language ID="en-us" />
    	<Language ID="nl-nl" />
    	<Language ID="de-de" />
    	<Language ID="fr-fr" />
    </Product>
    
    </Add>
    <Updates Enabled="FALSE" />
    <Display Level="None" AcceptEULA="TRUE" />
    <Logging Name="AllOffice2013_Setup.txt" Path="%temp%" />
    <Property Name="AUTOACTIVATE" Value="1" />
    </Configuration>
    

    As a workaround I can modify the DeploymentConfig.XML and change all shortcut languages +  tooltips. But I don’t believe ODT cannot generate an English Shell UI.

    Any suggestions please?

    Friday, March 21, 2014 2:01 PM

Answers

  • sorry have not played around allot yet with ODT, so did a new test with the exact same config as you posted. Guess what... same problem,
    my log also says: culture="en-us" productstoadd="ProPlusVolume_en-us_nl-nl_de-de_fr-fr_x-none"
    he also created the package like: VisioProVolume_ProPlusVolume_VisioStdVolume_ProjectStdVolume_ProjectProVolume_de-de_en-us_fr-fr_nl-nl_x86.appv.
    I tried swapping places en-us with de-de but this did not change anything. Seems to me a bug indeed in ODT.

    edit:
    ok did an other test, added the cs-cz language like:

    <Language ID="en-us"/>
    <Language ID="nl-nl"/>
    <Language ID="cs-cz"/>
    <Language ID="fr-fr"/>
    And again same issue, language is set to Czech instead of English. It seems ODT does some alphabetic order or something.

    Saturday, March 22, 2014 2:49 PM

All replies

  • This is the .appv file that ODT generates:

    VisioProVolume_ProPlusVolume_VisioStdVolume_ProjectStdVolume_ProjectProVolume_de-de_en-us_fr-fr_nl-nl_x86.appv

    DE-DE is first in line, while EN-US was first in line in the XML file.

    For simplicity I removed all Products except "ProPlusVolume", kept all four languages in my XML file.

    Logfile says: culture="en-us" productstoadd="ProPlusVolume_en-us_nl-nl_de-de_fr-fr_x-none"

    But the in the generated .appv file, DE-DE is placed first again: ProPlusVolume_de-de_en-us_fr-fr_nl-nl_x86 (and all shortcuts and tooltips in the Deployment & User XML's are German as well).

    Technet is wrong then? Or a bug in ODT?



    Friday, March 21, 2014 2:15 PM
  • Maybe it's your sourcefile? I use office en-us native with dutch languagepack. Also used click-to-run and a similar config-file, mine is default en-us and looks like:
    VisioProVolume_ProPlusVolume_VisioStdVolume_ProjectStdVolume_ProjectProVolume_en-us_nl-nl_x86.appv
    Friday, March 21, 2014 3:55 PM
  • Sources are being downloaded from Microsoft on the fly with ODT (with the /download parameter against ODT's setup.exe).

    Friday, March 21, 2014 4:12 PM
  • sorry have not played around allot yet with ODT, so did a new test with the exact same config as you posted. Guess what... same problem,
    my log also says: culture="en-us" productstoadd="ProPlusVolume_en-us_nl-nl_de-de_fr-fr_x-none"
    he also created the package like: VisioProVolume_ProPlusVolume_VisioStdVolume_ProjectStdVolume_ProjectProVolume_de-de_en-us_fr-fr_nl-nl_x86.appv.
    I tried swapping places en-us with de-de but this did not change anything. Seems to me a bug indeed in ODT.

    edit:
    ok did an other test, added the cs-cz language like:

    <Language ID="en-us"/>
    <Language ID="nl-nl"/>
    <Language ID="cs-cz"/>
    <Language ID="fr-fr"/>
    And again same issue, language is set to Czech instead of English. It seems ODT does some alphabetic order or something.

    Saturday, March 22, 2014 2:49 PM
  • Thx for the extra tests!

    Saturday, March 22, 2014 7:15 PM
  • "Fixed" by removing the German language for all Office 2013 applications, sorry to some people out there :-)
    Wednesday, March 26, 2014 1:46 PM
  • haha, full workaround would be removing all language id's above EN-US :)
    Wednesday, March 26, 2014 2:57 PM
  • Yeah, we have encouter this issue right now in customer deployment. Really annoying. And it is hard, because we need EN-US as display language and CS-CZ as proofing language.

    Will be this fixed by Microsoft sometime?

    • Edited by KazzanMVP Tuesday, October 14, 2014 2:30 PM
    Tuesday, October 14, 2014 2:26 PM
  • You could ask Microsoft support, they should know.

    Or log a support ticket?

    Tuesday, October 14, 2014 3:11 PM
  • I am asking Softies in many channels as I can to make this problém more visible to them.

    Currently normal support transfer us here, and we have open ticket at premier support as partner, but project is running and waiting to fix to next release is long...

    Tuesday, October 14, 2014 9:01 PM
  • Fix for this bug was promised to next build of ODT for Click-to-Run.
    Wednesday, February 25, 2015 3:14 PM