locked
"This action is only valid for products that are currently installed" Sequencer message RRS feed

  • Question

  • During sequencing after installing an application but before pressing the "Stop Monitoring" button I like to launch the application to apply some final settings and/or license information.

     

    The following message is displayed on a XP-sequencer and a Vista-sequencer when the application, just installed, is launched:

     

    "This action is only valid for products that are currently installed"

     

    What could be wrong?

     

     

    Monday, January 28, 2008 2:45 PM

Answers

  •  

    Are you launching from the exe or from the shortcut.  Shortcuts often aren't valid during sequencing.

     

    Matt McDermott

    Monday, January 28, 2008 7:23 PM
    Moderator
  • Try starting the application by browsing to and starting it's executable instead of using the shortcut.

     

    If this works then probably after sequencing when using the application through the SoftGrid Client the application should work through the shortcut.

     

    Regards,

    Rodney

     

    Monday, January 28, 2008 7:50 PM
    Answerer

All replies

  •  

    Are you launching from the exe or from the shortcut.  Shortcuts often aren't valid during sequencing.

     

    Matt McDermott

    Monday, January 28, 2008 7:23 PM
    Moderator
  •  

      Is there a reboot required for the app..some applications may require a reboot to replace in use files or such. By stopping the monitoring, it'll process the reboot files as if the system actually rebooted. This could affect your launch if those files aren't where they need to be. Doesn't hurt to stop monitoring and restart monitoring during your sequences.

      Final settings don't have to be configured at this stage of your sequence, you can set those later in the wizard for feature block one. Launch your app a couple of times(perferrably using the .exe from within Q:\approot\appdir as Matt mentions) and apply your licenses during the instalation phase is usually the case.  

       What application is this for, others may have sequenced it?

     

    Monday, January 28, 2008 7:45 PM
  • Try starting the application by browsing to and starting it's executable instead of using the shortcut.

     

    If this works then probably after sequencing when using the application through the SoftGrid Client the application should work through the shortcut.

     

    Regards,

    Rodney

     

    Monday, January 28, 2008 7:50 PM
    Answerer
  •  

    Yeah, I also wounder if you are starting the application trough a shortcut or by dubbel clicking on the exe file.

    If you are trying to start the application by dubbel clicking on the exe file could it be that you have an excludsion in your sequencer that you have to remove before sequencing the application?

     

    It's under Tools -> Option, tab Exclusion Items.

     

    BR

     

    Pierre

    Monday, January 28, 2008 9:09 PM
  • OK, directly executing the installed .EXE solves my problem.

     

    Tuesday, January 29, 2008 11:13 AM