locked
Registry Settings RRS feed

  • Question

  • Ok, a little information first...I am running Windowas Vista Ultimate. I play a game called ragnarok online. It uses the nProtect key encrypting software from Inca Internet Co.. After running the game and restarting my computer my USB keyboard no longer works. I have to use the on-screen keyboard to log in, open device manager, uninstall the keyboard, and reinstall it for it to work.


    When I run the game it sets 2 keys in the registry:
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\npkcrypt
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Services\npkvcryp

    In the each key there is a string entry "??\C:\Games\Gravity\RO\"

    The "??\" should not be there so I modify the string to remove them. Then I set the permissions for the key...
    (This solution works in XP for the same issue)
    1. remove the inheritance and copy current permissions
    2. set system as read-only
    3. set administrators as read-only
    4. apply...ok
    (I have tried many variations of these permissions and opened regedit using ctrl+shift+enter)

    Now I run the game, close it out, and open regedit. The permissions have reset and the string location has the "??\" again.
    It seems that Vista is resetting the permissions to the registry(or not setting them at all) and subsiquently overwriting my changes.
    BTW, I have the UAC disabled...I have to run the game as administrator anyways...

    Basically looking for a way to keep Vista from overwriting the key...or perhaps a logoff script that would merge the correct keys to the registry before shutdown (Don't know how to make one ). Any ideas?

    Thanks for any help,
       Rob

    Sunday, October 7, 2007 8:13 AM

All replies