none
Enter work hours without existing changing dates RRS feed

  • Question

  • Hi folks,

    I know this isn't how Project should be used, but...

    Our PMs created schedules with estimated predecessors and successors and start and end dates that I am not allowed to change in the current schedule.  They did not estimate work or resources other than the calculated durations when the sequences were created.  I have to now backfill resources and hours estimates without causing the existing dates to change.  It doesn't matter how over-allocated the resource ends up for the customers' purposes. This is further complicated by the fact that some of the tasks already have % complete values.

    Once the hours and resources are entered, I need to be able to set the task to Fixed Work to ensure that when the customer allows a date to shift, that the work hours will not then change.

    Oy and thanks.

    Thursday, May 9, 2013 9:09 PM

Answers

  • linearprism --
     
    Select all of the tasks in the project and change them all to Fixed Duration.  Assign resources to the tasks and ignore how overallocated they are.  Then switch the tasks back to Fixed Work or Fixed Units as needed.  I think that would meet your needs and the needs of your customer as well.  Hope this helps.
     

    Dale A. Howard [MVP]

    Thursday, May 9, 2013 11:09 PM
    Moderator

All replies

  • linearprism --
     
    Select all of the tasks in the project and change them all to Fixed Duration.  Assign resources to the tasks and ignore how overallocated they are.  Then switch the tasks back to Fixed Work or Fixed Units as needed.  I think that would meet your needs and the needs of your customer as well.  Hope this helps.
     

    Dale A. Howard [MVP]

    Thursday, May 9, 2013 11:09 PM
    Moderator
  • Hi Dale,

    Thanks for the quick reply and the suggestion.  The swap to the Fixed Duration seems to be the key to much of this, but I ran into a few wrinkles.

    I'm actually checking the impact of each change on the rest of the schedule (highly cross-linked with external projects on Project Server 2010) as I go instead of doing a bulk Fixed Duration that might tweak unrelated tasks in some way.

    I found that when doing this on an individual task, that you had to set the Fixed Duration first (choose Fixed Duration and then click OK) before attempting the other changes.  If I tried doing that with the other changes at the same time, it didn't seem to work very well.  Once the Fixed Duration was committed, the other thing I ran into on tasks with %Completes > 0 but < 100 was that I had to zero the % Complete, make the assignment and set the hours, then set back to fixed work, and then restore the original %Complete.  If I didn't zero the %Complete, things would shift around (the "Bermuda Triangle" of date, units and work) when I went back and set Fixed Work.

    Again, many thanks!  If there's any flaw in my follow-up thinking, please advise.

    Friday, May 10, 2013 6:53 PM
  • linearprism --
     
    Change all of the tasks to Fixed Duration before you make any other changes.  Then update tasks with Actual Work as needed.  Hope this helps.
     

    Dale A. Howard [MVP]

    Friday, May 10, 2013 8:07 PM
    Moderator
  • Hi Dale,

    Do you have a technique for selecting all of the tasks at once and changing them to Fixed Duration?  I can't seem to find a way to select multiple tasks (whole column CTRL-SPACEBAR, CTRL-A, or otherwise) that will allow me to change any Task Type except the first one in the selection.  The rest all remain Fixed Work.

    Thanks.

    Saturday, May 11, 2013 11:05 PM
  • Ah -- I found out how to do that -- select all of the tasks and then use the Task Information pop-up to make the setting on all of the selected tasks.  (I was trying to use the Task Details Form to do that.)

    Thanks again.

    Saturday, May 11, 2013 11:12 PM
  • linearprism --
     
    Go got it, my friend.  Way to go.  And you are more than welcome for the help.  :)
     

    Dale A. Howard [MVP]

    Sunday, May 12, 2013 11:12 PM
    Moderator