locked
stand alone set-up (newbee question) RRS feed

  • Question

  • Hello,

    i'm kind of new to the MS virtualization, and i've got some questions about it.
    Can  anyone tell me if i need to install any server if i want to use Softgrid 4.5 in stand alone mode only?

    Sunday, November 9, 2008 11:49 AM

Answers

  • Thanks for calling out the documentation bug.  I've made a not of it and sent it to the proper owners for update.

     

    Gene Ferioli

     

    Sunday, November 23, 2008 4:03 PM

All replies

  •  

    You would not need to install a Management or Streaming server if you are implementing all of the clients as Stand Alone.  In standalone, you would use a MSI based package importing, Custom SFTMIME or other scripting, or possibly an ESD solution for publishing packages and applications.

     

    There is no need to install a server.

     

    mattmcdermott

    Sunday, November 9, 2008 1:23 PM
    Moderator
  •  

    Thanks for the answer. I've had the same idea, but after sequensing the simple package to start with, i get this error:

     

    The Application Virtualization Client could not complete the operation.

    The system cannot find the path specified.


    Error code: 4505CD-14200A2A-00000003

     

    I'm trying to use msi package, so after sequencing, i go to deployment tab and set "generate msi" on.

    Protocol is set to FILE and path is set to UNC path to the network share containing all the files...

     

    Client is configured according to MS App-V  v.4.5trial Guide page 47-48

    What did i do wrong?

    Monday, November 10, 2008 12:55 PM
  • Stand Alone clients must be configured for Stand Alone usage.  Also, anything you change in the deployment tab around the path won't do anything for a Stand Alone client installing an MSI.  There are two different configurations for Stand Alone client, depending on whether or not you want to do standlone with MSI or Streaming with MSI.

     

    You would need to choose if you want to do stand alone with MSI or Streaming with MSI.  This information is available in the Application Publishing and Client Interaction whitepaper.

     

    It is located at:  http://go.microsoft.com/fwlink/?LinkId=127120

     

    Hope this helps

     

    mattmcdermott

     

     

    Monday, November 10, 2008 4:50 PM
    Moderator
  •  

    The joke is, that i've followed the guidance in the trial guide, the guide you've refernced and all others, but i was getting different errors like for example:

     

    The Application Virtualization Client could not launch Word Viewer 2003.

    The operation failed because you do not have sufficient permissions to stream from a file. Report the following error code to your System Administrator.

    Error code: 4505CD-14901C04-0000180B

     

    after breaking my head against all walls in my office, i've googled for 4505CD-14901C04-0000180B and discovered the only thread on some german forum. In short some guy suggested to set HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Client\Configuration\AllowIndependentFileStreaming to one, instead of 0, as suggested in the guidance... AND IT WORKS NOW 

    Tuesday, November 11, 2008 9:53 AM
  • I was assuming that the allowindependentfilestreaming wasn't set in your last post.  But I wanted to make sure that was the configuration you were going for.

     

    using the MSI and standalone is a little tricky at first, which is why there is a special section in the App Publishing and Client Interaction paper.

     

    Happy sequencing

     

    mattmcdermott

     

    Tuesday, November 11, 2008 12:05 PM
    Moderator
  • according to the "App Publishing and Client Interaction paper" HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\SoftGrid\4.5\Client\Configuration\AllowIndependentFileStreaming must be set to 0. and this was the reason why it wasn't working...

    any way it works now.

    Tuesday, November 11, 2008 2:43 PM
  • How are you trying to install the MSI.  If you are in StandAlone, just double-clicking on the MSI or using the SFTPath switch you do not need AllowIdenpendentFileStreaming.  If you are using MODE=Streaming with OVERRIDEURL you do need the AllowIndependentFileStreaming.

     

    Just confirmed with testing, if you are using the double-click or SFTPath make sure you are using Online=0.

     

    mattmcdermott

     

    Tuesday, November 11, 2008 3:28 PM
    Moderator
  • Thanks for calling out the documentation bug.  I've made a not of it and sent it to the proper owners for update.

     

    Gene Ferioli

     

    Sunday, November 23, 2008 4:03 PM
  • Nafanja,

     

    Could you please address Matt's question above?  How are you using the MSI?  Can you please post the syntax you were using which failed, during launch, when AllowIdenpendentFileStreaming=0?

     

    Gene Ferioli

     

    Monday, December 1, 2008 1:19 PM