none
DCOM errors in System Log on Primary Site Server RRS feed

  • Question

  • Greetings,

     

    I've been looking thru the system logs on my primary site server and I've noticed a large number of DCOM errors with the following description:

     

    The application-specific permission settings do not grant Local Launch permission for the COM Server application with CLSID {D9B257A6-C7FC-4B76-9824-599466B69D3B} to the user NT AUTHORITY\LOCAL SERVICE SID (S-1-5-19). This security permission can be modified using the Component Services administrative tool.

     

      

    I would assume I need to adjust the permissions in Component Services for the applications whose SID matches that one, however when I look in Component Services, I can't find any apps that match.

     

    Any other ideas or suggestions would be appreciated.

     

    Thanks,

    James

    Friday, July 11, 2008 1:16 PM

Answers

All replies

  • Search the registry for that SID and you should be able to identify it.

     

    Friday, July 11, 2008 1:46 PM
    Moderator
  • John,

     

    I gave that a shot and it references to DMP Datastore which contained the AppID for SMS Agent Host.

     

    I've given the Local Service account Local Launch Permissions for SMS Agent Host so we'll see how that goes.

     

    Thank You,

    James

    Friday, July 11, 2008 2:15 PM
  • I'm having same DCOM errors. James, did this worked for you? Is it OK to allow to Local Service Local Launch permission? Or is it unsafe thing to do from the security point of view?

    Thanks
    Thursday, November 19, 2009 10:14 PM