locked
Service manager exchange connector Error RRS feed

  • Question

  • Hi All,

    I am trying to install the service manager exchange connector but after importing the MP have failed to create the connector for exchange. below is the detail.

    Date: 2/8/2011 12:53:34 PM
    Application: System Center Service Manager
    Application Version: 7.0.6555.0
    Severity: Error
    Message: A required resource could not be found.

    System.IO.FileNotFoundException: Could not load file or assembly 'Microsoft.SystemCenter.ExchangeConnector' or one of its dependencies. The system cannot find the file specified.
    File name: 'Microsoft.SystemCenter.ExchangeConnector'
       at System.Reflection.Assembly._nLoad(AssemblyName fileName, String codeBase, Evidence assemblySecurity, Assembly locationHint, StackCrawlMark& stackMark, Boolean throwOnFileNotFound, Boolean forIntrospection)
       at System.Reflection.Assembly.InternalLoad(AssemblyName assemblyRef, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
       at System.Reflection.Assembly.InternalLoad(String assemblyString, Evidence assemblySecurity, StackCrawlMark& stackMark, Boolean forIntrospection)
       at System.Reflection.Assembly.Load(String assemblyString)
       at Microsoft.EnterpriseManagement.UI.SdkDataAccess.ConsoleTaskHandler.DoTask(IList`1 navigationNodes, NavigationModelNodeTask task, List`1 parameterList)
       at Microsoft.EnterpriseManagement.UI.SdkDataAccess.ConsoleTaskHandler.DoTask(IList`1 navigationNodes, NavigationModelNodeTask task)
       at Microsoft.EnterpriseManagement.ConsoleFramework.WindowJobRecord.ExecuteBackgroundJob(Object sender, ConsoleJobEventArgs eventargs)
       at Microsoft.EnterpriseManagement.ServiceManager.UI.Console.ConsoleJobExceptionHandler.ExecuteJob(IComponent component, EventHandler`1 job, Object sender, ConsoleJobEventArgs args)

    WRN: Assembly binding logging is turned OFF.
    To enable assembly bind failure logging, set the registry value [HKLM\Software\Microsoft\Fusion!EnableLog] (DWORD) to 1.
    Note: There is some performance penalty associated with assembly bind failure logging.
    To turn this feature off, remove the registry value [HKLM\Software\Microsoft\Fusion!EnableLog].

    Any suggestions.

    Cheers!!!

    Ashish

    Tuesday, February 8, 2011 8:59 AM

Answers

  • Hi Ashish,

    Did you do the following?

    1)      Copy the following files to the SCSM installation directory on the SCSM management server where you are running workflows and wherever you plan to use a console to configure the Exchange connector (example: C:\Program Files\Microsoft System Center\Service Manager 2010):

    a.       Microsoft.SystemCenter.ExchangeConnector.dll

    b.      Microsoft.Exchange.WebServices.dll   (see the Supported Environment for more information on where to get this file)

     

     

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se
    • Marked as answer by Ashish Shinde Tuesday, February 8, 2011 9:56 AM
    Tuesday, February 8, 2011 9:05 AM
  • As far as I remember right:

    You need a DNS A record for autodiscover.<your-dnsdomain> with IP from Exchange Server running the autodiscover-website.

    You are using a self-signed certificate for the IIS website of the Exchange Server?

    To check the autodiscover website: Open the IE on the SCSM Management Server and connect to https://<your-exchangeserver-FQDN>/autodiscover/autodiscover.xml

    You should get an xml page back (might be something with an error message in the xml but as long it is xml code it's ok ;-)). There should be no "certicate security warning" in IE! The SCSM Exchange connector "can't" press the option "continue" if he get's the warning. If you get a certificate security warning you have to import the SSL certificate of the Exchange Server website in the Trusted Root Certification Authorities" on the SCSM Management Server.

     

    Maybe this helps.


    Andreas Baumgarten | H&D International Group
    • Marked as answer by Ashish Shinde Friday, February 11, 2011 8:52 PM
    Wednesday, February 9, 2011 5:38 PM
  • Thanks Andreas,

    Was able to solve it. It was network issue, the server was not able to telnet on port 80 or 443.

    Regards,

    Ashish

    Friday, February 11, 2011 8:51 PM
  • Grab the PowerShell script at this blog:

    http://blogs.technet.com/servicemanager/archive/2009/12/17/deleting-objects-in-bulk-in-the-cmdb-using-powershell.aspx

    Then run

    Remove-SCSMObject.ps1 ExchangeInboxConnector and say yes to the connector you want to delete.


    Travis Wright Senior Program Manager Microsoft
    Monday, March 7, 2011 5:21 PM

All replies

  • Hi Ashish,

    Did you do the following?

    1)      Copy the following files to the SCSM installation directory on the SCSM management server where you are running workflows and wherever you plan to use a console to configure the Exchange connector (example: C:\Program Files\Microsoft System Center\Service Manager 2010):

    a.       Microsoft.SystemCenter.ExchangeConnector.dll

    b.      Microsoft.Exchange.WebServices.dll   (see the Supported Environment for more information on where to get this file)

     

     

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se
    • Marked as answer by Ashish Shinde Tuesday, February 8, 2011 9:56 AM
    Tuesday, February 8, 2011 9:05 AM
  • Thanks Andres. I forgot to add the dll files.
    • Proposed as answer by Shannon Terry Wednesday, November 23, 2011 11:56 PM
    Tuesday, February 8, 2011 9:56 AM
  • Hi Andres,

    One more query, do i have to remove the email processing option from the incident settings?

    Regards,

    Ashish

    Tuesday, February 8, 2011 10:20 AM
  • Yes, as this connector replaces that function.

    Regards
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se
    Tuesday, February 8, 2011 10:24 AM
  • Hi Andres,

    I configured the Exchange connector using the wizard, but dont find anything working. I checked the operation manager event logs and found information related to autodicovery failures. below are some of the events.

    Event ID: 33880

    Log Name:      Operations Manager
    Source:        Health Service Modules
    Date:          2/8/2011 11:23:20 PM
    Event ID:      33880
    Task Category: None
    Level:         Error
    Keywords:      Classic
    User:          N/A
    Computer:      SVR-SCSM-01.AFG.alfaraa.com
    Description:
    A Windows Workflow Foundation workflow failed during execution.
     
    Workflow Type: Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow

    Workflow Identifier: 657748e3-ea67-ebfb-dfc5-c094ae464076

    Exception Type: Microsoft.Exchange.WebServices.Data.AutodiscoverLocalException

    Exception Message: The Autodiscover service couldn't be located.

    Exception Stack:    at Microsoft.SystemCenter.ExchangeConnector.ExchangeInbox.ProcessMail()
       at Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow.Execute(ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.CompositeActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)
       at System.Workflow.Runtime.Scheduler.Run()
    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Health Service Modules" />
        <EventID Qualifiers="49152">33880</EventID>
        <Level>2</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-02-08T19:23:20.000Z" />
        <EventRecordID>42899</EventRecordID>
        <Channel>Operations Manager</Channel>
        <Computer>SVR-SCSM-01.AFG.alfaraa.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow</Data>
        <Data>657748e3-ea67-ebfb-dfc5-c094ae464076</Data>
        <Data>Microsoft.Exchange.WebServices.Data.AutodiscoverLocalException</Data>
        <Data>The Autodiscover service couldn't be located.</Data>
        <Data>   at Microsoft.SystemCenter.ExchangeConnector.ExchangeInbox.ProcessMail()
       at Microsoft.SystemCenter.ExchangeConnector.ProcessEmailsWorkflow.Execute(ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.CompositeActivityExecutor`1.Execute(T activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutor`1.Execute(Activity activity, ActivityExecutionContext executionContext)
       at System.Workflow.ComponentModel.ActivityExecutorOperation.Run(IWorkflowCoreRuntime workflowCoreRuntime)
       at System.Workflow.Runtime.Scheduler.Run()</Data>
      </EventData>
    </Event>

     


    Log Name:      Operations Manager
    Source:        Exchange Inbox Connector
    Date:          2/8/2011 11:27:59 PM
    Event ID:      0
    Task Category: None
    Level:         Information
    Keywords:      Classic
    User:          N/A
    Computer:      SVR-SCSM-01.AFG.alfaraa.com
    Description:
    AutodiscoverConfiguration: <Trace Tag="AutodiscoverConfiguration" Tid="18" Time="2011-02-08 19:27:59Z">
     failed: WebException (Unable to connect to the remote server)
    </Trace>

    Event Xml:
    <Event xmlns="http://schemas.microsoft.com/win/2004/08/events/event">
      <System>
        <Provider Name="Exchange Inbox Connector" />
        <EventID Qualifiers="0">0</EventID>
        <Level>4</Level>
        <Task>0</Task>
        <Keywords>0x80000000000000</Keywords>
        <TimeCreated SystemTime="2011-02-08T19:27:59.000Z" />
        <EventRecordID>42915</EventRecordID>
        <Channel>Operations Manager</Channel>
        <Computer>SVR-SCSM-01.AFG.alfaraa.com</Computer>
        <Security />
      </System>
      <EventData>
        <Data>AutodiscoverConfiguration: &lt;Trace Tag="AutodiscoverConfiguration" Tid="18" Time="2011-02-08 19:27:59Z"&gt;
     failed: WebException (Unable to connect to the remote server)
    &lt;/Trace&gt;
    </Data>
      </EventData>
    </Event>

    any suggestions.

    Cheers!

    Ashish

    Tuesday, February 8, 2011 8:11 PM
  • As you discovered, there is something wrong with the Autodiscover service in Exchange.

    In the documentation that comes with the Exchange connector, there is a link to a site on how to configure and troubleshoot the autodiscover service. Take a look at that.

    Rgds
    //Anders


    Anders Asp | Lumagate | www.lumagate.com | Sweden | My blog: www.scsm.se
    Tuesday, February 8, 2011 8:45 PM
  • Hi Andres,

    Thanks. I did check the document and went through the links. found that autodiscovery is working fine from the outlook client. any suggestions.

    Regards,

    Ashish

    Wednesday, February 9, 2011 10:21 AM
  • As far as I remember right:

    You need a DNS A record for autodiscover.<your-dnsdomain> with IP from Exchange Server running the autodiscover-website.

    You are using a self-signed certificate for the IIS website of the Exchange Server?

    To check the autodiscover website: Open the IE on the SCSM Management Server and connect to https://<your-exchangeserver-FQDN>/autodiscover/autodiscover.xml

    You should get an xml page back (might be something with an error message in the xml but as long it is xml code it's ok ;-)). There should be no "certicate security warning" in IE! The SCSM Exchange connector "can't" press the option "continue" if he get's the warning. If you get a certificate security warning you have to import the SSL certificate of the Exchange Server website in the Trusted Root Certification Authorities" on the SCSM Management Server.

     

    Maybe this helps.


    Andreas Baumgarten | H&D International Group
    • Marked as answer by Ashish Shinde Friday, February 11, 2011 8:52 PM
    Wednesday, February 9, 2011 5:38 PM
  • Thanks Andreas,

    Was able to solve it. It was network issue, the server was not able to telnet on port 80 or 443.

    Regards,

    Ashish

    Friday, February 11, 2011 8:51 PM
  • Hi AndersAsp;

    I have a trouble with a Exchange Connector Installation, after installed, we need it remove, when we try did it, the exchange connector stay in console view without options to delete or view propiertes, and neither can delete it because the delete option doesnt appears in console view. 

    We try to remove the management pack, but the trouble continous there, if we want to make a new connector, it work fine, but the failed connector stay there.

    How we does to delete it???

    Tuesday, February 22, 2011 9:27 PM
  • Grab the PowerShell script at this blog:

    http://blogs.technet.com/servicemanager/archive/2009/12/17/deleting-objects-in-bulk-in-the-cmdb-using-powershell.aspx

    Then run

    Remove-SCSMObject.ps1 ExchangeInboxConnector and say yes to the connector you want to delete.


    Travis Wright Senior Program Manager Microsoft
    Monday, March 7, 2011 5:21 PM
  • Hi Travis, Our Exchange conector has suddenly stopped working, when checking the Connectors the Exchange Conector has finished with errors. I have tried to edit the properties but I get the error as illustrated by other colleaues. Just to confirm your advice, I am okay to run the PowerShell script in a Live Environment, delete the exchange connector and recreate? Is this correct? Many Thanks jas
    Thursday, May 5, 2011 7:25 AM
  • Sure, but try to delete it from the UI first.
    Travis Wright Senior Program Manager Microsoft
    Thursday, May 5, 2011 1:00 PM
  • No certificate error, but I get prompted to enter crednentials, then I get the .XML view.  Why am I getting credentials prompt?

     

    Thanks,

     

    Dale

    Saturday, May 21, 2011 3:13 AM
  • Anders,

    Switched out my pc which I use to administer SCSM and your answer here saved me a lot of time and trouble figuring out why I could no longer view the properties of the Exchange Connector.  Always appreciate your assistance!

    Tuesday, July 28, 2015 4:28 PM