none
Can't Add Network Profile in WinPE

    Question

  • I am trying to add a network profile once booted into a WinPE (build Win 10 1607).  When I try to add the profile using the following command:

    netsh lan add profile filename=D:\filename.xml

    There is no such interface on the system.

    But when I do an ipconfig, it clearly lists Ethernet as the interface with a DHCP assigned address.

    Thanks for the help,

    Ross

    Monday, April 3, 2017 5:21 PM

All replies

  • Hi Ross, 

    This could be an known issue that we have feedback, because dot3svc - Error 126 starting service

    Here's the workaround to get this work for your: 

    Copy the following files from windows 10 1607 installtion into winpe:

    %windir%\l2schemas\OneX_v1.xsd %winpewindir%\l2schemas\OneX_v1.xsd
    %windir%\system32\l2gpstore.dll %winpewindir%\system32\l2gpstore.dll
    %windir%\system32\onex.dll %winpewindir%\system32\onex.dll
    %windir%\system32\en-US\onex.dll.mui %winpewindir%\system32\en-US\onex.dll.mui
    %windir%\system32\wbem\en-US\l2gpstore.mfl %winpewindir%\system32\wbem\en-US\l2gpstore.mflI hope, that Micorosft fix this error fast.


    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Tuesday, April 4, 2017 1:34 AM
    Moderator
  • Hi.

    This workaround will just help people to start the dot3svc service as this service is gone in the latest windows ADK. I am facing the same issue as Ross. Adding configuration to the nic is no longer possible. I have done this in previous versions with no problems.

    The annoying part is when you do ipconfig or netsh interface show interface, because you are then provided with the name of the interface. When you run netsh interface set interface "name_of_interface" disabled or enabled you will see that this works, but when you try to add configuration to the nic, you will receive the error "There is no interface on the system"

    I have heard that there is a new version of windows ADK coming soon. This should really be fixed in that version. If not, please provide us with a supported hotfix.

    Regards

    Thomas Alterhaug.

    Tuesday, April 4, 2017 11:22 AM
  • Thomas, thanks for confirming that its not just me!  My troubleshooting had the same results that you mentioned.

    Thanks,

    Ross

    Tuesday, April 4, 2017 4:27 PM
  • Well Ross, I guess it is testing time, this might be good news..

    Windows ADK for Windows 10, version 1703 was released yesterday.

    https://developer.microsoft.com/en-us/windows/hardware/windows-assessment-deployment-kit

    Thomas.

    Friday, April 7, 2017 11:17 AM
  • It doesn't appear that it is fixed in 1703.  Microsoft what is going?  How are we suppose to use 802.1x when we can't import a profile?

    Ross

    Thursday, April 13, 2017 8:03 PM
  • Hi All,

    Have you tried the answers in this thread??

    https://social.technet.microsoft.com/Forums/windows/en-US/289f8703-d0f4-441c-bb7e-63e71ae40b57/winpe-10-1703-and-8021x-problem-with-netsh?forum=win10itprosetup

    Download and install Windows 10 1703 Enterprise 90-day evaluation.  (I used this because as a volume license customer I can't get it until May 1.)
    Install the ADK version 1703.
    Use documentation here https://msdn.microsoft.com/en-us/windows/hardware/commercialize/manufacture/desktop/winpe-intro to create and customize a 64-bit Windows PE environment.  
    Be sure to add the dot3svc optional component using instructions in this link. https://msdn.microsoft.com/en-us/windows/hardware/commercialize/manufacture/desktop/winpe-add-packages--optional-components-reference 
    Add any network or storage drivers using the instructions in this link. https://msdn.microsoft.com/en-us/windows/hardware/commercialize/manufacture/desktop/winpe-add-drivers 
    Copy the missing DLL files required by running these commands.

    copy /Y C:\Windows\System32\authfwcfg.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\clbcatq.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\dmcmnutils.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\eapprovp.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\fwcfg.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\hnetmon.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\mdmregistration.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\nshhttp.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\nshipsec.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\onexui.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\p2p.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\p2pnetsh.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\peerdistsh.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\raschap.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\rastls.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\rmclient.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\rnr20.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\rpcnsh.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\TtlsExt.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\wcmapi.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\wcnnetsh.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\whhelper.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\wifidisplay.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\wininetlui.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\wlanapi.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\wlancfg.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\wwancfg.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\wwapi.dll C:\WinPE_amd64\mount\Windows\System32
    copy /Y C:\Windows\System32\en-US\authfwcfg.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\fwcfg.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\hnetmon.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\nshhttp.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\nshipsec.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\onexui.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\p2p.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\p2pnetsh.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\PeerDistSh.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\raschap.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\rastls.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\rpcnsh.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\TtlsExt.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    rem UIAutomationCore.dll.mui gives access denied, might have to copy it offline - it worked without it
    copy /Y C:\Windows\System32\en-US\UIAutomationCore.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\WcnNetsh.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\whhelper.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\WiFiDisplay.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\wininetlui.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\wlanapi.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\wlancfg.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US
    copy /Y C:\Windows\System32\en-US\wwancfg.dll.mui C:\WinPE_amd64\mount\Windows\System32\en-US


    Add registry entries by running the these commands.

    reg load HKLM\Mount "C:\WinPE_amd64\mount\Windows\System32\config\SOFTWARE"
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "authfwcfg" /t REG_SZ /d "authfwcfg.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "fwcfg" /t REG_SZ /d "fwcfg.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "hnetmon" /t REG_SZ /d "hnetmon.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "nshhttp" /t REG_SZ /d "nshhttp.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "nshipsec" /t REG_SZ /d "nshipsec.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "p2pnetsh" /t REG_SZ /d "p2pnetsh.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "peerdistsh" /t REG_SZ /d "peerdistsh.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "rpc" /t REG_SZ /d "rpcnsh.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "whhelper" /t REG_SZ /d "whhelper.dll" /f
    REG ADD "HKLM\Mount\Microsoft\Microsoft\NetSh" /v "wwancfg" /t REG_SZ /d "wwancfg.dll" /f
    reg unload HKLM\Mount

    Copy certutil.exe and certutil.exe.mui to a folder in your mount.  I used version 6.1.7601.18151 but apparently the one from Windows 10 1511 also works.

    Copy your XML and CER files required to connect to 802.1x.

    Unmount the image and create an ISO and/or bootable USB device.


    Boot into WinPE. 

    Run the following:

    net start dot3svc
    X:\<path to>\certutil.exe -addstore root X:\<path to>\<filename>.cer
    Netsh lan add profile filename="X:\<path to>\<filename>.xml"
    Netsh lan set eapuserdata filename=X:\<path to>\<filename>.xml allusers=yes interface="Ethernet"

    Wait approx. 60 seconds.



    Please remember to mark the replies as answers if they help.
    If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.


    Wednesday, April 26, 2017 12:53 AM
    Moderator