Problem opening Office 2007 documents using FBA RRS feed

  • Question

  • This problem has been well documented with workarounds and all but nothing worked for me.

    Problem: I have a web application that uses FBA and when users click on a doc in sharepoint library, word opens and displays nothing in windows xp sp 3, office 2007 sp2(12.0.6425.1000) machine. On win 7 sp1, office 2010 machine, I get a prompt for credentials via our login page and once I enter credentials, word displays the same login page within word document and not the actual content.

    Below are our specs:

    sharepoint server: MOSS 2007, stand alone, version in CA (sp2?), uses FBA via ADAM.

    What I tried: On xp machine I did this with no luck. Actually I couldn't find FormsBasedAuthSettings key, so I made on and created DWORD FormsAuthEnabled and set it to 1. On win 7 machine I tried this with no luck.

    Am I missing something? Please help! 

    • Edited by shazinus Wednesday, January 30, 2013 10:35 PM
    Wednesday, January 30, 2013 10:35 PM

All replies

  • Try adding the site to the trusted sites . and also change the Automatic logon using current username and password on the client machine 

    go to Central admin => application management => authentication provider

    => Select the correct web application => click on the internet zone

    => Uncheck Enable Anonymous access & select "YES" in 'Enable Client Integration'

    Also Upgrade the Server to sp3 if you can 

    Regards - Sushant Khambekar - MCTS Please Mark As Answer if my post solves your problem or Vote As Helpful if a post has been helpful for you. Sharepoint Admin - Moss 2007 , Sharepoint 2010 http://www.sharepointdirect.blogspot.com/ http://sharepointtechs.wordpress.com/

    Thursday, February 7, 2013 11:06 AM
  • I already tried the above settings and also we are on sp2 feb cu per http://jochenj.wordpress.com/versionsupdates/ Is it really dependent on SP3?
    Thursday, February 21, 2013 7:14 PM
  • Have you configures Trusted locations in Office 2007, you dont forget about a firewall ISA/IAG/UAG?

    Saturday, February 23, 2013 9:04 PM