none
Can't enable Power Query add-in

    Question

  • Having the same issue as many others it seems, and haven't found a solution posted for the issue.

    Current setup:

    - Office 365 ProPlus
    - Power Query 2.20.3945.242

    When going to File > Options > Add-Ins, Power Query doesn't appear. Selecting "COM Add-Ins" from the drop-down and clicking "Manage" doesn't show Power Query in the list of available add-ins. It's also not in the Inactive or Disabled lists. The LoadBehaviour registry key is set to 3. I've uninstalled/reinstalled both O365 & PQ several times, nothing has worked.

    Can someone please advise with a solution to this issue? I'm considering Power BI as the analytics platform for our business but if we can't run the required add-ins then it's a moot point.

    Tuesday, March 31, 2015 11:54 PM

Answers

All replies

  • Hi Conor. Could you the first two lines (i.e. the version info) from your Excel "About" dialog?

    Thanks,

    Ehren

    Monday, April 6, 2015 5:19 PM
    Owner
  • Thanks for the reply Ehren.

    Version number is as follows:

    Microsoft Office (15.0.4701.1001) MSO (15.0.4701.1000) 32-bit

    Tuesday, April 7, 2015 12:13 AM
  • Thanks, Conor. What's the full file name of the Power Query .msi installer you ran?

    Ehren

    Tuesday, April 7, 2015 8:02 PM
    Owner
  • PowerQuery_2.20.3945.242 (32-bit) [en-us].msi
    Tuesday, April 7, 2015 10:15 PM
  • Thanks. Can you see what's under the following registry locations?

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{B175BE9A-8AA3-4C11-94B9-93A270D9B034}
    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel

    Ehren

    Tuesday, April 7, 2015 11:37 PM
    Owner
  • One more:

    HKLM\SOFTWARE\Microsoft\Office\15.0\ClickToRun\REGISTRY\MACHINE\Software\Wow6432Node\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel

    Ehren



    Tuesday, April 7, 2015 11:54 PM
    Owner
  • HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{B175BE9A-8AA3-4C11-94B9-93A270D9B034}

    (Default) - Microsoft.Mashup.Client.Excel.AddIn

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{B175BE9A-8AA3-4C11-94B9-93A270D9B034}\Implemented Categories

    (Default) - NULL

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{B175BE9A-8AA3-4C11-94B9-93A270D9B034}\Implemented Categories\{62C8FE65-4EBB-45e7-B440-6E39B2CDBF29}

    (Default) - NULL

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{B175BE9A-8AA3-4C11-94B9-93A270D9B034}\InprocServer32

    (Default) - C:\Windows\SysWOW64\mscoree.dll
    Assembly - Microsoft.Mashup.Client.Excel, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
    Class - Microsoft.Mashup.Client.Excel.AddIn
    CodeBase - file:///C:\Program Files (x86)\Microsoft Power Query for Excel\bin\Microsoft.Mashup.Client.Excel.dll
    ThreadingModel - Both

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{B175BE9A-8AA3-4C11-94B9-93A270D9B034}\InprocServer32\1.0.0.0

    (Default) - NULL
    Assembly - Microsoft.Mashup.Client.Excel, Version=1.0.0.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35
    Class - Microsoft.Mashup.Client.Excel.AddIn
    CodeBase - file:///C:\Program Files (x86)\Microsoft Power Query for Excel\bin\Microsoft.Mashup.Client.Excel.dll
    RuntimeVersion - v2.0.50727
    SupportedRuntimeVersions - v4.0;v2.0.50727

    HKEY_CLASSES_ROOT\Wow6432Node\CLSID\{B175BE9A-8AA3-4C11-94B9-93A270D9B034}\ProgID

    (Default) - Microsoft.Mashup.Client.Excel

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\Microsoft\Office\Excel\Addins\Microsoft.Mashup.Client.Excel

    (Default) - NULL
    Description - Microsoft Power Query for Excel
    FriendlyName - Microsoft Power Query for Excel
    LoadBehavior - 3

    There is no Microsoft.Mashup.Client.Excel folder located at HKLM\SOFTWARE\Microsoft\Office\15.0\ClickToRun\REGISTRY\MACHINE\Software\Wow6432Node\Microsoft\Office\Excel\Addins

    Wednesday, April 8, 2015 12:10 AM
  • Hi Conor,

    Everything you provided looks okay. Could you send a screenshot of your Excel COM Add-ins dialog?

    Sorry for all the requests, but we're a bit puzzled.

    Thanks for your patience,

    Ehren

    Friday, April 10, 2015 6:48 PM
    Owner
  • http://i.imgur.com/0LkoQxK.png

    http://i.imgur.com/I6sgW2q.png

    Sunday, April 12, 2015 11:20 PM
  • Hi Conor,

    As Ehren mentioned, this is a bit of a mystery.  It seems you have all the necessary pieces.  Please note anything unusual that you think might be contributing to this situation.  Barring any contributing factors, I think we need to walk through the pieces that are linked together that make it work.

    Excel looks in the registry to find the addin, then uses the PROGID to find the COM Class, and uses the COM class to activate the module.  The connection from PROGID to CLSID is done through this key which we didn't check.  Can you display the values from your machine for this key?

    HKEY_CLASSES_ROOT\Microsoft.Mashup.Client.Excel

    Also, can you verify that the file pointed to by the CLSID entry actually exists. This one

    file:///C:\Program Files (x86)\Microsoft Power Query for Excel\bin\Microsoft.Mashup.Client.Excel.dll

    Thanks, I appreciate your help and patience.

    Monday, April 13, 2015 6:00 PM
  • No worries Jeff, appreciate yourself & Ehren looking into it.

    http://i.imgur.com/jQ7Vv7T.png - Here's the .dll file in question

    HKEY_CLASSES_ROOT\Microsoft.Mashup.Client.Excel

    (Default) - Microsoft.Mashup.Client.Excel.AddIn

    HKEY_CLASSES_ROOT\Microsoft.Mashup.Client.Excel\CLSID

    (Default) - {B175BE9A-8AA3-4C11-94B9-93A270D9B034}

    Monday, April 13, 2015 10:33 PM
  • Bummer, those look correct also. We are now looking at longer shots, but can you export these registry keys?

    • HKEY_CURRENT_USER\Software\Policies\Microsoft\Office\15.0\Excel\Resiliency

    • HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Resiliency\AddinList

    Note that the paths can look similar, but are quite different.

    Monday, April 13, 2015 11:59 PM
  • With the first key, I can get as far as HKEY_CURRENT_USER\Software\Policies\Microsoft, but there's no Office folder.

    With the second key, I can get as far as HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Resiliency, but there's no AddinList folder.

    Tuesday, April 14, 2015 12:03 AM
  • Can you please export the HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Resiliency key instead?
    Tuesday, April 14, 2015 12:14 AM
  • HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Resiliency

    (Default) - NULL

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Resiliency\DocumentRecovery

    (Default) - NULL

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Resiliency\DocumentRecovery\3E1839C7

    (Default) - NULL
    3E1839C7 - A big long grid of letters/numbers that would be a bit much to copy/paste into here.

    HKEY_CURRENT_USER\Software\Microsoft\Office\15.0\Excel\Resiliency\DocumentRecovery\3E1839F6

    (Default) - NULL
    3E1839F6 - A big long grid of letters/numbers that would be a bit much to copy/paste into here.

    Tuesday, April 14, 2015 12:17 AM
  • Thanks Conor for sticking with us. I noticed a few strange things about your COM add-ins dialog, I wonder if it's somehow related.

    • The "Location" field for the "Microsoft Power Pivot for Excel" add-in is empty
    • You are missing the "Microsoft Power Map for Excel" add-in, which should be included in the Excel that is installed as part of Office 365 ProPlus.

    Can you try enabling the "Microsoft Power Pivot for Excel" add-in, and let us know if the PowerPivot tab appears in your Excel ribbon?

    Tuesday, April 14, 2015 12:54 AM
  • Thanks for jumping in David.

    PowerPivot enabled just fine. Tab visible & features can be used.

    Tuesday, April 14, 2015 2:17 AM
  • Sorry for the inconvenience Conor, at this stage we're a little puzzled. As a last resort, would you mind trying the latest Power Query update (2.21.3974.242) and seeing if that makes a difference?
    Wednesday, April 15, 2015 2:04 AM
  • Just installed it now, the add-ins still aren't visible.
    Wednesday, April 15, 2015 2:34 AM
  • I am also having the exact same issue as Connor.  I attempt to enable Power Query and it simply won't enable.  I also ran the full Office 365 repair tool and downloaded Power Query and installed it again to no avail. I do not know exactly when this stopped working.  I haven't used Power Query for about a week.
    Thursday, April 16, 2015 2:01 PM
  • TMiq, can you please start a new thread? Sounds like the issue you are seeing is slightly different.  Please respond here with the title of the new thread and I will follow up.
    Thursday, April 16, 2015 4:08 PM
  • Hi,

    unfortunately I have the same issue with Power Query like conor has (Win 8, MSO365). FYI:

    - Day before yesterday I installed slovakian version of the PowerQuery (PowerQuery_2.20.3945.242 (32-bit) [sk-SK].MSI) - today morning it worked well.

    - however i realised I am using Excel in English bud PowerQ n SK, so I unistalled the SK version and installed the current EN version (PowerQuery_2.21.3974.242 (32-bit) [en-us].MSI) - installation was successfully finisched, however this version is not available under COM Add-In.

    - I tried also to unistal the EN version and install the Sk version from yesterday, believeing it will work. but it does NOT.

    Thanks for a solution

    Thursday, April 16, 2015 4:17 PM
  • Jeff, I posted the question under the title "Can't Enable Excel Power Query Add-in: Runtime Error?"
    Thursday, April 16, 2015 5:21 PM
  • RobertoZet, can you please open a new thread and add the title here?  I will follow up with you.

    Thursday, April 16, 2015 5:58 PM
  • Done.

    https://social.technet.microsoft.com/Forums/en-US/f7f0891c-6ea3-41a9-8db7-75e20bad307e/power-query-not-in-com-addin-after-installation?forum=powerquery

    Thursday, April 16, 2015 7:36 PM
  • Hey Conor, just had success with Robert who had a very similar situation.  Can you try these steps?

    1. Uninstall Power Query

    2. Run Repair on your Office installation

    3. Install Power Query

    -jeff

    Friday, April 17, 2015 4:48 PM
  • Just tried this with no luck.
    Monday, April 20, 2015 11:54 PM
  • Sorry, Conor, seems your issue is very unique. I am engaging the Office Excel team to see if they can help.
    Tuesday, April 21, 2015 6:09 PM
  • Conor, have you made any progress with this?

    Thanks!


    Ed Price, Azure & Power BI Customer Program Manager (Blog, Small Basic, Wiki Ninjas, Wiki)

    Answer an interesting question? Create a wiki article about it!

    Wednesday, May 6, 2015 6:22 AM
    Owner
  • Hey Ed, thanks for checking in.

    No progress since the last update, and in the interim my ProPlus trial expired so I've left it be. Our org is moving to 365 E3 in the upcoming weeks so I might revisit it then.

    Wednesday, May 6, 2015 6:25 AM
  • Hi Conor. Let us know how it goes after the O365 move.

    Ehren

    Wednesday, May 6, 2015 7:35 PM
    Owner