Error message The account password was not specified in Crawl Log RRS feed

  • Question

  • Hi,

    I got the error message: The account password was not specified. Specify the password in Crawl Log. 

    I tried the change the password of the service account in the "Content Access Account" section and do full crawl. However, the error still occurs.

    Any idea about this issue?


    Tuesday, August 27, 2019 2:31 AM

All replies

  • Hi Kit2607,

    Ensure the default content access account has right permission with the search service application and full read permission of the web application you crawled.

    Please note If you want to change the password of the default content access account in SharePoint Server, you must first change the password in AD DS, this is because the credentials that you enter for the default content access account in SharePoint Server are checked against those in AD DS.

    And you could also use the below PowerShell script to make changes to the default content access account:

    $SearchInstance = Get-SPEnterpriseSearchServiceApplication "Search Service Application name" 
    $Pwd = Read-Host -AsSecureString 
    Set-SPEnterpriseSearchServiceApplication -Identity $SearchInstance -DefaultContentAccessAccountName "Domain\user" -DefaultContentAccessAccountPassword $Pwd

    In addition, try to disable Loopback Check in IIS with below article:

    Disable Loopback Check in IIS

    Best regards,

    Grace Wang

    Please remember to mark the replies as answers if they helped. If you have feedback for TechNet Subscriber Support, contact tnmff@microsoft.com.

    SharePoint Server 2019 has been released, you can click here to download it.
    Click here to learn new features. Visit the dedicated forum to share, explore and talk to experts about SharePoint Server 2019.

    Tuesday, August 27, 2019 8:43 AM
  • Hi Grace,

    Here is the permission screen of the web application.

    Then I tried to Disable Loopback Check, but error still occurs. 

    Attached two screen for the information

    Any idea about this issue?


    Thursday, August 29, 2019 3:12 AM
  • Hi Kit2607,

    I will suggest you to take a look inside Crawl Rules. Inside crawl rules check if any of the crawl rule is using your content access account. If so then update the password there as well and start full crawl. Here is the link for your reference - 


    If the above option does not work then provision a new SSA and check it it works.


    K Mohit

    Thursday, August 29, 2019 1:36 PM
  • Just my two cents here. In my case, it was antivirus or something from the security team end that was blocking SharePoint configuration cache files to be updated, where I believe, the passwords are stored. Since, it was not being updated, causing this bad password issue.



    Thanks, Kashif

    Wednesday, June 17, 2020 5:58 AM