locked
FS4SP install on custom SQL port RRS feed

  • General discussion

  • Hello, I tried searching for similar threads but found no answer to this particular question.

    Environment details:

    All Win2k8 R2 64bit

    DB tier : SQL 2008 R2 64bit

    4x SharePoint 2010 (2xApp, 2xWFE)

    2x FAST Search Servers (if I mange to get through this issue).

     

    Basically I have a SQL cluster  (active/passive) default instance running on a custom port (50000). I've installed the FAST Search Server binaries and created the deployment.xml file.

    However, when I run through the FAST configuration wizard it keeps telling me that it is unable to connect to the SQL instance, even though I specify the instance FQDN and the port appropriately. The account I am logged in has securityadmin and dbcreator permissions on the SQL instance. I am also able to connect to the instance using the Data Sources (ODBC) tool included with Win2k8 R2. Initially I had a SQL alias configured on the FAST servers (just like I do on all the SharePoint boxes) but I took it out as I thought the config wizard didn't like it for some reason (ODBC worked just fine with it).

    Anyone have any experience installing FAST Search Server to an instance with a custom SQL port or with an Alias configured? Am I missing something painfully obvious here?

    Cheers,

    Max

    Thursday, October 7, 2010 4:43 PM

All replies

  • So I got through this - it had nothing to do with the sql aliases or connectivity, but rather permissios. Basically in step 3 of the config wizard you specify an account - ensure that THAT particular account has appropriate permissins to the DB tier and NOT the account you are logged in as.
    Friday, October 8, 2010 1:44 PM