locked
Cannot open MS Word Files in edit mode with MS Word 2010 on WSS 3.0 RRS feed

  • Question

  • Hello

    I am facinfg the following problem...

    When I try to open a Word File on a WSS 3.0 (running on W2K8 Server) with MS Word 2010 it let's me choose how to open (edit or read only), but when I choose to open the file in edit-mode word still opens it in read only mode. No option to change this.

    Environment

    Server: WSS 3.0 SP2, W2K8

    Client: Win XP SP3, MS Office 2010

    Any help appreciated !

    Thanks in advance

    MArtin

    Monday, January 10, 2011 3:27 PM

Answers

  • Hi,

     

    Please try to check if WebDAV Publishing is enabled in IIS. If yes, please try to disable WebDAV Publishing. It may be caused by the WebDAV Publishing.

     

    Let me know the result.

    Xue-Mei Chang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Xue-Mei Chang

     

    • Marked as answer by IM-consult Monday, October 24, 2011 11:24 AM
    Tuesday, January 11, 2011 8:02 AM
    Moderator
  • It sound like you have a network issue if you are getting prompted for credentials when you do explorer view.

    As for the _vti_inf.html page, put that in your broswer.  It should look like http://<yourhostheader>/_vti_inf.html

    If you get prompted for credentials there then you have somethign blocking traffic. Or you've disabled this in IIS for security. http://www.sharepoint2007security.com/guidance/firewall_rules 

    Also last place to check is SharePoint alternate access mappings page in central admin.  Make sure your http://<yourhostheader>/ is listed as a public zone and not as internal.


    Regards, Savoeurn Va Microsoft Online Community Support
    • Marked as answer by Lily Wu Monday, February 7, 2011 2:42 AM
    Monday, January 31, 2011 2:21 PM

All replies

  • Have you tried checking them out before opening them ?

    Is versioning enable on that doc lib ?

    if yes disable it and then try


    Regards, Pratik Vyas | SharePoint Consultant | http://sharepointpratik.blogspot.com/
    Monday, January 10, 2011 3:33 PM
  • Pratik,

    thanks for quick reply !!

    1. Versioning is not enabled !

    2. If I first check the document out than open it by using "Server Cache" Word opens it but it tells me that the doc is currently blocked by another person, which is DEFINITLY not is !

    3. If I check it out and use the local cache I can edit the file and can further save it, but if I close it, Word ask me to check it in. If I fill in the version comments and click OK, Word gives me an error message that tells me the file cannot be uploaded to the server.

    Hope this describes my situation good enough...

    Regards

    Martin

    PS: Option 3 also seems to log on to the server with a wrong password as afterwards my account in AD was locked !
    • Edited by IM-consult Monday, January 10, 2011 4:09 PM Additional Information
    Monday, January 10, 2011 4:01 PM
  • Hi,

     

    Please try to check if WebDAV Publishing is enabled in IIS. If yes, please try to disable WebDAV Publishing. It may be caused by the WebDAV Publishing.

     

    Let me know the result.

    Xue-Mei Chang

    TechNet Subscriber Support in forum

    If you have any feedback on our support, please contact tngfb@microsoft.com

     


    Xue-Mei Chang

     

    • Marked as answer by IM-consult Monday, October 24, 2011 11:24 AM
    Tuesday, January 11, 2011 8:02 AM
    Moderator
  • Xue-Mei Chang

    thanks for reply...

    I have checked the WebDAV settings and there where disabled. So this was already in place....

    Any other idea ?

    Regards

    Martin

    Tuesday, January 11, 2011 12:35 PM
  • Hi,

    Please follow the steps below to troubleshoot your issue:

    1. You are trying to edit the word document using which account ? What are the permission level for that particular account?

    -If that is not an Admin account please try using the admin account (both from Client and Server)

    -Is it happening for all the users?

     

    2. Are you able to create new Word Documents?

     

    3. Are you using a Host Header for youe site URL.

    -Problem appears to be WSS server is responding differently depending on the host header, and when it requires authentication it doesn't seem to take the credentials passed as being valid, although the same user authenticated with those credentials for other pages on the same web. Looks like partly a host header config issue and partly a server folder permission issue.

     

    4. Please also analyze the netmon traces to try and determine what is happening during the NTLM negotiation that is causing the failure.

    -Usually a request on a different port starts the NTLM negotiation process over as the Server believes it is talking to a different client.

     

    5.Did you repair or update your MS Office 2010 installation?

    -If yes then Search for DLL owssupp.dll (Office14 folder)

    re-register the DLL:

    (run regsvr32 /u owssupp.dll)

     


    Xue-Mei Chang
    Tuesday, January 25, 2011 2:58 AM
    Moderator
  • Hi,

    The password issue may be due to your client machine having saved the credentials.  Check the password manger in the control panel to clear those.

    On the document library it self, ensure that there are no workflows holding the file.

    Also see if you can hit: /_vti_inf.html on the site from the client machine and the server.  It should show up as blank page, but it’s really not. 


    Regards, Savoeurn Va Microsoft Online Community Support
    Friday, January 28, 2011 3:08 PM
  • Xue-Mei Chang

    1. tried --- no success and yes it happens for all users

    2. no, I am not

    3. yes, I am using a host header and I tried couple of different setups within AAM .... no success :-(

    4. will take some time....

    5. yes I did and I registered the .dll --- no success :-(

    Regards

     

    • Proposed as answer by mh53j_fe Thursday, May 16, 2013 4:43 PM
    Saturday, January 29, 2011 6:33 PM
  • Office 2010 is designed to do this by default.

    In MS Word 2010 Click File -> Options -> Trust Center -> Trust Center Settings -> ActiveX Settings and change the controls to allow editing for all Office Applications.


    Kris Wagner, MVP, MCITP, MCTS Twitter @sharepointkris Blog: http://www.sharepointkris.com/blog
    Monday, January 31, 2011 7:22 AM
    Moderator
  • Hi,

    not sure from where I should try to access _vti_inf.html...

    can you help me on that ?

    Regard

    Monday, January 31, 2011 10:54 AM
  • Kris,

    did it.... tested..... NO sucess.

    Interesting thing is, when I try to switch from standard view to explorer view WSS ask me to logon....

    Regards

    Monday, January 31, 2011 11:07 AM
  • It sound like you have a network issue if you are getting prompted for credentials when you do explorer view.

    As for the _vti_inf.html page, put that in your broswer.  It should look like http://<yourhostheader>/_vti_inf.html

    If you get prompted for credentials there then you have somethign blocking traffic. Or you've disabled this in IIS for security. http://www.sharepoint2007security.com/guidance/firewall_rules 

    Also last place to check is SharePoint alternate access mappings page in central admin.  Make sure your http://<yourhostheader>/ is listed as a public zone and not as internal.


    Regards, Savoeurn Va Microsoft Online Community Support
    • Marked as answer by Lily Wu Monday, February 7, 2011 2:42 AM
    Monday, January 31, 2011 2:21 PM
  • Savoeurn Va,

    I agree with you that I might have a misconfiguration at AAM Level. I definitly need to double check it as this comes more and more in my focus this is the troublemaker. It will take another 2 weeks (minimum) until äI can test it as I am now on another project and will be back at this customer in 2 weeks.

    Thanks for your input !

    Regards

    IM-consult

    Monday, February 7, 2011 5:25 AM
  • Solution,

    in my "special case" this issue was due to wrong configuration of the Webserver (IIS). Actually Xue-Mei Chang described it in his(her ??) answer correctly but I searched for installed WebDav components at a wrong place. In Windows Server 2008 R2 this is a feature and can be found in the "feature list", in Windows Server 2008 it was a dedicated download and is therefore to be found in control panel -> software.

    My fault was "only" to look at the feature list.

    So:

    "Xue-Mei Chang, thanks for you answer, you've been on the right track, I was to blind to find it !"

    Regards

    Martin

    Monday, October 24, 2011 11:24 AM