locked
issue with second hdd RRS feed

  • Question

  • ok I installed win7rtm on my system and all went well. installed second hdd all went well.
    after a few weeks of usage with no problem suddenly when you start the system it goes to the windows startup but before you get to sign in the screen it changes to checking d:drive for (ntfs)  it checks it and starts win7.
    once in win7 I go to my d:drive and try to use it and everything on it is ok.
    so I dont understand what's up. why is it suddenly checking the drive everytime you start the system. and why does it check it when it always turns out ok? never had a hdd do this any ideas as to what's wrong would be appreciated.
    Monday, August 31, 2009 11:28 PM

Answers

  • Hi jeniece,

    This issue may be caused by the incorrect settings on the computer. We can use the below method to test this issue:
     
    Method 1: Using CHKNTFS utility
    ========================
    1. Click the Start Button, type "cmd" (without quotation marks) in the Start Search bar.
    2. Right click on the search result listed upper and click Run as Administrator.
    3. If you want to disable check disk on C: drive, use the following command on command prompt.
     
    chkntfs /X C:
     
    If you want to disable check disk on two or more drives, just keep on adding the drives:
     
    chkntfs /X C: D: E:
     
    This will disable check disk on C, D and E drives.
     
    4. Restart the computer
     
    Method 2: Using Registry
    ========================
    1. Click the Start Button, type regedit in the "Start Search" text box and then press ENTER.
    2. Navigate to the following key:
     
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
     
    Right click the {Session Manager} entry, choose "Export", select Desktop in the Save in box and type backup in File Name. Click Save.
     
    Please Note: The backup file is on the Desktop and named backup.reg. We can simply restore the registry by double-clicking the backup.reg file.
     
    3. In the right hand pane, double click BootExecute.
    4. The default value of the key is autocheck autochk *
    5. To disable the autocheck on C: drive, change the key to
     
    autocheck autochk /k:C *
     
    If you want to add more drives, the key should look like this: (disabling C and D drives)
     
    autocheck autochk /k:C /k:D *
     
    6. Exit the registry and restart the computer.

    Hope the above information is useful for you. :)

    Candice

    • Marked as answer by Linda Yan Friday, September 4, 2009 8:06 AM
    Wednesday, September 2, 2009 7:52 AM

All replies

  • Check to see if your HDDs have bad sectors, that may be why your disk is checked at every bootup.

    Hello! Please reply back, promptly if possible with the results to solutions to your problem!

    Curious about Win7 min. system requirements?
    Readme: Older ATI, Intel onboard graphics, or NVIDIA graphics cards on Windows 7
    Windows 7 tips
    - JoelbX
    Tuesday, September 1, 2009 2:39 AM
  • no when it's done all is ok. no bad sectors,the whole drive passes everytime.
    Tuesday, September 1, 2009 5:07 AM
  • Can you go into msconfig and see if chkdsk is set to run at every boot?

    Hello! Please reply back, promptly if possible with the results to solutions to your problem!

    Curious about Win7 min. system requirements?
    Readme: Older ATI, Intel onboard graphics, or NVIDIA graphics cards on Windows 7
    Windows 7 tips
    - JoelbX
    Tuesday, September 1, 2009 2:52 PM
  • no it not set to run everytime. but I did find out that my children tried to change page file like in xp (not sure windows 7 has same feature) but they were changing things for new game and this started happening since.. so is it possible the screwed up the link to d: drive if so can I fix it without losing all my data on d:?
    wish they would ask before missing up stuff.
    Tuesday, September 1, 2009 11:34 PM
  • Hi jeniece,

    This issue may be caused by the incorrect settings on the computer. We can use the below method to test this issue:
     
    Method 1: Using CHKNTFS utility
    ========================
    1. Click the Start Button, type "cmd" (without quotation marks) in the Start Search bar.
    2. Right click on the search result listed upper and click Run as Administrator.
    3. If you want to disable check disk on C: drive, use the following command on command prompt.
     
    chkntfs /X C:
     
    If you want to disable check disk on two or more drives, just keep on adding the drives:
     
    chkntfs /X C: D: E:
     
    This will disable check disk on C, D and E drives.
     
    4. Restart the computer
     
    Method 2: Using Registry
    ========================
    1. Click the Start Button, type regedit in the "Start Search" text box and then press ENTER.
    2. Navigate to the following key:
     
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
     
    Right click the {Session Manager} entry, choose "Export", select Desktop in the Save in box and type backup in File Name. Click Save.
     
    Please Note: The backup file is on the Desktop and named backup.reg. We can simply restore the registry by double-clicking the backup.reg file.
     
    3. In the right hand pane, double click BootExecute.
    4. The default value of the key is autocheck autochk *
    5. To disable the autocheck on C: drive, change the key to
     
    autocheck autochk /k:C *
     
    If you want to add more drives, the key should look like this: (disabling C and D drives)
     
    autocheck autochk /k:C /k:D *
     
    6. Exit the registry and restart the computer.

    Hope the above information is useful for you. :)

    Candice

    • Marked as answer by Linda Yan Friday, September 4, 2009 8:06 AM
    Wednesday, September 2, 2009 7:52 AM
  • thanks for the help.I did what you said to stop chkdsk d: and alls fine.
    thanks again.
    Friday, September 4, 2009 4:53 PM
  • Hi jeniece,

    This issue may be caused by the incorrect settings on the computer. We can use the below method to test this issue:
     
    Method 1: Using CHKNTFS utility
    ========================
    1. Click the Start Button, type "cmd" (without quotation marks) in the Start Search bar.
    2. Right click on the search result listed upper and click Run as Administrator.
    3. If you want to disable check disk on C: drive, use the following command on command prompt.
     
    chkntfs /X C:
     
    If you want to disable check disk on two or more drives, just keep on adding the drives:
     
    chkntfs /X C: D: E:
     
    This will disable check disk on C, D and E drives.
     
    4. Restart the computer
     
    Method 2: Using Registry
    ========================
    1. Click the Start Button, type regedit in the "Start Search" text box and then press ENTER.
    2. Navigate to the following key:
     
    HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Session Manager
     
    Right click the {Session Manager} entry, choose "Export", select Desktop in the Save in box and type backup in File Name. Click Save.
     
    Please Note: The backup file is on the Desktop and named backup.reg. We can simply restore the registry by double-clicking the backup.reg file.
     
    3. In the right hand pane, double click BootExecute.
    4. The default value of the key is autocheck autochk *
    5. To disable the autocheck on C: drive, change the key to
     
    autocheck autochk /k:C *
     
    If you want to add more drives, the key should look like this: (disabling C and D drives)
     
    autocheck autochk /k:C /k:D *
     
    6. Exit the registry and restart the computer.

    Hope the above information is useful for you. :)

    Candice


    In my registry "autocheck autochk *" is the value but there are no disk checks. Why is there no disk checking on my system when there are no drive letters appended to the reg value per your intstructions?
    Friday, September 4, 2009 5:29 PM