locked
Windows Virtual PC not seeing my SATA DVD-RW drive RRS feed

  • Question

  • I have a PC with SATA DVD-ROM and DVD-RW drives.  The DVD-ROM has been remove from the computer to be replaced with a new unit.  My Windows Virtual PC virtual machine does not see my host SATA DVD-RW drive even though I have Integration Features running and have selected the drive letter of the DVD-RW on the host PC from the settings options.  Windows VPC only shows the default D: drive.  Two questions.  What is Windows VPC referring to with regards the default D: drive it installs  - when I load a CD or DVD, the D drive on the VPC does not see the disc.  And 2; why will it not see the SATA DVD-RW drive?  Any help would be appreciated.
    Sunday, February 14, 2010 10:27 PM

Answers

  • In the VM, your DVD/RW is just a ROM drive, you can't burn a DVD from inside the VM, UNLESS you have a USB DVD burner attached.  Internal drives on the host PC are all presented as read-only drives in a VM.

    Saturday, February 20, 2010 12:58 AM
  • 1. In the toolbar for the running virtual machine's window, go to Tools and select Settings.

    2. On the Settings dialog box, select DVD Drive.

    3. Under Access the physical drive, select an optical drive that's on the physical host machine. This makes the physical device available to the virtual machine as an emulated DVD-ROM as Steve pointed out.

    Also notice the option to select an iso file on the physical host machine. You will get much better performance using an iso file instead of physical optical media.

    If you must write to optical media, the workaround is to use software in the virtual machine to create an iso file. Copy the iso file from the vm to the physical machine or have the program write the file directly to a mapped drive on the physical machine. On the physical machine, create a DVD from the iso file.
    Monday, February 15, 2010 4:18 PM
  • What point would there be for the VM's ROM drive to access a blank CD or DVD?  It cannot write to it.
    What do you mean E: drive?  You have multiple optical drives on the host PC?
    If you have more than 1 ROM drive, you need to select the one you want to capture in the Settings.

    By default, a VM is set up with 1 hard drive (C:) and 1 optical ROM drive (D:)
    The D: drive in the VM is not necessarily the D: on the host.  Drive letters are just mappings.
    Friday, February 19, 2010 1:22 AM

All replies

  • VPC emulates all the hardware in a VM, doesn't really matter what kind of DVD drive you have installed physicall, all you get is a ROM drive.
    It's the D: drive in a VM because the VM is a different computer than your physical computer, it just has a single hard drive, the C: drive.
    Are you capturing the DVD or CD in the VM's settings?
    Monday, February 15, 2010 3:43 AM
  • 1. In the toolbar for the running virtual machine's window, go to Tools and select Settings.

    2. On the Settings dialog box, select DVD Drive.

    3. Under Access the physical drive, select an optical drive that's on the physical host machine. This makes the physical device available to the virtual machine as an emulated DVD-ROM as Steve pointed out.

    Also notice the option to select an iso file on the physical host machine. You will get much better performance using an iso file instead of physical optical media.

    If you must write to optical media, the workaround is to use software in the virtual machine to create an iso file. Copy the iso file from the vm to the physical machine or have the program write the file directly to a mapped drive on the physical machine. On the physical machine, create a DVD from the iso file.
    Monday, February 15, 2010 4:18 PM
  • Many thanks for the replies.  I understand that the D drive the VM creates is only a ROM drive.  When I insert a CD-ROM into the DVD-RW drive, both the VM's D drive and the Integration Features shows the contents of the CD.  What I need to know is why, when I insert a blank CD/DVD,  the VM cannot access the host E drive; it tells me that the parameter is incorrect and that the drive is inaccessible.
    Thursday, February 18, 2010 11:04 PM
  • What point would there be for the VM's ROM drive to access a blank CD or DVD?  It cannot write to it.
    What do you mean E: drive?  You have multiple optical drives on the host PC?
    If you have more than 1 ROM drive, you need to select the one you want to capture in the Settings.

    By default, a VM is set up with 1 hard drive (C:) and 1 optical ROM drive (D:)
    The D: drive in the VM is not necessarily the D: on the host.  Drive letters are just mappings.
    Friday, February 19, 2010 1:22 AM
  • Thanks for the reply.  I now know - being a new user of Windows VPC - that the D drive it creates is only a ROM drive.  I wanted to load RealPlayer onto XP on a VM and then burn discs to the E drive, which is my DVD-RW drive on my host PC.  RP doesn't like Windows 7.  Using Integration Features, the VM does see all my drives and and any CD/DVD-ROMs inserted into the E drive but not blank discs.  I suppose I will have to invetigate the ISO option.
    Friday, February 19, 2010 8:46 PM
  • In the VM, your DVD/RW is just a ROM drive, you can't burn a DVD from inside the VM, UNLESS you have a USB DVD burner attached.  Internal drives on the host PC are all presented as read-only drives in a VM.

    Saturday, February 20, 2010 12:58 AM
  • Many thanks.  It is the simple reply that hits the mark...
    Tuesday, February 23, 2010 4:48 PM