none
AppV 5 Add Package RRS feed

  • Question

  • I am trying to add a sequenced package for the first time from the appv management console, and there seems to be some permission issues.

    I believe I have added all the correct permissions for HVTEST2$ to the share \\HVTEST2\appv

    This is the error I get below when I try to add the package \\HVTEST2\appv\fileMaker11.appv 




    • Edited by WildHare Thursday, April 4, 2013 9:33 PM
    • Edited by Aaron.ParkerModerator Saturday, April 13, 2013 7:49 AM added App-V version to title
    Thursday, April 4, 2013 9:32 PM

Answers

  • I went to c:\appv (where the appv package resides) and right clicked on the appv folder sharing tab ->advanced permissions   -> permissions -> and added HVTEST2$

    • not sure if this what you meant Aaron, but it worked.  I can now add the package, FYI It was already shared but I did add computer group when I added it again.. not sure if this was the fix.

    But its working.. onward and upward..

    thx

    • Marked as answer by WildHare Friday, April 5, 2013 3:50 PM
    Friday, April 5, 2013 3:50 PM

All replies

  • Stange it sounds, but:

    If the Management Server and the 'content/appv' share are on the same machine, then this machine's NETWORK SERVICE needs read access.

    If the Management Server and the 'content/appv' share are on different machines, then <domain>\<machinename>$ (as you did) needs read access.

    I think the reason is that Windows is 'clever' enough to determine that one is trying to address a network resource that is hosted on the local machine (so there is no 'need' to go through the entire network communication stack, but it results in different ACLs comming into play).



    Falko

    Twitter @kirk_tn   |  Blog kirxblog   |  Web kirx.org

    Friday, April 5, 2013 7:38 AM
    Moderator
  • I could move the APPV package to a another computer (not the local machine which is same as appv server) and try that.

    But what would I need to do for sharing or read access on a "Network Services" account if I want to keep the appv package on the local machine?

    Thx,

    Dave

    Friday, April 5, 2013 2:59 PM
  • It might be worth using the advanced permissions editor interface instead - ensure you're settings the right NTFS permissions and not permissions on the share only.


    Please remember to click "Mark as Answer" or "Vote as Helpful" on the post that answers your question (or click "Unmark as Answer" if a marked post does not actually answer your question). This can be beneficial to other community members reading the thread.


    This forum post is my own opinion and does not necessarily reflect the opinion or view of my employer, Microsoft, its employees, or other MVPs.

    Twitter: @stealthpuppy | Blog: stealthpuppy.com | The Definitive Guide to Delivering Microsoft Office with App-V

    Friday, April 5, 2013 3:08 PM
    Moderator
  • I went to c:\appv (where the appv package resides) and right clicked on the appv folder sharing tab ->advanced permissions   -> permissions -> and added HVTEST2$

    • not sure if this what you meant Aaron, but it worked.  I can now add the package, FYI It was already shared but I did add computer group when I added it again.. not sure if this was the fix.

    But its working.. onward and upward..

    thx

    • Marked as answer by WildHare Friday, April 5, 2013 3:50 PM
    Friday, April 5, 2013 3:50 PM