none
Importing csv into project RRS feed

  • Question

  • Hello,

    I am trying to import a basic project.

    Name,Work,Resource_Names,Outline_Level
    PM,16 hrs,,1
    task1,8 hrs,PM1,2
    task2,8 hrs,PM1,2
    Design,400 hrs,,1
    task3,40 hrs,Person2,2
    task4,40 hrs,Person2,2
    task5,40 hrs,Person2,2
    task6,280 hrs,PM1,2

    However the work is not importing.

    I do add the work column.  but has 0 values.

    this must be simple.  Any ideas?

    thanks

    Monday, July 2, 2012 8:44 PM

Answers

  • my_drive

    If I may, I believe that you are attempting to import two different dimensions of data into project; Task data and Assignment data.  In your original post you were importing Task information (Name, Outline_Level) and Assigment information (Resource_Name, Work) in a single table.  In the second posting you include Task Name and Outline_Level (Task Information) with Work (Typically Assignment data).  Work is usually the sum of the work on task assignments (calculated at the task level).  I some quick tests, I experienced the same issues that you did.  If you change Work to Duration in your second posting entries of 80h, 80 hrs will work although this may not meet your needs.

    Hope this helps

    • Marked as answer by my_drive Thursday, July 5, 2012 2:57 PM
    Tuesday, July 3, 2012 3:54 PM

All replies

  • Is it Project 2010 ? Can you pls provide more details on your procedure ? I cannot reproduce it. --Regards.
    Monday, July 2, 2012 11:43 PM
  • As I recall, it's a type mismatch error....try just "40" or "2400" (40 X 60) to see if either work.  Make sure you're mapping it.

    As an experiment, export a real project schedule to Excel and see how the data looks....


    Andrew Lavinsky [MVP] Blog: http://azlav.umtblog.com Twitter: @alavinsky

    Tuesday, July 3, 2012 1:58 AM
    Moderator
  • my_drive --
     
    If you enter the Work as 16h, 8h, 400h, and the like, I believe you will have better results.  Hope this helps.

    Dale A. Howard [MVP]
    VP of Educational Services
    msProjectExperts
    http://www.msprojectexperts.com
    http://www.projectserverexperts.com
    "We write the books on Project Server"

    Tuesday, July 3, 2012 12:05 PM
    Moderator
  • Thanks for the input.

    I am using project 2010.  (on xp)

    The csv file I am creating with notepad.

    If my data is like this

    Outline_Level,Name,Work
    1,Initiate,
    2,Define Project, 80 h
    2,Define Project2, 8 h

    I am getting this error

    With a result of

    I have also tried 80h

    Any ideas.  Thank you

    Tuesday, July 3, 2012 2:47 PM
  • my_drive,

    Did you try exporting a sample Project file and looking at the results as Andrew suggested? Also did you try using just a numerical value for the work hours (i.e. leave off the "h")? The error message indicates you are giving it the wrong type of data (i.e. should be just a number and you are giving it a string).

    John

    Tuesday, July 3, 2012 3:06 PM
  • I really appreciate your help.  There must be something really simple.

    I tried this with no "h"

    Outline_Level,Name,Work
    1,Initiate,
    2,Define Project, 80
    2,Define Project2, 8

    In the wizard it looks ok

    But comes up blank.

    Exporting from project I get

    Name,Scheduled_Work,Outline_Level
    t1,88 hrs,1
    t2,80 hrs,2
    t3,8 hrs,2

    then reimporting

    It looks good.  But not in the workplan.

    Tuesday, July 3, 2012 3:36 PM
  • my_drive

    If I may, I believe that you are attempting to import two different dimensions of data into project; Task data and Assignment data.  In your original post you were importing Task information (Name, Outline_Level) and Assigment information (Resource_Name, Work) in a single table.  In the second posting you include Task Name and Outline_Level (Task Information) with Work (Typically Assignment data).  Work is usually the sum of the work on task assignments (calculated at the task level).  I some quick tests, I experienced the same issues that you did.  If you change Work to Duration in your second posting entries of 80h, 80 hrs will work although this may not meet your needs.

    Hope this helps

    • Marked as answer by my_drive Thursday, July 5, 2012 2:57 PM
    Tuesday, July 3, 2012 3:54 PM
  • Is it SP1 ? Have you installed the latest service pack and cumulative updates ?
    Tuesday, July 3, 2012 4:13 PM
  • OK,

    I think with Mike's help I have figured this out.

    By default on a new project I do not have the work column displayed.

    When I open a new project.  Add in the work column.  Then import into the current workplan.

    Now when I import it works fine.

    so you seem to need to have the work column displayed to make this work.  as absurd as this sounds.

    Would I guess that people who this worked for, somehow, have the work column displayed by default?

    Tuesday, July 3, 2012 4:31 PM
  • my-drive,

    I'm glad you got it figured out. Please give Mike the credit and mark this post as answered so it doesn't sit around in an "open" state.

    John

    Wednesday, July 4, 2012 2:45 AM
  • sure,

    I was just seeing if anyone would give input on the visible work column.

    thanks all

    Thursday, July 5, 2012 2:57 PM