none
Content type selection unavailable in edit mode

    Question

  • I have 2 (or more) content types created based on the 'item' content type. a simple list created with 'Allow management of content types' turned on. These content types added. These now appear in the 'new' drop list (as expected).

    The issue is that after creating a number of items based on either of these content types, now when in edit mode the content type drop option is no longer appearing.

    Going a little crazy searching for a solution, as I swear blind that this was working previously (within the last weeks Pre 21-Mar-2017).

    Any suggestions welcome.....

    Regards.


    To Add: when returning to 'Classic Mode' it is there and working as expected, so this issue is only applicable to the 'Modern' pages. It was working in the modern view previously.
    • Edited by LateNightDBA Tuesday, March 28, 2017 4:26 AM Additional comments
    Tuesday, March 28, 2017 4:13 AM

All replies

  • Its per design, modern library experience does not show the edit form. You need to click on edit properties explicitly to set the content type or any meta data associated.

    ---
    Rajesh
    rjesh.com| @rjesh
    You don't need to buy me a beer, if helpful just smile, vote, and mark it as answer.

    Tuesday, March 28, 2017 6:05 AM
  • I will say then, this is a bad design.

    Using the 'Show details', yes the content type does show along with all the other fields for this content type.

    when clicking on 'Edit All' it redirects to the EditForm.aspx not containing the content type :-(

    Issue with changing content type here in the 'details pane' is that system preforms a save directly after each and every change even when there is now required fields related to this changed content type.

    Because of this save, workflows are started without the required fields completed! Unusable.

    Please give me a solution, ie can we simply put the content type selection back on the edit form.

    Thursday, March 30, 2017 5:27 AM
  • As of now, only option is to go back to classic mode on this library. You can provide this feedback to the product team through user voice, hopefully they will implement this feature in future.

    ---
    Rajesh
    rjesh.com| @rjesh
    You don't need to buy me a beer, if helpful just smile, vote, and mark it as answer.

    Thursday, March 30, 2017 4:23 PM
  • Thanks Rajesh, I have done so.

    For those who also find this a little annoying/frustrating please add your vote to the user voice post.

    Friday, March 31, 2017 12:31 AM