locked
SharePoint running .Net 3.5 Performance Point issue RRS feed

  • Question

  • I recently changed our SharePoint 2007 Farm to run on .Net 3.5 SP1.  I have everything working except Performance Point 2007 SP2.   It was working and will work if I change the web.config back to using <add tagPrefix="asp" namespace="System.Web.UI" assembly="System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35" />.  I have Performance Point running on it's own server that is not apart of the SharePoint Farm.  .Net 3.5 is not installed on Performance Point server.   Just the SharePoint farm.   When I deploy a dashboard to SharePoint using the Performance Point master page I get an unexpected error has occurred.  

    Do I need to change something in the Performance Point Master Page to work with .Net 3.5 SP1? 
    Thursday, May 28, 2009 5:29 PM

Answers

All replies

  • Hi,

    Please try installing AJAX 1.0 from this link


    http://www.microsoft.com/downloads/details.aspx?FamilyID=ca9d90fa-e8c9-42e3-aa19-08e2c027f5d6&displaylang=en
     


    Thank you,
    Sundar - MSFT


    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, May 28, 2009 5:44 PM
  • I have AJAX installed and Performance Point has been working great for over a year now.  I just installed .Net 3.5 on my Farm and changed the web.config files to point to

    System.Web.Extensions, Version=3.5.0.0, Culture=neutral, PublicKeyToken=31BF3856AD364E35

     

    " instead of System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35.  Everything works great if I change the Web.config file back to point to System.Web.Extensions, Version=1.0.61025.0, Culture=neutral, PublicKeyToken=31bf3856ad364e35. 

    What could be causing the issue in the web.config file?   I have already check to make sure I have all the correct code in the web.config file for Performance Point so I know that is not it.  

    Could it be the Performance Point Master Page?   Do I need to edit that to get it to work with .Net 3.5? 

    Thursday, May 28, 2009 6:27 PM
  • Hi,

    I have seen this issue reinstall of AJAX 1.0 took care of the issue in certain scenarios.    In addition check from Central Admin | Operations | Solution Management | pscwebparts.cab is deployed.   If it is not there probably you need to run the Monitoring Server Configuration Manager to install DVSS (Dashboard Viewer for SharePoint Services)

    Thank you,
    Sundar - MSFT



    This posting is provided "AS IS" with no warranties, and confers no rights.
    Thursday, May 28, 2009 6:51 PM
  • You might want to take a look at this posting if you are trying to use .net 3.5 instead of 2.0 --> Performance Point Server 2007 and AJAX on SharePoint.
    Dan English's BI Blog
    _____________________________________________________
    Please mark posts as answer or helpful when they are.
    • Marked as answer by Paul Nath Monday, June 8, 2009 2:51 PM
    Friday, May 29, 2009 2:23 AM