none
maintaing the original cookie name for the client side RRS feed

  • Question

  • We have a scenario where the client side code needs to be able to access specific cookies created in the response on the server.  Tried the solutions in the advanced manual (chapter 8 Optimize Portal performance - page 356) but the cookies names are still being rewritten with the 'whalecom' prefix followed by an sequence of unknown values as far as the client side is concerned.  What's the secret to keeping the IAG from encoding specific cookies in the response to the client side?

     

    thanks

     

    we tried the following entry:

     

    <COOKIES_HANDLING>
    <SERVER>
    <SERVER_NAME mask="">www\.whalecom\.com</SERVER_NAME>
    <Set-Cookie remove="">
    <NAME>our cookie name</NAME>
    <Path remove="true">/Internal</Path>
    <Domain remove="true">.whalecom.com</Domain>
    </Set-Cookie>
    </SERVER>
    </COOKIES_HANDLING

     

    So would the server name mask (which is suppose to be the internal server name) be "www\.whalecom\.com" or "localhost" or something else?  We assume it is referring to the internal IAG server name - is that correct?

    Are the 'Path' and "Domain' entries correct?

     

    thanks

    mike

    Tuesday, October 26, 2010 11:00 PM

Answers

  • Found the solution.  The documentation states "The changes you make in the custom file are merged with the definitions
    of the file that is supplied with the system.", however that did not happen.  When I put the changes into the default template 'WhlFiltSecureRemote_HTTPS.xml' and reactivated the problem was solved. 
    Thursday, October 28, 2010 3:20 PM

All replies

  • Found the solution.  The documentation states "The changes you make in the custom file are merged with the definitions
    of the file that is supplied with the system.", however that did not happen.  When I put the changes into the default template 'WhlFiltSecureRemote_HTTPS.xml' and reactivated the problem was solved. 
    Thursday, October 28, 2010 3:20 PM
  • Hi Amigo. When adding or editing custom xml files it is necessary to mark the "apply changes made to external configuration settings" when the configuration is activated.
    // Raúl - I love this game
    Thursday, October 28, 2010 3:40 PM
  • been there done that - didn't work
    Thursday, October 28, 2010 4:02 PM